x11/kdisplay: update to 6.0.0

Changes:	https://github.com/winft/kdisplay/releases/v6.0.0
Reported by:	GitHub (watch releases)
This commit is contained in:
Jan Beich 2024-04-08 16:07:00 +02:00
parent d3293a94a0
commit d062b287b6
4 changed files with 26 additions and 73 deletions

View file

@ -1,7 +1,6 @@
PORTNAME= kdisplay
DISTVERSIONPREFIX= ${PORTNAME}@
DISTVERSION= 5.27.0
PORTREVISION= 1
DISTVERSIONPREFIX= v
DISTVERSION= 6.0.0
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
@ -13,21 +12,16 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
LICENSE_FILE_LGPL21+ = ${WRKSRC}/COPYING.LGPL
BROKEN= fails to build with disman 0.600
LIB_DEPENDS= libdisman.so:x11/disman
TEST_DEPENDS= ${qt-testlib_PORT:T}>0:${qt-testlib_PORT}
USES= cmake:testing kde:5 qt:5
USES= cmake:testing gettext-tools kde:6 qt:6
USE_GITHUB= yes
USE_KDE= ecm:build config coreaddons dbusaddons globalaccel i18n \
kcmutils kdeclarative plasma-framework xmlgui
kcmutils layer-shell-qt libplasma windowsystem xmlgui
USE_LDCONFIG= yes
USE_QT= qmake:build buildtools:build core dbus declarative gui \
sensors widgets
USE_QT= base declarative sensors
GH_ACCOUNT= winft
WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME:S/@/-/}
PLIST_SUB= VERSION=${PORTVERSION}
LDFLAGS+= -Wl,--as-needed # Qt5*, KF5*
LDFLAGS+= -Wl,--as-needed # X11, GL, KF6*
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1676648413
SHA256 (winft-kdisplay-kdisplay@5.27.0_GH0.tar.gz) = 3f22a17dcfcdaedc3dfa8104c89c17f49ecaf9dbf892e7e8c3163ca6f82f0395
SIZE (winft-kdisplay-kdisplay@5.27.0_GH0.tar.gz) = 184657
TIMESTAMP = 1712585220
SHA256 (winft-kdisplay-v6.0.0_GH0.tar.gz) = b1da715f9eb0cffb116ea9d0f756668da96848db562b4a2de5a524f321759537
SIZE (winft-kdisplay-v6.0.0_GH0.tar.gz) = 195687

View file

@ -1,39 +0,0 @@
CMake Error at /usr/local/lib/cmake/Qt5/Qt5Config.cmake:28 (find_package):
find_package for module Qt5Test called with REQUIRED, but
CMAKE_DISABLE_FIND_PACKAGE_Qt5Test is enabled. A REQUIRED package cannot
be disabled.
Call Stack (most recent call first):
CMakeLists.txt:26 (find_package)
--- CMakeLists.txt.orig 2022-06-14 20:47:09 UTC
+++ CMakeLists.txt
@@ -24,19 +24,27 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
-find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS Test Sensors)
+find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS Sensors)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
DBusAddons
Declarative
I18n
)
+find_package(Qt5Test ${QT_MIN_VERSION})
+set_package_properties(Qt5Test PROPERTIES
+ PURPOSE "Required for tests"
+ TYPE OPTIONAL
+)
+
set(MIN_DISMAN_VERSION "0.519.80")
find_package(disman ${MIN_DISMAN_VERSION} REQUIRED)
add_subdirectory(kcm)
add_subdirectory(plasma-integration)
-add_subdirectory(tests)
+if (BUILD_TESTING)
+ add_subdirectory(tests)
+endif()
install(FILES kdisplay.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})

View file

@ -1,22 +1,12 @@
bin/kdisplay
%%QT_PLUGINDIR%%/kcm_kdisplay.so
%%QT_PLUGINDIR%%/kf5/kded/kdisplayd.so
%%QT_PLUGINDIR%%/plasma/applets/plasma_applet_kdisplay.so
lib/libexec/kdisplay_osd_service
%%QT_PLUGINDIR%%/kf6/kded/kdisplayd.so
%%QT_PLUGINDIR%%/plasma/applets/org.kwinft.kdisplay.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_kdisplay.so
lib/systemd/user/plasma-kdisplay-osd.service
share/applications/kcm_kdisplay.desktop
share/applications/org.kwinft.kdisplay.desktop
share/kded_kdisplay/qml/Osd.qml
share/kded_kdisplay/qml/OsdItem.qml
share/kded_kdisplay/qml/OsdSelector.qml
share/kded_kdisplay/qml/OutputIdentifier.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/Orientation.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/Output.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/OutputIdentifier.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/OutputPanel.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/Panel.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/RotationButton.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/Screen.qml
share/kpackage/kcms/kcm_kdisplay/contents/ui/main.qml
share/kservices5/kcm_kdisplay.desktop
share/kservices5/plasma-applet-org.kwinft.kdisplay.desktop
share/dbus-1/services/org.kwinft.kdisplay.osdService.service
share/locale/de/LC_MESSAGES/kcm_kdisplay.mo
share/locale/de/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/el/LC_MESSAGES/kcm_kdisplay.mo
@ -33,15 +23,23 @@ share/locale/nb_NO/LC_MESSAGES/kcm_kdisplay.mo
share/locale/nb_NO/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/nl/LC_MESSAGES/kcm_kdisplay.mo
share/locale/nl/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/pl/LC_MESSAGES/kcm_kdisplay.mo
share/locale/pl/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/pt/LC_MESSAGES/kcm_kdisplay.mo
share/locale/pt/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/pt_BR/LC_MESSAGES/kcm_kdisplay.mo
share/locale/pt_BR/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/rm/LC_MESSAGES/kcm_kdisplay.mo
share/locale/ro/LC_MESSAGES/kcm_kdisplay.mo
share/locale/ro/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/ru/LC_MESSAGES/kcm_kdisplay.mo
share/locale/ru/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/locale/uk/LC_MESSAGES/kcm_kdisplay.mo
share/locale/uk/LC_MESSAGES/plasma_applet_org.kwinft.kdisplay.mo
share/metainfo/org.kwinft.kdisplay.appdata.xml
share/plasma/plasmoids/org.kwinft.kdisplay/contents/ui/InhibitionHint.qml
share/plasma/plasmoids/org.kwinft.kdisplay/contents/ui/PresentationModeItem.qml
share/plasma/plasmoids/org.kwinft.kdisplay/contents/ui/ScreenLayoutSelection.qml
share/plasma/plasmoids/org.kwinft.kdisplay/contents/ui/main.qml
share/plasma/plasmoids/org.kwinft.kdisplay/metadata.desktop
share/plasma/plasmoids/org.kwinft.kdisplay/metadata.json
share/qlogging-categories5/kdisplay.categories
share/qlogging-categories6/kdisplay.categories