[NEW PORT] security/spm: spm - Simple password manager

This commit is contained in:
Michael Gmelin 2020-02-08 15:03:50 +00:00
parent e5764ec79f
commit cf9dc85fc9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=525558
5 changed files with 75 additions and 0 deletions

View file

@ -1194,6 +1194,7 @@
SUBDIR += sops
SUBDIR += spass
SUBDIR += spass-qt5
SUBDIR += spm
SUBDIR += spybye
SUBDIR += sqlmap
SUBDIR += sqlninja

30
security/spm/Makefile Normal file
View file

@ -0,0 +1,30 @@
# $FreeBSD$
PORTNAME= spm
PORTVERSION= 0.20200208
CATEGORIES= security
MASTER_SITES= https://notabug.org/kl3/spm/archive/
DISTNAME= f920ab3f68
MAINTAINER= grembo@FreeBSD.org
COMMENT= Simple password manager
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= gpg2:security/gnupg \
tree:sysutils/tree
PLIST_FILES= bin/spm \
man/man1/spm.1.gz
WRKSRC= ${WRKDIR}/spm
NO_ARCH= yes
NO_BUILD= yes
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/spm.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>

3
security/spm/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1581170074
SHA256 (f920ab3f68.tar.gz) = f5f23f98fae345717e8193fe0e629fe4dbed0eec32e4813cf9d5f0c0b6616fdb
SIZE (f920ab3f68.tar.gz) = 15367

View file

@ -0,0 +1,33 @@
See:
https://notabug.org/mcz/spm/commit/8c3120fd44df117e5947d2705ba0d87443be831c.diff
--- spm.orig 2017-10-22 12:27:00 UTC
+++ spm
@@ -21,6 +21,7 @@ umask u=rwx,go=
## Variables
GPG_OPTS='--quiet --yes --batch'
STORE_DIR="${PASSWORD_STORE_DIR:-${HOME}/.spm}"
+STORE_KEY="${PASSWORD_STORE_KEY:-}"
## Helper
usage() {
@@ -41,10 +42,10 @@ check() {
}
gpg() {
- if [ -z "${PASSWORD_STORE_KEY}" ]; then
+ if [ -z "${STORE_KEY}" ]; then
gpg2 ${GPG_OPTS} --default-recipient-self "${@}"
else
- gpg2 ${GPG_OPTS} --recipient "${PASSWORD_STORE_KEY}" "${@}"
+ gpg2 ${GPG_OPTS} --recipient "${STORE_KEY}" "${@}"
fi
}
@@ -53,6 +54,7 @@ readpw() {
IFS= read -r "${2}"
[ -t 0 ] && stty echo
[ -z "${2}" ] && usage 'empty password'
+ return 0
}
find() {

8
security/spm/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
spm is a single fully POSIX shell compliant script utilizing gpg2(1) in
combination with basic tools such as find(1) and tree(1). Passwords are
stored as PGP encrypted files with directories funtioning as (sub)groups.
spm reads/writes passwords via standard input/output allowing you to build
flexible and powerful management tools. Refer to the manual page for
various examples or read its source code to see how it works.
WWW: https://notabug.org/kl3/spm