mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
science/kplib: Fix build by removing -Werror promoting a warrning to an error
Reported by: fallout
This commit is contained in:
parent
762217a6dd
commit
ced925f70c
1 changed files with 11 additions and 3 deletions
|
@ -1,8 +1,16 @@
|
|||
--- CMakeLists.txt.orig 2022-07-21 22:39:52 UTC
|
||||
- removal of -Werror is to quiet this warning promoted to error:
|
||||
- error: variable length arrays in C++ are a Clang extension [-Werror,-Wvla-cxx-extension]
|
||||
- 612 | int oppedArray[size][size];
|
||||
- | ^~~~
|
||||
|
||||
--- CMakeLists.txt.orig 2023-04-09 05:04:30 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -4,7 +4,7 @@ project(kplib)
|
||||
@@ -2,9 +2,9 @@ project(kplib)
|
||||
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror -fPIC")
|
||||
project(kplib)
|
||||
|
||||
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror -fPIC")
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -fPIC")
|
||||
set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g") # Debug mode.
|
||||
-set(CMAKE_CXX_FLAGS_RELEASE "-O3 -march=native") # Default optimization.
|
||||
+set(CMAKE_CXX_FLAGS_RELEASE "-O3") # Default optimization.
|
||||
|
|
Loading…
Add table
Reference in a new issue