mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
lang/emilua: update to 0.11.0.
PR: 284553 Reported by: maintainer
This commit is contained in:
parent
1b054ae612
commit
cec67062c8
5 changed files with 39 additions and 57 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= emilua
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.10.1
|
||||
DISTVERSION= 0.11.0
|
||||
CATEGORIES= lang devel
|
||||
|
||||
MAINTAINER= manipuladordedados@gmail.com
|
||||
|
@ -27,9 +27,6 @@ LIB_DEPENDS= libserd-0.so:devel/serd \
|
|||
|
||||
USES= localbase luajit:luajit-devel meson ncurses pathfix \
|
||||
pkgconfig ssl
|
||||
USE_GITHUB= nodefault
|
||||
GH_TUPLE= breese:trial.protocol:79149f6:trial_protocol/subprojects/trial-protocol \
|
||||
chriskohlhoff:asio:c586e95:asio/subprojects/asio
|
||||
USE_GITLAB= yes
|
||||
|
||||
CONFIGURE_ENV+= BOOST_INCLUDEDIR="${LOCALBASE}/include" \
|
||||
|
@ -40,10 +37,5 @@ MESON_ARGS= --buildtype=plain \
|
|||
-Db_pch=false \
|
||||
-Denable_manpages=true \
|
||||
-Denable_tests=true \
|
||||
-Duse_standalone_asio=true
|
||||
|
||||
post-extract:
|
||||
${CP} ${WRKSRC}/subprojects/packagefiles/trial.protocol/meson.build \
|
||||
${WRKSRC}/subprojects/trial-protocol/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,7 +1,3 @@
|
|||
TIMESTAMP = 1725313108
|
||||
SHA256 (breese-trial.protocol-79149f6_GH0.tar.gz) = ea82ba7736a2c6ae94e72587a454d3380517ed764df89e2297e6fac2acdeac03
|
||||
SIZE (breese-trial.protocol-79149f6_GH0.tar.gz) = 255698
|
||||
SHA256 (chriskohlhoff-asio-c586e95_GH0.tar.gz) = 71e2ef350996b887e25c3184a0e3f60608a00a4e650b0a7e26a8f27f43eb3253
|
||||
SIZE (chriskohlhoff-asio-c586e95_GH0.tar.gz) = 2846704
|
||||
SHA256 (emilua-v0.10.1.tar.bz2) = 4351dc0494fce71974929169ef6c35cc54efdf901c8b998427fab2054c5b858c
|
||||
SIZE (emilua-v0.10.1.tar.bz2) = 350498
|
||||
TIMESTAMP = 1738623692
|
||||
SHA256 (emilua-v0.11.0.tar.bz2) = 1a80f5527a8958c8d7ec70330ddc290ac3971cf8b21855e0cbec6d87b396dbbe
|
||||
SIZE (emilua-v0.11.0.tar.bz2) = 401194
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
From 8aa543be97491b5c061cadedfcb2162c4f88c67a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Vin=C3=ADcius=20dos=20Santos=20Oliveira?=
|
||||
<vini.ipsmaker@gmail.com>
|
||||
Date: Fri, 21 Jun 2024 15:43:25 -0300
|
||||
Subject: [PATCH] Add meson.build
|
||||
|
||||
The idea is to use the project as a subproject in meson projects.
|
||||
--- subprojects/asio/meson.build.orig 2024-09-02 23:16:53 UTC
|
||||
+++ subprojects/asio/meson.build
|
||||
@@ -0,0 +1,9 @@
|
||||
+project('asio',
|
||||
+ 'cpp',
|
||||
+ version : '1.30.2',
|
||||
+ license : 'BSL-1.0',
|
||||
+)
|
||||
+
|
||||
+asio_dep = declare_dependency(
|
||||
+ include_directories : include_directories('asio/include'),
|
||||
+)
|
|
@ -1,16 +0,0 @@
|
|||
--- test/builtin_modules1.cpp.orig 2024-09-02 21:31:27 UTC
|
||||
+++ test/builtin_modules1.cpp
|
||||
@@ -21,11 +21,9 @@ namespace fs = std::filesystem;
|
||||
namespace hana = boost::hana;
|
||||
namespace fs = std::filesystem;
|
||||
|
||||
-#if EMILUA_CONFIG_USE_STANDALONE_ASIO
|
||||
-namespace asio = ::asio;
|
||||
-#else // EMILUA_CONFIG_USE_STANDALONE_ASIO
|
||||
+#if !EMILUA_CONFIG_USE_STANDALONE_ASIO
|
||||
namespace asio = boost::asio;
|
||||
-#endif // EMILUA_CONFIG_USE_STANDALONE_ASIO
|
||||
+#endif // !EMILUA_CONFIG_USE_STANDALONE_ASIO
|
||||
|
||||
extern char** environ;
|
||||
|
|
@ -1,5 +1,6 @@
|
|||
bin/emilua
|
||||
include/emilua/actor.hpp
|
||||
include/emilua/ambient_authority.hpp
|
||||
include/emilua/asio_error.hpp
|
||||
include/emilua/async_base.hpp
|
||||
include/emilua/byte_span.hpp
|
||||
|
@ -15,12 +16,14 @@ include/emilua/filesystem.hpp
|
|||
include/emilua/future.hpp
|
||||
include/emilua/generic_error.hpp
|
||||
include/emilua/ip.hpp
|
||||
include/emilua/json.hpp
|
||||
include/emilua/libc_service.hpp
|
||||
include/emilua/lua_shim.hpp
|
||||
include/emilua/modules.re
|
||||
include/emilua/mutex.hpp
|
||||
include/emilua/native_module.hpp
|
||||
include/emilua/open_posix_libs.hpp
|
||||
include/emilua/pipe.hpp
|
||||
include/emilua/plugin.hpp
|
||||
include/emilua/proc_set_libc_service.hpp
|
||||
include/emilua/recursive_mutex.hpp
|
||||
include/emilua/regex.hpp
|
||||
include/emilua/scope_cleanup.hpp
|
||||
|
@ -33,11 +36,30 @@ include/emilua/time.hpp
|
|||
include/emilua/tls.hpp
|
||||
include/emilua/unix.hpp
|
||||
include/emilua/windows.hpp
|
||||
lib/libemilua-libc-service.so
|
||||
lib/libemilua-libc-service.so.0
|
||||
lib/libemilua-libc-service.so.0.11.0
|
||||
lib/libemilua-main.so
|
||||
lib/libemilua-main.so.0
|
||||
lib/libemilua-main.so.0.11.0
|
||||
lib/libemilua-preload-libc.so
|
||||
lib/libemilua-preload-libc.so.0
|
||||
lib/libemilua-preload-libc.so.0.11.0
|
||||
lib/libemilua.so
|
||||
lib/libemilua.so.0
|
||||
lib/libemilua.so.0.10.1
|
||||
lib/libemilua.so.0.11.0
|
||||
libdata/pkgconfig/emilua.pc
|
||||
libdata/pkgconfig/emilua_main.pc
|
||||
libdata/pkgconfig/emilua_libc_service.pc
|
||||
libdata/pkgconfig/emilua_preload_libc.pc
|
||||
libexec/emilua/emilua-genmain0
|
||||
libexec/emilua/emilua-genmods0
|
||||
libexec/emilua/emilua_gperf.awk
|
||||
libexec/emilua/errnos.awk
|
||||
libexec/emilua/luabcxxd
|
||||
libexec/emilua/normalize_path
|
||||
libexec/emilua/run_test.awk
|
||||
libexec/emilua/run_test.sh
|
||||
share/man/man1/emilua.1.gz
|
||||
share/man/man3em/asio_error.3em.gz
|
||||
share/man/man3em/byte_span.3em.gz
|
||||
|
@ -66,6 +88,8 @@ share/man/man3em/filesystem.create_symlink.3em.gz
|
|||
share/man/man3em/filesystem.current_working_directory.3em.gz
|
||||
share/man/man3em/filesystem.directory_entry.3em.gz
|
||||
share/man/man3em/filesystem.directory_iterator.3em.gz
|
||||
share/man/man3em/filesystem.dev_major.3em.gz
|
||||
share/man/man3em/filesystem.dev_minor.3em.gz
|
||||
share/man/man3em/filesystem.equivalent.3em.gz
|
||||
share/man/man3em/filesystem.exists.3em.gz
|
||||
share/man/man3em/filesystem.file_size.3em.gz
|
||||
|
@ -85,6 +109,7 @@ share/man/man3em/filesystem.mkdir.3em.gz
|
|||
share/man/man3em/filesystem.mkfifo.3em.gz
|
||||
share/man/man3em/filesystem.mknod.3em.gz
|
||||
share/man/man3em/filesystem.mode.3em.gz
|
||||
share/man/man3em/filesystem.open.3em.gz
|
||||
share/man/man3em/filesystem.path.3em.gz
|
||||
share/man/man3em/filesystem.proximate.3em.gz
|
||||
share/man/man3em/filesystem.read_symlink.3em.gz
|
||||
|
@ -115,8 +140,9 @@ share/man/man3em/ip.tcp.socket.3em.gz
|
|||
share/man/man3em/ip.toendpoint.3em.gz
|
||||
share/man/man3em/ip.tostring.3em.gz
|
||||
share/man/man3em/ip.udp.socket.3em.gz
|
||||
share/man/man3em/json.3em.gz
|
||||
share/man/man3em/json.writer.3em.gz
|
||||
share/man/man3em/libc_service.3em.gz
|
||||
share/man/man3em/libc_service.master.3em.gz
|
||||
share/man/man3em/libc_service.slave.3em.gz
|
||||
share/man/man3em/mutex.3em.gz
|
||||
share/man/man3em/pipe.pair.3em.gz
|
||||
share/man/man3em/pipe.read_stream.3em.gz
|
||||
|
@ -133,9 +159,12 @@ share/man/man3em/stream.scanner.3em.gz
|
|||
share/man/man3em/stream.write_all.3em.gz
|
||||
share/man/man3em/stream.write_at_least.3em.gz
|
||||
share/man/man3em/system.arguments.3em.gz
|
||||
share/man/man3em/system.caph_limit_stdio.3em.gz
|
||||
share/man/man3em/system.environment.3em.gz
|
||||
share/man/man3em/system.err.3em.gz
|
||||
share/man/man3em/system.exit.3em.gz
|
||||
share/man/man3em/system.get_ld_library_directories.3em.gz
|
||||
share/man/man3em/system.get_lowfd.3em.gz
|
||||
share/man/man3em/system.getgroups.3em.gz
|
||||
share/man/man3em/system.getpgid.3em.gz
|
||||
share/man/man3em/system.getpgrp.3em.gz
|
||||
|
@ -188,11 +217,11 @@ share/man/man3em/unix.stream.socket.3em.gz
|
|||
share/man/man7/emilua-alternatives.7.gz
|
||||
share/man/man7/emilua-embedding.7.gz
|
||||
share/man/man7/emilua-errors.7.gz
|
||||
share/man/man7/emilua-fiber_cancellation.7.gz
|
||||
share/man/man7/emilua-filesystem.7.gz
|
||||
share/man/man7/emilua-getting-started.7.gz
|
||||
share/man/man7/emilua-internals-sandboxes.7.gz
|
||||
share/man/man7/emilua-internals.7.gz
|
||||
share/man/man7/emilua-interruption.7.gz
|
||||
share/man/man7/emilua-linux_namespaces.7.gz
|
||||
share/man/man7/emilua-lua51.7.gz
|
||||
share/man/man7/emilua-modules.7.gz
|
||||
|
|
Loading…
Add table
Reference in a new issue