mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
biology/minimap2: Update to 2.29
A few new features and fixes Changes: https://github.com/lh3/minimap2/releases Reported by: portscout
This commit is contained in:
parent
d0be75580f
commit
cdd5a51ea0
3 changed files with 14 additions and 9 deletions
|
@ -1,7 +1,6 @@
|
|||
PORTNAME= minimap2
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.28
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2.29
|
||||
CATEGORIES= biology
|
||||
|
||||
MAINTAINER= jwb@FreeBSD.org
|
||||
|
@ -27,6 +26,8 @@ INSTALL_TARGET= install-strip
|
|||
MAKEFILE= Makefile.simde
|
||||
MAKE_ARGS= MAN1DIR=${PREFIX}/share/man/man1
|
||||
|
||||
CFLAGS+= -DHAVE_KALLOC
|
||||
|
||||
pre-build:
|
||||
${REINPLACE_CMD} -e 's|-msse4.1||g' -e 's|-msse2||g' ${WRKSRC}/Makefile.simde
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1713393837
|
||||
SHA256 (lh3-minimap2-v2.28_GH0.tar.gz) = 5ea6683b4184b5c49f6dbaef2bc5b66155e405888a0790d1b21fd3c93e474278
|
||||
SIZE (lh3-minimap2-v2.28_GH0.tar.gz) = 260341
|
||||
TIMESTAMP = 1745154104
|
||||
SHA256 (lh3-minimap2-v2.29_GH0.tar.gz) = 008d5e9848b918e4eb09d054aa3d6c272d50e92b8fc8537abf5081a507019718
|
||||
SIZE (lh3-minimap2-v2.29_GH0.tar.gz) = 269107
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Makefile.simde.orig 2021-11-18 22:11:48 UTC
|
||||
--- Makefile.simde.orig 2025-04-18 17:41:47 UTC
|
||||
+++ Makefile.simde
|
||||
@@ -1,13 +1,26 @@
|
||||
-CFLAGS= -g -Wall -O2 -Wc++-compat #-Wextra
|
||||
|
@ -15,7 +15,7 @@
|
|||
+OBJS= kthread.o kalloc.o misc.o bseq.o sketch.o sdust.o options.o \
|
||||
+ index.o lchain.o align.o hit.o map.o format.o pe.o seed.o \
|
||||
+ esterr.o splitidx.o ksw2_extz2_simde.o ksw2_extd2_simde.o \
|
||||
+ ksw2_exts2_simde.o ksw2_ll_simde.o
|
||||
+ ksw2_exts2_simde.o ksw2_ll_simde.o jump.o
|
||||
PROG= minimap2
|
||||
PROG_EXTRA= sdust minimap2-lite
|
||||
LIBS= -lm -lz -lpthread
|
||||
|
@ -32,7 +32,7 @@
|
|||
ifneq ($(arm_neon),) # if arm_neon is defined
|
||||
ifeq ($(aarch64),) #if aarch64 is not defined
|
||||
CFLAGS+=-D_FILE_OFFSET_BITS=64 -mfpu=neon -fsigned-char
|
||||
@@ -26,7 +39,7 @@ ifneq ($(tsan),)
|
||||
@@ -26,7 +39,7 @@ endif
|
||||
LIBS+=-fsanitize=thread
|
||||
endif
|
||||
|
||||
|
@ -41,9 +41,13 @@
|
|||
.SUFFIXES:.c .o
|
||||
|
||||
.c.o:
|
||||
@@ -61,6 +74,22 @@ ksw2_exts2_simde.o:ksw2_exts2_sse.c ksw2.h kalloc.h
|
||||
@@ -60,7 +73,26 @@ ksw2_exts2_simde.o:ksw2_exts2_sse.c ksw2.h kalloc.h
|
||||
ksw2_exts2_simde.o:ksw2_exts2_sse.c ksw2.h kalloc.h
|
||||
$(CC) -c $(CFLAGS) -msse4.1 $(CPPFLAGS) $(INCLUDES) $< -o $@
|
||||
|
||||
+jump.o:jump.c ksw2.h kalloc.h
|
||||
+ $(CC) -c $(CFLAGS) -msse4.1 $(CPPFLAGS) $(INCLUDES) $< -o $@
|
||||
+
|
||||
# other non-file targets
|
||||
+
|
||||
+
|
||||
|
|
Loading…
Add table
Reference in a new issue