graphics/gpsmanshp: update to 1.2.3

- Chase new home
- Define LICENSE
- Convert to USES=tcl
- Convert to USES=tar
- Convert to COPYTREE_SHARE

Changes:	http://gpsmanshp.sourceforge.net/GPSManSHP_3.html
PR:		199235
Submitted by:	tkato432@yahoo.com
This commit is contained in:
Jan Beich 2015-05-08 00:34:49 +00:00
parent d83f8f9b98
commit cabb68b96d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=385718
6 changed files with 25 additions and 54 deletions

View file

@ -2,29 +2,28 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= gpsmanshp PORTNAME= gpsmanshp
PORTVERSION= 1.2 PORTVERSION= 1.2.3
PORTREVISION= 2
CATEGORIES= graphics tcl geography CATEGORIES= graphics tcl geography
MASTER_SITES= http://www.ncc.up.pt/gpsmanshp/ MASTER_SITES= SF/${PORTNAME}/distr
DISTNAME= ${PORTNAME}_${PORTVERSION} DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org MAINTAINER= ports@FreeBSD.org
COMMENT= Shapelib support for gpsman COMMENT= Shapelib support for gpsman
BROKEN= No public distfiles LICENSE= GPLv3 # (or later)
LIB_DEPENDS= libshp.so:${PORTSDIR}/devel/shapelib
RUN_DEPENDS= gpsman:${PORTSDIR}/astro/gpsman RUN_DEPENDS= gpsman:${PORTSDIR}/astro/gpsman
LIB_DEPENDS= libshp.so:${PORTSDIR}/devel/shapelib \
libtcl${TCLVERSION:S/.//}.so:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
TCLVERSION?= 8.4 USES= tar:tgz tcl
PLIST_SUB= TCLVERSION=${TCLVERSION} PORTVERSION=${PORTVERSION} MAKE_ENV= TCLVERSION="${TCL_VER}"
PLIST_SUB= TCLVERSION="${TCL_VER}" PORTVERSION="${PORTVERSION}"
OPTIONS_DEFINE= DOCS OPTIONS_DEFINE= DOCS
post-install: post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR} (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
${INSTALL_MAN} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR} . ${STAGEDIR}${DOCSDIR} \
"! -name gpl-3_0.txt")
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (gpsmanshp_1.2.tgz) = f216332c8d42f7c6d6f3a3111835e55793e5fc562036299dd8c4ace406f30cd3 SHA256 (gpsmanshp_1.2.3.tgz) = 2803524aa8f87db6ff1eaec93cef9619c944c9aa00149e554be11f6e2f1cafd2
SIZE (gpsmanshp_1.2.tgz) = 104092 SIZE (gpsmanshp_1.2.3.tgz) = 150070

View file

@ -1,30 +1,27 @@
--- Makefile.orig Fri Jul 9 11:05:39 2004 --- Makefile.orig 2013-10-06 18:44:14 UTC
+++ Makefile Fri Jul 9 11:18:01 2004 +++ Makefile
@@ -25,11 +25,15 @@ @@ -24,12 +24,16 @@
VERSION = 1.2
TCLVERSION = 8.4 VERSION = 1.2.3
+TCLLVERSION = 84
-TCLVERSION = 8.4
+TCLVERSION ?= 8.4
+TCLLVERSION = $(TCLVERSION:S/.//)
-INSTALLDIR = /usr/lib/tcl$(TCLVERSION) -INSTALLDIR = /usr/lib/tcl$(TCLVERSION)
+INSTALLDIR = ${DESTDIR}${PREFIX}/lib/tcl$(TCLVERSION)/gpsmanshp-$(VERSION) +INSTALLDIR = ${DESTDIR}${PREFIX}/lib/tcl$(TCLVERSION)/gpsmanshp-$(VERSION)
-CFLAGS = -Wall -fPIC -c -I/usr/include/tcl$(TCLVERSION) -CFLAGS = -Wall -fPIC -c -I/usr/include/tcl$(TCLVERSION)
-LINKOPT = -lshp -ltcl$(TCLVERSION) -LINKOPT = -lshp -ltcl$(TCLVERSION)
+CFLAGS += -Wall -fPIC -c -I${PREFIX}/include/tcl$(TCLVERSION) +CFLAGS += -Wall -fPIC -c -I${LOCALBASE}/include/tcl$(TCLVERSION)
+CFLAGS += -I${PREFIX}/include +CFLAGS += -I${LOCALBASE}/include
+LINKOPT = -L${PREFIX}/lib -lshp -ltcl$(TCLLVERSION) +LINKOPT = -L${LOCALBASE}/lib -lshp -ltcl$(TCLLVERSION)
+ +
+all: pkgIndex.tcl +all: pkgIndex.tcl
gpsmanshp.so: gpsmanshp.o gpsmanshp.so: gpsmanshp.o
$(CC) -shared -o gpsmanshp.so $(LINKOPT) gpsmanshp.o $(CC) -shared -o gpsmanshp.so $(LINKOPT) gpsmanshp.o
@@ -38,12 +42,13 @@ @@ -42,8 +46,9 @@ pkgIndex.tcl: gpsmanshp.so
$(CC) $(CFLAGS) gpsmanshp.c
pkgIndex.tcl: gpsmanshp.so
- echo "source package-8.3.tcl ; pkg_mkIndex -lazy -verbose . gpsmanshp.so" | tclsh$(TCLVERSION)
+ echo "pkg_mkIndex -lazy -verbose . gpsmanshp.so" | tclsh$(TCLVERSION)
chmod 644 gpsmanshp.so pkgIndex.tcl chmod 644 gpsmanshp.so pkgIndex.tcl
install: pkgIndex.tcl install: pkgIndex.tcl

View file

@ -1,11 +0,0 @@
--- gpsmanshp.c.org Mon Jan 26 14:10:32 2004
+++ gpsmanshp.c Wed Jul 7 20:53:40 2004
@@ -65,7 +65,7 @@
#include <stdlib.h>
#include <string.h>
-#include <libshp/shapefil.h>
+#include <shapefil.h>
#include <tcl.h>
#define VERSION "1.1"

View file

@ -3,4 +3,4 @@ A Tcl Package to Read and Write Shapefiles
Gpsmanshp was developed for use in GPSMan, a manager of GPS receiver Gpsmanshp was developed for use in GPSMan, a manager of GPS receiver
data. It is written in C and is based on shapelib. data. It is written in C and is based on shapelib.
WWW: http://www.ncc.up.pt/gpsmanshp/ WWW: http://gpsmanshp.sourceforge.net/

View file

@ -1,17 +1,3 @@
lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/gpsmanshp.so lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/gpsmanshp.so
lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/pkgIndex.tcl lib/tcl%%TCLVERSION%%/gpsmanshp-%%PORTVERSION%%/pkgIndex.tcl
%%PORTDOCS%%%%DOCSDIR%%/GPL.txt
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.html
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.pdf %%PORTDOCS%%%%DOCSDIR%%/GPSManSHP.pdf
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_1.html
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_2.html
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_3.html
%%PORTDOCS%%%%DOCSDIR%%/GPSManSHP_4.html
%%PORTDOCS%%%%DOCSDIR%%/backgr.gif
%%PORTDOCS%%%%DOCSDIR%%/blank.gif
%%PORTDOCS%%%%DOCSDIR%%/gpsman-logo-small.gif
%%PORTDOCS%%%%DOCSDIR%%/newarr.gif
%%PORTDOCS%%%%DOCSDIR%%/newearr.gif
%%PORTDOCS%%%%DOCSDIR%%/next.gif
%%PORTDOCS%%%%DOCSDIR%%/previous.gif
%%PORTDOCS%%%%DOCSDIR%%/up.gif