mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
print/libmspub01: Simplify ICU fix
- Add LICENSE_FILE
This commit is contained in:
parent
3ff5f8bf41
commit
ca315094f9
3 changed files with 58 additions and 18 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= libmspub
|
||||
DISTVERSION= 0.1.4
|
||||
PORTVERSION= 0.1.4
|
||||
PORTREVISION= 24
|
||||
CATEGORIES= print graphics devel
|
||||
MASTER_SITES= LODEV/${PORTNAME}
|
||||
|
@ -10,18 +10,17 @@ COMMENT= Library and tools for parsing Microsoft Publisher file format
|
|||
WWW= https://wiki.documentfoundation.org/DLP/Libraries/libmspub
|
||||
|
||||
LICENSE= MPL20
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.MPL
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/boost/cstdint.hpp:devel/boost-libs
|
||||
LIB_DEPENDS= libicui18n.so:devel/icu \
|
||||
librevenge-0.0.so:textproc/librevenge
|
||||
|
||||
USES= autoreconf compiler:c++11-lib libtool localbase pathfix \
|
||||
pkgconfig tar:xz
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= compiler:c++11-lib libtool localbase pathfix pkgconfig tar:xz
|
||||
|
||||
CONFIGURE_ARGS= --disable-werror --without-docs
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
52
print/libmspub01/files/patch-configure
Normal file
52
print/libmspub01/files/patch-configure
Normal file
|
@ -0,0 +1,52 @@
|
|||
--- configure.orig 2018-02-28 12:02:05 UTC
|
||||
+++ configure
|
||||
@@ -18856,12 +18856,12 @@ if test -n "$ICU_CFLAGS"; then
|
||||
pkg_cv_ICU_CFLAGS="$ICU_CFLAGS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-i18n\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "icu-i18n") 2>&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-i18n icu-uc\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "icu-i18n icu-uc") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_ICU_CFLAGS=`$PKG_CONFIG --cflags "icu-i18n" 2>/dev/null`
|
||||
+ pkg_cv_ICU_CFLAGS=`$PKG_CONFIG --cflags "icu-i18n icu-uc" 2>/dev/null`
|
||||
test "x$?" != "x0" && pkg_failed=yes
|
||||
else
|
||||
pkg_failed=yes
|
||||
@@ -18873,12 +18873,12 @@ if test -n "$ICU_LIBS"; then
|
||||
pkg_cv_ICU_LIBS="$ICU_LIBS"
|
||||
elif test -n "$PKG_CONFIG"; then
|
||||
if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-i18n\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "icu-i18n") 2>&5
|
||||
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-i18n icu-uc\""; } >&5
|
||||
+ ($PKG_CONFIG --exists --print-errors "icu-i18n icu-uc") 2>&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
test $ac_status = 0; }; then
|
||||
- pkg_cv_ICU_LIBS=`$PKG_CONFIG --libs "icu-i18n" 2>/dev/null`
|
||||
+ pkg_cv_ICU_LIBS=`$PKG_CONFIG --libs "icu-i18n icu-uc" 2>/dev/null`
|
||||
test "x$?" != "x0" && pkg_failed=yes
|
||||
else
|
||||
pkg_failed=yes
|
||||
@@ -18899,14 +18899,14 @@ fi
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- ICU_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "icu-i18n" 2>&1`
|
||||
+ ICU_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "icu-i18n icu-uc" 2>&1`
|
||||
else
|
||||
- ICU_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "icu-i18n" 2>&1`
|
||||
+ ICU_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "icu-i18n icu-uc" 2>&1`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$ICU_PKG_ERRORS" >&5
|
||||
|
||||
- as_fn_error $? "Package requirements (icu-i18n) were not met:
|
||||
+ as_fn_error $? "Package requirements (icu-i18n icu-uc) were not met:
|
||||
|
||||
$ICU_PKG_ERRORS
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.ac.orig 2025-01-04 20:17:51 UTC
|
||||
+++ configure.ac
|
||||
@@ -104,7 +104,7 @@ AC_CHECK_HEADERS(
|
||||
# ========
|
||||
# Find icu
|
||||
# ========
|
||||
-PKG_CHECK_MODULES([ICU], [icu-i18n])
|
||||
+PKG_CHECK_MODULES([ICU], [icu-i18n icu-uc])
|
||||
AC_SUBST(ICU_CFLAGS)
|
||||
AC_SUBST(ICU_LIBS)
|
||||
|
Loading…
Add table
Reference in a new issue