MultiGet is an easy-to-use GUI file downloader for Linux/Unix/BSDs/Windows.

It's programmed by C++ and GUI is based on wxWidgets. It supports http/ftp
protocol which covers most user's requirement. It supports multi-task with
multi-thread on multi-server. It supports resume download if server side have
resume feature, and if you like, you can reconfig the thread number without
stopping the going task. It's also support SOCKS 4, 4a, 5 proxy, ftp proxy,
http proxy.

WWW: http://multiget.sourceforge.net/
This commit is contained in:
Alejandro Pulver 2006-12-07 18:01:00 +00:00
parent 28fe8e4844
commit c6d1ed1b58
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179135
5 changed files with 66 additions and 0 deletions

View file

@ -59,6 +59,7 @@
SUBDIR += mirror
SUBDIR += moftpd
SUBDIR += muddleftpd
SUBDIR += multiget
SUBDIR += ncftp
SUBDIR += ncftp2
SUBDIR += ncftp3

43
ftp/multiget/Makefile Normal file
View file

@ -0,0 +1,43 @@
# New ports collection makefile for: multiget
# Date created: 2006-11-03
# Whom: alepulver
#
# $FreeBSD$
#
PORTNAME= multiget
PORTVERSION= 1.0
CATEGORIES= ftp www
MASTER_SITES= SF
DISTNAME= ${PORTNAME}${PORTVERSION}.src
MAINTAINER= alepulver@FreeBSD.org
COMMENT= An http/ftp downloader with a nice GUI
USE_BZIP2= yes
USE_WX= 2.6
MAKEFILE= makefile
ALL_TARGET= MultiGet
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/src
PLIST_FILES= bin/${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e \
's|g++|${CXX}|; \
s|\(CFLAGS\) =|\1 +=|; \
s|wx-config|${WX_CONFIG}|' \
${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -Ee 's,(fopen|ftruncate)64,\1,' \
${WRKSRC}/mgfilemanager.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/MultiGet ${PREFIX}/bin/${PORTNAME}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
IGNORE= does not build
.endif
.include <bsd.port.post.mk>

3
ftp/multiget/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (multiget1.0.src.tar.bz2) = a30f15408079289e49ad0ea249075261
SHA256 (multiget1.0.src.tar.bz2) = 2cfeca1fe2833db678505f1a318fc1d32f8f09b2da141b0739a1b9456505f493
SIZE (multiget1.0.src.tar.bz2) = 577376

View file

@ -0,0 +1,10 @@
--- ./mgsocket.h.orig Sat Nov 4 05:04:00 2006
+++ ./mgsocket.h Wed Dec 6 14:02:01 2006
@@ -30,6 +30,7 @@
#else
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <arpa/inet.h>
#include <unistd.h>
#include <sys/un.h>

9
ftp/multiget/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
MultiGet is an easy-to-use GUI file downloader for Linux/Unix/BSDs/Windows.
It's programmed by C++ and GUI is based on wxWidgets. It supports http/ftp
protocol which covers most user's requirement. It supports multi-task with
multi-thread on multi-server. It supports resume download if server side have
resume feature, and if you like, you can reconfig the thread number without
stopping the going task. It's also support SOCKS 4, 4a, 5 proxy, ftp proxy,
http proxy.
WWW: http://multiget.sourceforge.net/