mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
x11-wm/wmakerconf: undeprecate the port, assume maintainership
- Drop unused run-time dependency on `archivers/rpm4' and bogus CONFIGURE_ARGS (esp. --with-wmakeretcprefix=${LOCALBASE}/share which is plain wrong), trim some vertical whitespace - Fix getstyle(1) program invocation and actually capture its output; this also gets rid of the segmentation fault on exit - Limit the scope of the WMWritePropListToFile() calls patching so it only touches needed files
This commit is contained in:
parent
051c93eb76
commit
c5eaec4c72
2 changed files with 15 additions and 15 deletions
|
@ -1,38 +1,28 @@
|
|||
PORTNAME= wmakerconf
|
||||
PORTVERSION= 2.12
|
||||
PORTREVISION= 12
|
||||
PORTREVISION= 13
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= danfe@FreeBSD.org
|
||||
COMMENT= Configuration tool for Window Maker
|
||||
WWW= https://sourceforge.net/projects/wmakerconf/
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
DEPRECATED= Last upstream release was in 2007
|
||||
EXPIRATION_DATE= 2024-01-17
|
||||
|
||||
LIB_DEPENDS= \
|
||||
libWINGs.so:x11-wm/windowmaker \
|
||||
LIB_DEPENDS= libWINGs.so:x11-wm/windowmaker \
|
||||
libharfbuzz.so:print/harfbuzz \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libwraster.so:x11-wm/libwraster
|
||||
RUN_DEPENDS= rpm:archivers/rpm4
|
||||
|
||||
USES= gettext pkgconfig perl5 gmake gnome localbase shebangfix xorg
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk20
|
||||
USE_XORG= x11
|
||||
|
||||
SHEBANG_FILES= scripts/getfile.pl.in scripts/upgrade.pl.in
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-wmakerdataprefix="${LOCALBASE}/share" \
|
||||
--with-wmakeretcprefix="${LOCALBASE}/share"
|
||||
|
||||
LIBS= -lintl -lX11 -lWUtil
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
@ -53,7 +43,8 @@ post-patch:
|
|||
.for file in data/po/ja.po po/ja.po
|
||||
@${REINPLACE_CMD} -e 's|JISX-0208-1983-0|euc-jp|g' ${WRKSRC}/${file}
|
||||
.endfor
|
||||
@${FIND} ${WRKSRC}/src -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
'/WMWritePropListToFile/s|,[[:space:]]YES||g'
|
||||
@${REINPLACE_CMD} -e '/WMWritePropListToFile/s|,[[:space:]]YES||' \
|
||||
${WRKSRC}/src/menu.c ${WRKSRC}/src/rootmenu.c \
|
||||
${WRKSRC}/src/wmconfig.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -27,6 +27,15 @@
|
|||
{
|
||||
dialog_popup (DIALOG_ERROR, NULL, NULL,
|
||||
_("Can't save theme file\n`%s'\n"
|
||||
@@ -2897,7 +2897,7 @@ getstyle_call (const char *themename)
|
||||
*/
|
||||
{
|
||||
char *quotedname = protect_quotes (g_strdup (themename));
|
||||
- char *cmdline = g_strconcat (GETSTYLE, " -t \"", quotedname, "\"", NULL);
|
||||
+ char *cmdline = g_strconcat (GETSTYLE, " -t > \"", quotedname, "\"", NULL);
|
||||
bool_t success = !system (cmdline);
|
||||
|
||||
Free (cmdline);
|
||||
@@ -3526,17 +3526,17 @@ compute_preview (GtkWidget *progress_bar, GtkWidget *p
|
||||
path = get_pixmap_path (pname);
|
||||
|
||||
|
|
Loading…
Add table
Reference in a new issue