mirror of
https://git.freebsd.org/ports.git
synced 2025-05-04 15:37:40 -04:00
graphics/inkscape: update to 1.3
Also update math/lib2geom to 1.3, which must be updated together Release notes: https://inkscape.org/doc/release_notes/1.3/Inkscape_1.3.html - 2.5 patches included to address system macro clashes - DBUS option removed, now uses GDBus from GLib instead of dbus-glib Differential Revision: https://reviews.freebsd.org/D41503
This commit is contained in:
parent
ffaa8cd925
commit
c41b45f3bf
9 changed files with 415 additions and 1601 deletions
|
@ -1,17 +1,11 @@
|
|||
PORTNAME= inkscape
|
||||
DISTVERSION= 1.2.2
|
||||
PORTREVISION= 12
|
||||
DISTVERSION= 1.3
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= https://media.inkscape.org/dl/resources/file/
|
||||
|
||||
PATCH_SITES= https://gitlab.com/${PORTNAME}/${PORTNAME}/-/commit/
|
||||
# https://gitlab.com/inkscape/inkscape/-/merge_requests/4463
|
||||
PATCHFILES+= c5fc06a7c29d6be9e2fb18b841e973a193428332.patch:-p1 \
|
||||
40c4147ec66319f42129ab253d0483f91329419c.patch:-p1 \
|
||||
57c85eec491e07949497fa67edc7c76eafde7471.patch:-p1
|
||||
# 362f987096833dd1dfa223be82fc6a97c3795f6c.patch:-p1
|
||||
PATCHFILES+= fdc7329ba5036ef5cde7bb5e61ed52a69850f5d8.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/merge_requests/4483
|
||||
PATCHFILES+= 781e29cd3538.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/merge_requests/5111
|
||||
PATCHFILES+= 3db96bfbac475022a32b70473b767b21a8d70c7f.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/issues/4427
|
||||
PATCHFILES+= 00851fede7f9162cbcacf81258d1dda823b88a5c.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/merge_requests/5650
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= Full featured open source SVG editor
|
||||
|
@ -28,10 +22,10 @@ LICENSE_FILE_LGPL3 = ${WRKSRC}/LICENSES/LGPL-3.0.txt
|
|||
LICENSE_FILE_LGPL3+ = ${WRKSRC}/LICENSES/LGPL-3.0-or-later.txt
|
||||
LICENSE_FILE_MPL11 = ${WRKSRC}/LICENSES/MPL-1.1.txt
|
||||
|
||||
BUILD_DEPENDS= ragel:devel/ragel
|
||||
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
|
||||
libpopt.so:devel/popt \
|
||||
libgc.so:devel/boehm-gc \
|
||||
libgdl-3.so:x11-toolkits/gdl \
|
||||
libgsl.so:math/gsl \
|
||||
liblcms2.so:graphics/lcms2 \
|
||||
libfribidi.so:converters/fribidi \
|
||||
|
@ -43,6 +37,8 @@ LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
|
|||
libsoup-2.4.so:devel/libsoup \
|
||||
libyaml.so:textproc/libyaml \
|
||||
libdouble-conversion.so:devel/double-conversion \
|
||||
libenchant-2.so:textproc/enchant2 \
|
||||
libepoxy.so:graphics/libepoxy \
|
||||
lib2geom.so:math/lib2geom
|
||||
RUN_DEPENDS= ${PYNUMPY} \
|
||||
${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVOR} \
|
||||
|
@ -53,22 +49,25 @@ RUN_DEPENDS= ${PYNUMPY} \
|
|||
${PYTHON_PKGNAMEPREFIX}cssselect>0:www/py-cssselect@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
|
||||
fig2dev:print/fig2dev
|
||||
TEST_DEPENDS= googletest>0:devel/googletest \
|
||||
bash:shells/bash
|
||||
|
||||
USES= compiler:c++17-lang cmake cpe desktop-file-utils ghostscript:run \
|
||||
USES= compiler:c++17-lang cmake:testing cpe desktop-file-utils ghostscript:run \
|
||||
gnome iconv:wchar_t jpeg pathfix pkgconfig python \
|
||||
readline shebangfix tar:xz xorg
|
||||
USE_GNOME= gdkpixbuf2 gtkmm30 libxml2 libxslt
|
||||
USE_GNOME= cairo gdkpixbuf2 gtkmm30 gtksourceview4 libxml2 libxslt
|
||||
USE_PYTHON= cython
|
||||
USE_XORG= sm ice x11 xext
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
DATETAG= 2022-12-01_b0a8486541
|
||||
|
||||
DATETAG= 2023-07-21_0e150ed6c4
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}_${DATETAG}
|
||||
|
||||
BINARY_ALIAS= python3=${PYTHON_CMD}
|
||||
SHEBANG_FILES= share/extensions/*.py share/extensions/genpofiles.sh \
|
||||
share/templates/*.py man/fix-roff-punct
|
||||
|
||||
OPTIONS_DEFINE= OPENMP POPPLER SCRIBUS VISIO CDR DBUS WPG GVFS NLS GSPELL
|
||||
OPTIONS_DEFINE= OPENMP POPPLER SCRIBUS VISIO CDR WPG GVFS NLS GSPELL
|
||||
OPTIONS_DEFAULT= POPPLER VISIO CDR WPG GM GSPELL
|
||||
OPTIONS_DEFAULT_amd64= OPENMP
|
||||
OPTIONS_DEFAULT_powerpc64= OPENMP
|
||||
|
@ -82,10 +81,6 @@ CDR_CMAKE_BOOL= WITH_LIBCDR
|
|||
CDR_LIB_DEPENDS= librevenge-stream-0.0.so:textproc/librevenge \
|
||||
libcdr-0.1.so:graphics/libcdr01
|
||||
|
||||
DBUS_CMAKE_BOOL= WITH_DBUS
|
||||
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
|
||||
libdbus-1.so:devel/dbus
|
||||
|
||||
GVFS_USE= GNOME=gvfs
|
||||
|
||||
OPENMP_CMAKE_BOOL= WITH_OPENMP
|
||||
|
@ -119,7 +114,7 @@ NLS_CMAKE_BOOL= WITH_NLS
|
|||
NLS_USES= gettext
|
||||
|
||||
GSPELL_DESC= Support for spell checking through gspell
|
||||
GSPELL_CMAKE_BOOL= WITH_GSPELL
|
||||
GSPELL_CMAKE_BOOL= WITH_GSPELL
|
||||
GSPELL_LIB_DEPENDS= libgspell-1.so:textproc/gspell
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1,13 +1,7 @@
|
|||
TIMESTAMP = 1687584227
|
||||
SHA256 (inkscape-1.2.2.tar.xz) = a0c7fd0d03c0a21535e648ef301dcf80dd7cfc1f3545e51065fbf1ba3ee8a5c4
|
||||
SIZE (inkscape-1.2.2.tar.xz) = 39392040
|
||||
SHA256 (c5fc06a7c29d6be9e2fb18b841e973a193428332.patch) = 08ca608bc5509e2398d23ef67202f7155296c36e329d1d2a3b00b37d8fd08214
|
||||
SIZE (c5fc06a7c29d6be9e2fb18b841e973a193428332.patch) = 22563
|
||||
SHA256 (40c4147ec66319f42129ab253d0483f91329419c.patch) = 05e670f7d768cfbbc5aacf233fe5c169402611b4f2949a491beb45150b95b14b
|
||||
SIZE (40c4147ec66319f42129ab253d0483f91329419c.patch) = 24153
|
||||
SHA256 (57c85eec491e07949497fa67edc7c76eafde7471.patch) = e3119ce429fb60f554b42b4507becd9bee47c3cb6f71fe1fbfc46331b2bf0574
|
||||
SIZE (57c85eec491e07949497fa67edc7c76eafde7471.patch) = 26184
|
||||
SHA256 (fdc7329ba5036ef5cde7bb5e61ed52a69850f5d8.patch) = 064f76e8691b0975b6a82a21923c562d9bb9855aa08d99ece9af9da877b544d6
|
||||
SIZE (fdc7329ba5036ef5cde7bb5e61ed52a69850f5d8.patch) = 5483
|
||||
SHA256 (781e29cd3538.patch) = 0dda9fb22107b81768e41c38adacf4920c9ecd2ca6ca47efa90693481b72e1b8
|
||||
SIZE (781e29cd3538.patch) = 9262
|
||||
TIMESTAMP = 1692891317
|
||||
SHA256 (inkscape-1.3.tar.xz) = bf4f286b025e0169b8948cc14d5199a9b4c204d761c894c4b48496571ec76307
|
||||
SIZE (inkscape-1.3.tar.xz) = 85764028
|
||||
SHA256 (3db96bfbac475022a32b70473b767b21a8d70c7f.patch) = fb572fa3b566149293b0ffeae468ff6025d0e54a090d928eb8c2037afe2d3f8d
|
||||
SIZE (3db96bfbac475022a32b70473b767b21a8d70c7f.patch) = 2003
|
||||
SHA256 (00851fede7f9162cbcacf81258d1dda823b88a5c.patch) = d0ebfcb85682345d7e10d97931894acd171881a8467b70a777f37a293d255a59
|
||||
SIZE (00851fede7f9162cbcacf81258d1dda823b88a5c.patch) = 5207
|
||||
|
|
File diff suppressed because it is too large
Load diff
11
graphics/inkscape/files/patch-src_helper_geom.h
Normal file
11
graphics/inkscape/files/patch-src_helper_geom.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/helper/geom.h.orig 2023-08-24 15:45:30 UTC
|
||||
+++ src/helper/geom.h
|
||||
@@ -55,7 +55,7 @@ inline Geom::Coord triangle_area(Geom::Point const &p1
|
||||
return p1[X] * p2[Y] + p1[Y] * p3[X] + p2[X] * p3[Y] - p2[Y] * p3[X] - p1[Y] * p2[X] - p1[X] * p3[Y];
|
||||
}
|
||||
|
||||
-inline auto rounddown(Geom::IntPoint const &a, Geom::IntPoint const &b)
|
||||
+inline auto round_down(Geom::IntPoint const &a, Geom::IntPoint const &b)
|
||||
{
|
||||
using namespace Inkscape::Util;
|
||||
return Geom::IntPoint(round_down(a.x(), b.x()), round_down(a.y(), b.y()));
|
|
@ -1,10 +0,0 @@
|
|||
--- src/object/algorithms/graphlayout.cpp.orig 2022-11-26 17:42:01 UTC
|
||||
+++ src/object/algorithms/graphlayout.cpp
|
||||
@@ -14,6 +14,7 @@
|
||||
*/
|
||||
|
||||
#include <algorithm>
|
||||
+#include <array>
|
||||
#include <cstring>
|
||||
#include <iostream>
|
||||
#include <list>
|
File diff suppressed because it is too large
Load diff
|
@ -1,25 +1,42 @@
|
|||
PORTNAME= lib2geom
|
||||
DISTVERSION= 1.2.2
|
||||
DISTVERSION= 1.3
|
||||
CATEGORIES= math gnome
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= Easy to use 2D geometry library in C++
|
||||
WWW= https://gitlab.com/inkscape/lib2geom
|
||||
|
||||
BUILD_DEPENDS= googletest>0:devel/googletest
|
||||
LICENSE= LGPL21 MPL11
|
||||
LICENSE_COMB= dual
|
||||
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING-LGPL-2.1
|
||||
LICENSE_FILE_MPL11= ${WRKSRC}/COPYING-MPL-1.1
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
|
||||
ragel:devel/ragel \
|
||||
googletest>0:devel/googletest
|
||||
LIB_DEPENDS= libdouble-conversion.so:devel/double-conversion \
|
||||
libgsl.so:math/gsl \
|
||||
libboost_thread.so:devel/boost-libs
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR}
|
||||
TEST_DEPENDS= googletest>0:devel/googletest \
|
||||
ragel:devel/ragel
|
||||
|
||||
USES= cmake:testing gettext-runtime gnome localbase:ldflags pkgconfig \
|
||||
python
|
||||
USE_GNOME= cairo glib20 gtk30
|
||||
USE_PYTHON= cython cython_test
|
||||
|
||||
USES= cmake gettext-runtime gnome localbase:ldflags pkgconfig
|
||||
USE_GITLAB= yes
|
||||
USE_GNOME= cairo glib20
|
||||
|
||||
GL_ACCOUNT= inkscape
|
||||
GL_TAGNAME= a84a73ebdae50cc729f57d1ffb788aeaef0f746c
|
||||
|
||||
CMAKE_ON= 2GEOM_BUILD_SHARED
|
||||
CMAKE_ON= 2GEOM_BUILD_SHARED \
|
||||
2GEOM_TESTING
|
||||
|
||||
PLIST_SUB= VERSION=${PORTVERSION}
|
||||
PLIST_SUB= VERSION=${PORTVERSION}.0
|
||||
|
||||
OPTIONS_DEFINE= GPL
|
||||
|
||||
GPL_DESC= Build with GPL-licensed code
|
||||
GPL_CMAKE_BOOL= 2GEOM_USE_GPL_CODE
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1670507287
|
||||
SHA256 (inkscape-lib2geom-a84a73ebdae50cc729f57d1ffb788aeaef0f746c_GL0.tar.gz) = 3a5b38cfb611290f45475b21e8d556d80640eeee231ed588bef3d6945aedadd0
|
||||
SIZE (inkscape-lib2geom-a84a73ebdae50cc729f57d1ffb788aeaef0f746c_GL0.tar.gz) = 1397606
|
||||
TIMESTAMP = 1692190492
|
||||
SHA256 (lib2geom-1.3.tar.bz2) = bd07f2a1322fcad16a55a1901207faa55dffdecebc56a00eabd4575f62e043c9
|
||||
SIZE (lib2geom-1.3.tar.bz2) = 1275751
|
||||
|
|
|
@ -93,5 +93,5 @@ lib/cmake/2Geom/2GeomConfigVersion.cmake
|
|||
lib/cmake/2Geom/2GeomTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/2Geom/2GeomTargets.cmake
|
||||
lib/lib2geom.so
|
||||
lib/lib2geom.so.1.2.0
|
||||
lib/lib2geom.so.%%VERSION%%
|
||||
libdata/pkgconfig/2geom.pc
|
||||
|
|
Loading…
Add table
Reference in a new issue