mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
devel/utf8cpp3: Remove obsoleted port
Use devel/utf8cpp instead.
devel/utf8cpp3 was created for textproc/apertium as it was the only port which do not work with utf8cpp 4.*.
It is no longer needed after 04e8d6e30a
.
PR: 284627
Reported by: diizzy
Reference: https://cgit.freebsd.org/ports/commit/?id=18e703731c1b9e6b1ee31866ea9a83d904a701aa
https://cgit.freebsd.org/ports/commit/?id=04e8d6e30a276fe64a23259406c6fe905f58044c
This commit is contained in:
parent
4cfd46b571
commit
c3b38f91ff
7 changed files with 1 additions and 68 deletions
1
MOVED
1
MOVED
|
@ -4209,3 +4209,4 @@ textproc/py-towncrier23|textproc/py-towncrier|2025-03-14|Remove obsoleted port.
|
|||
net/wifi-firmware-mtw-kmod|net/wifi-firmware-mt7601u-kmod|2025-03-14|Fixed to match firmware name
|
||||
devel/ccrtp||2025-03-16|Has expired: No active development in years and no users in tree
|
||||
textproc/rubygem-cucumber-gherkin29|textproc/rubygem-cucumber-gherkin|2025-03-19|Remove obsoleted port. Use textproc/rubygem-cucumber-gherkin instead
|
||||
devel/utf8cpp3|devel/utf8cpp|2025-03-19|Remove obsoleted port. Use devel/utf8cpp instead
|
||||
|
|
|
@ -8337,7 +8337,6 @@
|
|||
SUBDIR += urjtag
|
||||
SUBDIR += ut
|
||||
SUBDIR += utf8cpp
|
||||
SUBDIR += utf8cpp3
|
||||
SUBDIR += uthash
|
||||
SUBDIR += util-linux
|
||||
SUBDIR += uv
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
PORTNAME= utf8cpp
|
||||
PORTVERSION= 3.2.5
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= devel
|
||||
PKGNAMESUFFIX= 3
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Simple, portable, lightweight library for handling UTF-8 strings
|
||||
WWW= https://github.com/nemtrif/utfcpp
|
||||
|
||||
LICENSE= BSL
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= cmake
|
||||
|
||||
CMAKE_ON= UTF8_INSTALL
|
||||
CMAKE_OFF= UTF8_SAMPLES UTF8_TESTS
|
||||
NO_ARCH= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= nemtrif
|
||||
GH_PROJECT= utfcpp
|
||||
|
||||
CONFLICTS_INSTALL= utf8cpp
|
||||
|
||||
PORTSCOUT= limit:^3\.
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1696001272
|
||||
SHA256 (nemtrif-utfcpp-v3.2.5_GH0.tar.gz) = 14fd1b3c466814cb4c40771b7f207b61d2c7a0aa6a5e620ca05c00df27f25afd
|
||||
SIZE (nemtrif-utfcpp-v3.2.5_GH0.tar.gz) = 28865
|
|
@ -1,11 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2020-09-27 18:26:57 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -36,7 +36,7 @@ if(UTF8_SAMPLES)
|
||||
target_link_libraries(docsample PRIVATE utf8::cpp)
|
||||
endif()
|
||||
|
||||
-if(UTF8_TESTS)
|
||||
+if(0)
|
||||
enable_testing()
|
||||
add_subdirectory(extern/gtest)
|
||||
add_subdirectory(tests)
|
|
@ -1,16 +0,0 @@
|
|||
C++ developers miss an easy and portable way of handling Unicode encoded
|
||||
strings. The original C++ Standard (known as C++98 or C++03) is Unicode
|
||||
agnostic. C++11 provides some support for Unicode on core language and library
|
||||
level: u8, u, and U character and string literals, char16_t and char32_t
|
||||
character types, u16string and u32string library classes, and codecvt support
|
||||
for conversions between Unicode encoding forms. In the meantime, developers use
|
||||
third party libraries like ICU, OS specific capabilities, or simply roll out
|
||||
their own solutions.
|
||||
|
||||
In order to easily handle UTF-8 encoded Unicode strings, I came up with a small,
|
||||
C++98 compatible generic library. For anybody used to work with STL algorithms
|
||||
and iterators, it should be easy and natural to use. The code is freely
|
||||
available for any purpose - check out the license. The library has been used a
|
||||
lot in the past ten years both in commercial and open-source projects and is
|
||||
considered feature-complete now. If you run into bugs or performance issues,
|
||||
please let me know and I'll do my best to address them.
|
|
@ -1,9 +0,0 @@
|
|||
include/utf8cpp/utf8.h
|
||||
include/utf8cpp/utf8/checked.h
|
||||
include/utf8cpp/utf8/core.h
|
||||
include/utf8cpp/utf8/cpp11.h
|
||||
include/utf8cpp/utf8/cpp17.h
|
||||
include/utf8cpp/utf8/unchecked.h
|
||||
lib/cmake/utf8cpp/utf8cppConfig.cmake
|
||||
lib/cmake/utf8cpp/utf8cppConfigVersion.cmake
|
||||
lib/cmake/utf8cpp/utf8cppTargets.cmake
|
Loading…
Add table
Reference in a new issue