This is the Public software group utf8proc library repackaged as a

conveniance library for NetSurf.

This takes the unicode 5 capable version 1.1.6 of the library and
converts it to the NetSurf build system. additional API has been added
with a normalisation function but there are no data changes from
upstream.

WWW: http://www.netsurf-browser.org/
This commit is contained in:
Olivier Duchateau 2016-03-20 16:34:30 +00:00
parent ec8ac903fc
commit c33b3f73a2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=411464
7 changed files with 66 additions and 0 deletions

View file

@ -421,6 +421,7 @@
SUBDIR += libucl SUBDIR += libucl
SUBDIR += libunibreak SUBDIR += libunibreak
SUBDIR += libuninameslist SUBDIR += libuninameslist
SUBDIR += libutf8proc
SUBDIR += libvisio SUBDIR += libvisio
SUBDIR += libvisio01 SUBDIR += libvisio01
SUBDIR += libwapcaplet SUBDIR += libwapcaplet

View file

@ -0,0 +1,29 @@
# Created by: Olivier Duchateau
# $FreeBSD$
PORTNAME= libutf8proc
PORTVERSION= 1.3.1
CATEGORIES= textproc
MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= olivierd@FreeBSD.org
COMMENT= UTF8 Processing library
LICENSE= MIT
BUILD_DEPENDS= netsurf-buildsystem>=1.5:${PORTSDIR}/devel/netsurf-buildsystem
USES= gmake
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
MAKE_ENV+= COMPONENT_TYPE="lib-shared"
PLIST_SUB+= VERSION=${PORTVERSION}
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libutf8proc.so*
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (libutf8proc-1.3.1-src.tar.gz) = 78e950bfc691182d3b61109b1b4e234399743607231f72a395331a367c2ac675
SIZE (libutf8proc-1.3.1-src.tar.gz) = 144963

View file

@ -0,0 +1,10 @@
--- Makefile.orig 2016-01-07 00:18:19 UTC
+++ Makefile
@@ -46,5 +46,5 @@ endif
# Extra installation rules
I := /$(INCLUDEDIR)/libutf8proc
INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):include/libutf8proc/utf8proc.h
-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR)/pkgconfig:lib$(COMPONENT).pc.in
-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR):$(OUTPUT)
+INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
+INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)

View file

@ -0,0 +1,10 @@
--- libutf8proc.pc.in.orig 2016-01-07 00:18:19 UTC
+++ libutf8proc.pc.in
@@ -1,6 +1,6 @@
prefix=PREFIX
exec_prefix=${prefix}
-libdir=${exec_prefix}/LIBDIR
+libdir=${exec_prefix}/lib
includedir=${prefix}/INCLUDEDIR
Name: libutf8proc

View file

@ -0,0 +1,9 @@
This is the Public software group utf8proc library repackaged as a
conveniance library for NetSurf.
This takes the unicode 5 capable version 1.1.6 of the library and
converts it to the NetSurf build system. additional API has been added
with a normalisation function but there are no data changes from
upstream.
WWW: http://www.netsurf-browser.org/

View file

@ -0,0 +1,5 @@
include/libutf8proc/utf8proc.h
lib/libutf8proc.so
lib/libutf8proc.so.1
lib/libutf8proc.so.%%VERSION%%
libdata/pkgconfig/libutf8proc.pc