science/py-h5py: Update to 3.2.1

- Update USES=python of dependent ports

Changes:	https://github.com/h5py/h5py/releases
		https://github.com/h5py/h5py/blob/master/docs/whatsnew/3.2.rst
This commit is contained in:
Po-Chuan Hsieh 2021-04-18 13:06:18 +08:00
parent 2ff060b906
commit c3183a0a8b
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
13 changed files with 22 additions and 22 deletions

View file

@ -20,7 +20,7 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
RUN_DEPENDS= ${PY_DEPENDS} \
llvm${LLVM_VER}>0:devel/llvm${LLVM_VER}
USES= cmake compiler:c++14-lang gettext-runtime python:3.6+ shebangfix
USES= cmake compiler:c++14-lang gettext-runtime python:3.7+ shebangfix
USE_LDCONFIG= yes
USE_GITHUB= yes

View file

@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}h5py>=0:science/py-h5py@${PY_FLAVOR}
USES= python:3.6+
USES= python:3.7+
USE_GITHUB= yes
GH_ACCOUNT= keras-team
USE_PYTHON= autoplist distutils

View file

@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}theano>=0.8.0:math/py-theano@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
USES= python:3.6+
USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes

View file

@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cvxopt>0:math/py-cvxopt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYNUMPY}
USES= python:3.6+
USES= python:3.7+
USE_GITHUB= yes
GH_ACCOUNT= quantumlib
USE_PYTHON= distutils autoplist

View file

@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}pytools>=2016.2.1:devel/py-pytools@${PY_FLAVOR} \
${PYNUMPY}
USES= python:3.3+ shebangfix zip
USES= python:3.7+ shebangfix zip
SHEBANG_FILES= setup.py pyfr/__main__.py
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes

View file

@ -18,7 +18,7 @@ PY_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
USES= python:3.6+
USES= python:3.7+
USE_PYTHON= distutils cython concurrent autoplist # pkg-plist also exists and contains files missing from the python-generated plist
post-install:

View file

@ -14,7 +14,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pkgconfig>0:devel/py-pkgconfig@${PY_FLAVOR
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR}
USES= python:3.6+
USES= python:3.7+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes

View file

@ -1,7 +1,7 @@
# Created by: TAOKA Fumiyoshi
PORTNAME= h5py
PORTVERSION= 3.1.0
PORTVERSION= 3.2.1
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,14 +12,14 @@ COMMENT= General-purpose Python interface to the HDF5 library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/licenses/license.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.14:lang/cython@${PY_FLAVOR} \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.15:lang/cython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pkgconfig>=0:devel/py-pkgconfig@${PY_FLAVOR} \
${RUN_DEPENDS}
LIB_DEPENDS= libhdf5.so:science/hdf5
RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= localbase pkgconfig python:3.6+
USES= localbase pkgconfig python:3.7+
USE_PYTHON= autoplist concurrent cython distutils
OPTIONS_DEFINE= DOCS EXAMPLES

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1611665487
SHA256 (h5py-3.1.0.tar.gz) = 1e2516f190652beedcb8c7acfa1c6fa92d99b42331cbef5e5c7ec2d65b0fc3c2
SIZE (h5py-3.1.0.tar.gz) = 371392
TIMESTAMP = 1618320258
SHA256 (h5py-3.2.1.tar.gz) = 89474be911bfcdb34cbf0d98b8ec48b578c27a89fdb1ae4ee7513f1ef8d9249e
SIZE (h5py-3.2.1.tar.gz) = 368170

View file

@ -1,20 +1,19 @@
--- setup.py.orig 2020-11-06 14:25:11 UTC
--- setup.py.orig 2021-03-05 10:02:07 UTC
+++ setup.py
@@ -27,10 +27,7 @@ VERSION = '3.1.0'
@@ -27,9 +27,7 @@ VERSION = '3.2.1'
# Minimum supported versions of Numpy & Cython depend on the Python version
NUMPY_MIN_VERSIONS = [
# Numpy Python
- ('1.12', "=='3.6'"),
- ('1.14.5', "=='3.7'"),
- ('1.17.5', "=='3.8'"),
- ('1.19.3', ">='3.9'"),
+ ('1.14.5', ">='3.6'"),
+ ('1.14.5', ">='3.7'"),
]
# these are required to use h5py
@@ -49,7 +46,7 @@ SETUP_REQUIRES = [
f"Cython >=0.29; python_version<'3.8'",
f"Cython >=0.29.14; python_version>='3.8'",
@@ -49,7 +47,7 @@ SETUP_REQUIRES = [
"Cython >=0.29.14; python_version=='3.8'",
"Cython >=0.29.15; python_version>='3.9'",
] + [
- f"numpy =={np_min}; python_version{py_condition}"
+ f"numpy >={np_min}; python_version{py_condition}"

View file

@ -35,6 +35,7 @@
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/2.9.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.0.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.1.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.2.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/index.rst
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bytesio.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/collective_io.py

View file

@ -21,7 +21,7 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
${LOCALBASE}/include/lapacke.h:math/lapacke
RUN_DEPENDS= ${PY_DEPENDS}
USES= blaslapack:openblas fortran localbase python:3.6+
USES= blaslapack:openblas fortran localbase python:3.7+
USE_PYTHON= distutils cython autoplist
.include <bsd.port.mk>

View file

@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
USES= python:3.6+
USES= python:3.7+
USE_PYTHON= distutils cython autoplist
do-test: