mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
Add clit, a tool to manipulate Microsoft LIT eBook format.
PR: ports/76201 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
This commit is contained in:
parent
1b0190a48e
commit
c28ba6d653
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126461
5 changed files with 91 additions and 0 deletions
|
@ -45,6 +45,7 @@
|
|||
SUBDIR += cl-ppcre-clisp
|
||||
SUBDIR += cl-ppcre-cmucl
|
||||
SUBDIR += cl-ppcre-sbcl
|
||||
SUBDIR += clit
|
||||
SUBDIR += coco
|
||||
SUBDIR += code2html
|
||||
SUBDIR += cole
|
||||
|
|
50
textproc/clit/Makefile
Normal file
50
textproc/clit/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
# New ports collection makefile for: clit
|
||||
# Date created: 2005-01-11
|
||||
# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= clit
|
||||
PORTVERSION= ${MAJ_VER}.${MIN_VER}
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.convertlit.com/\
|
||||
http://math.libtomcrypt.org/files/:ltm
|
||||
DISTFILES= clit${MAJ_VER}${MIN_VER}src.zip \
|
||||
ltm-0.33.tar.bz2:ltm
|
||||
EXTRACT_ONLY= clit${MAJ_VER}${MIN_VER}src.zip
|
||||
|
||||
MAINTAINER= itetcu@people.tecnik93.com
|
||||
COMMENT= Microsoft Lit to HTML and Open eBooks converter
|
||||
|
||||
PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}${MAJ_VER}${MIN_VER}
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
MAJ_VER= 1
|
||||
MIN_VER= 8
|
||||
|
||||
PLIST_FILES= bin/clit
|
||||
|
||||
USE_ZIP= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-extract:
|
||||
cd ${WRKDIR} && ${BZIP2_CMD} -dc "${DISTDIR}/ltm-0.33.tar.bz2" | \
|
||||
${TAR} -xf -
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKDIR} -name *.c -or -name *.h | ${XARGS} ${REINPLACE_CMD} -e 's|
||'
|
||||
|
||||
do-build:
|
||||
cd ${WRKDIR}/libtommath-0.33 && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} -f makefile libtommath.a
|
||||
cd ${WRKDIR}/lib && ${SETENV} ${MAKE_ENV} ${GMAKE} -f Makefile all
|
||||
cd ${WRKDIR}/${PORTNAME}${MAJ_VER}${MIN_VER} && \
|
||||
${SETENV} ${MAKE_ENV} ${GMAKE} -f Makefile all
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME}${MAJ_VER}${MIN_VER}/clit \
|
||||
${LOCALBASE}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
4
textproc/clit/distinfo
Normal file
4
textproc/clit/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
MD5 (clit18src.zip) = d691d4729485fe5d73e3f0937d8fb42e
|
||||
SIZE (clit18src.zip) = 135120
|
||||
MD5 (ltm-0.33.tar.bz2) = deaefdedd5078ab8995c728fd9fc369b
|
||||
SIZE (ltm-0.33.tar.bz2) = 1899564
|
14
textproc/clit/files/patch-clit_Makefile
Normal file
14
textproc/clit/files/patch-clit_Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- Makefile.orig Sun Jul 4 16:52:14 2004
|
||||
+++ Makefile Fri Jan 14 21:56:45 2005
|
||||
@@ -1,9 +1,9 @@
|
||||
all: clit
|
||||
|
||||
-CFLAGS=-funsigned-char -Wall -O2 -I ../libtommath-0.30/ -I ../lib -I ../lib/des -I .
|
||||
+CFLAGS=-funsigned-char -Wall -O2 -I ../libtommath-0.33/ -I ../lib -I ../lib/des -I .
|
||||
clean:
|
||||
rm -f *.o clit
|
||||
|
||||
clit: clit.o hexdump.o drm5.o explode.o transmute.o display.o utils.o manifest.o ../lib/openclit.a
|
||||
- gcc -o clit $^ ../libtommath-0.30/libtommath.a
|
||||
+ gcc -o clit $^ ../libtommath-0.33/libtommath.a
|
||||
|
22
textproc/clit/pkg-descr
Normal file
22
textproc/clit/pkg-descr
Normal file
|
@ -0,0 +1,22 @@
|
|||
This program has three modes of operation:
|
||||
- First, is ** EXPLOSION **, or the expanding of a .LIT file into an
|
||||
OEBPS compliant package.
|
||||
- Second, is the DOWNCONVERTING of a .LIT file down to "Sealed",
|
||||
or DRM1 format for reading on handheld devices.
|
||||
- Third, is the INSCRIBING of a .LIT file which allows you to label
|
||||
your ebooks.
|
||||
|
||||
DRM5 is supported if you have a "keys.txt" file that contains
|
||||
the private key(s) for your passport(s) in either the CLIT program
|
||||
directory or the current directory.
|
||||
|
||||
This is a tool for **YOUR OWN FAIR USE** and not for stealing
|
||||
other people's ebooks.
|
||||
|
||||
Please do not use this program to distrbute illegal copies of ebooks.
|
||||
... that would make Baby Jesus sad.
|
||||
|
||||
WWW: http://www.convertlit.com/download.php
|
||||
|
||||
- IOnut
|
||||
<itetcu@people.tecnik93.com>
|
Loading…
Add table
Reference in a new issue