mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
devel/py-thinc8: Update to 8.3.3
- Add GitHub to MASTER_SITES Changes: https://github.com/explosion/thinc/releases
This commit is contained in:
parent
dd5985e25c
commit
c22767b8f6
4 changed files with 22 additions and 32 deletions
|
@ -1,7 +1,8 @@
|
|||
PORTNAME= thinc
|
||||
PORTVERSION= 8.3.2
|
||||
PORTVERSION= 8.3.3
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= PYPI
|
||||
MASTER_SITES= PYPI \
|
||||
https://github.com/explosion/thinc/releases/download/release-v${PORTVERSION}/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
PKGNAMESUFFIX= 8
|
||||
|
||||
|
@ -13,19 +14,19 @@ WWW= https://thinc.ai/ \
|
|||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.0.0<1.1.0:math/py-blis@${PY_FLAVOR} \
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.1.0<1.2.0:math/py-blis@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=0,1<2.1.0,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=1.19.0,1<3.0.0,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}preshed3>=3.0.2<3.1.0:devel/py-preshed3@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.0.0<1.1.0:math/py-blis@${PY_FLAVOR} \
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.1.0<1.2.0:math/py-blis@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}catalogue>=2.0.4<2.1.0:devel/py-catalogue@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}confection>=0.0.1<1.0.0:devel/py-confection@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=0,1<2.1.0,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=1.19.0,1<3.0.0,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=20.0:devel/py-packaging@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}preshed3>=3.0.2<3.1.0:devel/py-preshed3@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pydantic2>=1.7.4<3.0.0:devel/py-pydantic2@${PY_FLAVOR} \
|
||||
|
@ -33,7 +34,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=1.0.0<1.1.0:math/py-blis@${PY_FLAVOR}
|
|||
${PYTHON_PKGNAMEPREFIX}srsly>=2.4.0<3.0.0:devel/py-srsly@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wasabi>=0.8.1<1.2.0:textproc/py-wasabi@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USES= python:3.9+
|
||||
USE_PYTHON= autoplist concurrent cython pep517
|
||||
|
||||
PORTSCOUT= limit:^8\.
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1728632418
|
||||
SHA256 (thinc-8.3.2.tar.gz) = 3e8ef69eac89a601e11d47fc9e43d26ffe7ef682dcf667c94ff35ff690549aeb
|
||||
SIZE (thinc-8.3.2.tar.gz) = 193915
|
||||
TIMESTAMP = 1735227922
|
||||
SHA256 (thinc-8.3.3.tar.gz) = e137ddd244ee1c6a1b2500f95b7688029d7faab71f33e041e563a4372abdd004
|
||||
SIZE (thinc-8.3.3.tar.gz) = 193907
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
--- pyproject.toml.orig 2024-07-31 10:32:18 UTC
|
||||
--- pyproject.toml.orig 2024-12-16 12:18:54 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -6,8 +6,7 @@ requires = [
|
||||
@@ -6,7 +6,7 @@ requires = [
|
||||
"cymem>=2.0.2,<2.1.0",
|
||||
"preshed>=3.0.2,<3.1.0",
|
||||
"blis>=1.0.0,<1.1.0",
|
||||
- "numpy>=2.0.0,<2.1.0; python_version < '3.9'",
|
||||
- "numpy>=2.0.0,<2.1.0; python_version >= '3.9'",
|
||||
+ "numpy>=0,<2.1.0",
|
||||
"blis>=1.1.0,<1.2.0",
|
||||
- "numpy>=2.0.0,<3.0.0",
|
||||
+ "numpy>=1.19.0,<3.0.0",
|
||||
]
|
||||
build-backend = "setuptools.build_meta"
|
||||
|
||||
|
|
|
@ -1,21 +1,11 @@
|
|||
--- setup.cfg.orig 2024-07-31 10:32:29 UTC
|
||||
--- setup.cfg.orig 2024-12-16 12:19:05 UTC
|
||||
+++ setup.cfg
|
||||
@@ -32,7 +32,7 @@ setup_requires =
|
||||
python_requires = >=3.6
|
||||
@@ -33,7 +33,7 @@ setup_requires =
|
||||
python_requires = >=3.9,<3.13
|
||||
setup_requires =
|
||||
cython>=0.25,<3.0
|
||||
- numpy>=2.0.1,<2.1.0
|
||||
+ numpy>=0,<2.1.0
|
||||
cython>=0.29.0,<3.0
|
||||
- numpy>=2.0.0,<3.0.0
|
||||
+ numpy>=1.19.0,<3.0.0
|
||||
cymem>=2.0.2,<2.1.0
|
||||
preshed>=3.0.2,<3.1.0
|
||||
murmurhash>=1.0.2,<1.1.0
|
||||
@@ -47,8 +47,7 @@ install_requires =
|
||||
catalogue>=2.0.4,<2.1.0
|
||||
confection>=0.0.1,<1.0.0
|
||||
setuptools
|
||||
- numpy>=2.0.0,<2.1.0; python_version < "3.9"
|
||||
- numpy>=2.0.0,<2.1.0; python_version >= "3.9"
|
||||
+ numpy>=0,<2.1.0
|
||||
pydantic>=1.7.4,!=1.8,!=1.8.1,<3.0.0
|
||||
packaging>=20.0
|
||||
dataclasses>=0.6,<1.0; python_version < "3.7"
|
||||
|
|
Loading…
Add table
Reference in a new issue