mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
devel/py-optree: Update to 0.15.0
Changes: https://github.com/metaopt/optree/releases
This commit is contained in:
parent
fea8e2dd44
commit
c05461a94b
3 changed files with 6 additions and 15 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= optree
|
||||
PORTVERSION= 0.14.1
|
||||
PORTVERSION= 0.15.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1742070384
|
||||
SHA256 (optree-0.14.1.tar.gz) = c011c6124d6dcbfceade2d7c4f836eab66ed8cf9ab12f94535b41a71dd734637
|
||||
SIZE (optree-0.14.1.tar.gz) = 163095
|
||||
TIMESTAMP = 1744288932
|
||||
SHA256 (optree-0.15.0.tar.gz) = d00a45e3b192093ef2cd32bf0d541ecbfc93c1bd73a5f3fe36293499f28a50cf
|
||||
SIZE (optree-0.15.0.tar.gz) = 171403
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup.py.orig 2025-03-01 19:39:44 UTC
|
||||
--- setup.py.orig 2025-04-06 13:55:44 UTC
|
||||
+++ setup.py
|
||||
@@ -119,10 +119,6 @@ class cmake_build_ext(build_ext): # noqa: N801
|
||||
@@ -211,10 +211,6 @@ class cmake_build_ext(build_ext): # noqa: N801
|
||||
cmake_args.append(f'-Dpybind11_DIR={pybind11.get_cmake_dir()}')
|
||||
|
||||
build_args = ['--config', config]
|
||||
|
@ -11,12 +11,3 @@
|
|||
|
||||
build_args.extend(['--target', ext.target, '--'])
|
||||
|
||||
@@ -138,7 +134,7 @@ class cmake_build_ext(build_ext): # noqa: N801
|
||||
with unset_python_path():
|
||||
self.spawn([cmake, '--version']) # cmake in the parent virtual environment
|
||||
|
||||
- self.mkpath(build_temp)
|
||||
+ self.mkpath(str(build_temp))
|
||||
with spawn_context():
|
||||
self.spawn([cmake, '-S', str(ext.source_dir), '-B', str(build_temp), *cmake_args])
|
||||
self.spawn([cmake, '--build', str(build_temp), *build_args])
|
||||
|
|
Loading…
Add table
Reference in a new issue