mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
editors/gobby: Update to 0.6.0
- Switch from PORTVERSION to DISTVERSION - Update LICENSE - Remove extinct GTKSPELL option - Submitter becomes maintainer ChangeLog: https://github.com/gobby/gobby/blob/v0.6.0/NEWS PR: 283864
This commit is contained in:
parent
6feefd0a1a
commit
bfbb316cca
6 changed files with 79 additions and 138 deletions
|
@ -1,49 +1,42 @@
|
||||||
PORTNAME= gobby
|
PORTNAME= gobby
|
||||||
PORTVERSION= 0.4.13
|
DISTVERSION= 0.6.0
|
||||||
PORTREVISION= 11
|
|
||||||
CATEGORIES= editors
|
CATEGORIES= editors
|
||||||
MASTER_SITES= http://releases.0x539.de/gobby/
|
MASTER_SITES= http://releases.0x539.de/gobby/
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= nxjoseph@protonmail.com
|
||||||
COMMENT= Free collaborative editor
|
COMMENT= Free collaborative editor
|
||||||
WWW= http://gobby.0x539.de
|
WWW= http://gobby.0x539.de
|
||||||
|
|
||||||
LICENSE= GPLv2
|
LICENSE= ISCL
|
||||||
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
LIB_DEPENDS= libobby.so:devel/obby \
|
BUILD_DEPENDS= itstool:textproc/itstool
|
||||||
libnet6.so:net/net6 \
|
LIB_DEPENDS= libgnutls.so:security/gnutls \
|
||||||
libxml++-2.6.so:textproc/libxml++26 \
|
libgsasl.so:security/libgsasl \
|
||||||
libgtkmm-2.4.so:x11-toolkits/gtkmm24
|
libinfgtk-0.7.so:textproc/libinfinity \
|
||||||
|
libinfinity-0.7.so:textproc/libinfinity \
|
||||||
|
libinftext-0.7.so:textproc/libinfinity \
|
||||||
|
libinftextgtk-0.7.so:textproc/libinfinity
|
||||||
|
|
||||||
OPTIONS_DEFINE= GTKSPELL NLS
|
USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake \
|
||||||
GTKSPELL_DESC= Enable GtkSpell support
|
gnome pathfix pkgconfig
|
||||||
|
|
||||||
USE_GNOME= gtksourceview2 intltool
|
|
||||||
USES= compiler:c++11-lang cpe gmake gnome pathfix pkgconfig
|
|
||||||
CPE_VENDOR= ${PORTNAME}_project
|
|
||||||
USE_CXXSTD= c++11
|
USE_CXXSTD= c++11
|
||||||
|
USE_GNOME= atkmm cairomm glibmm gtkmm30 gtksourceview3 intltool \
|
||||||
|
libsigc++20 libxml++26 pangomm
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
|
||||||
|
|
||||||
.include <bsd.port.options.mk>
|
OPTIONS_DEFINE= NLS
|
||||||
|
OPTIONS_SUB= yes
|
||||||
|
|
||||||
.if ${PORT_OPTIONS:MGTKSPELL}
|
NLS_CONFIGURE_ENABLE= nls
|
||||||
LIB_DEPENDS+= libgtkspell.so:textproc/gtkspell
|
|
||||||
CONFIGURE_ARGS+=--with-gtkspell
|
|
||||||
.else
|
|
||||||
CONFIGURE_ARGS+=--without-gtkspell
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if ${PORT_OPTIONS:MNLS}
|
post-install:
|
||||||
CPPFLAGS+= -I${LOCALBASE}/include
|
@cd ${STAGEDIR}${PREFIX}/bin && \
|
||||||
LDFLAGS+= -L${LOCALBASE}/lib -lintl
|
${MV} gobby-0.5 \
|
||||||
CONFIGURE_ARGS+= --enable-nls
|
gobby
|
||||||
USES+= cpe gettext
|
@cd ${STAGEDIR}${PREFIX}/share/man/man1 && \
|
||||||
CPE_VENDOR= ${PORTNAME}_project
|
${MV} gobby-0.5.1 \
|
||||||
PLIST_SUB+= NLS=""
|
gobby.1
|
||||||
.else
|
|
||||||
CONFIGURE_ARGS+= --disable-nls
|
|
||||||
PLIST_SUB+= NLS="@comment "
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,2 +1,3 @@
|
||||||
SHA256 (gobby-0.4.13.tar.gz) = 8cbd89ffbe3e056160a8d76e11d641f3b045793e35897546f98d2de368001871
|
TIMESTAMP = 1736084866
|
||||||
SIZE (gobby-0.4.13.tar.gz) = 507676
|
SHA256 (gobby-0.6.0.tar.gz) = fdb3f3f1984fa22b4f5116804281e2ea17bcaeebebdc14e66f5cf80e995d5cdc
|
||||||
|
SIZE (gobby-0.6.0.tar.gz) = 808019
|
||||||
|
|
|
@ -1,38 +0,0 @@
|
||||||
--- ./inc/config.hpp.orig 2012-01-30 01:27:51.000000000 +0100
|
|
||||||
+++ ./inc/config.hpp 2014-07-24 13:11:27.000000000 +0200
|
|
||||||
@@ -31,6 +31,19 @@
|
|
||||||
#include <libxml++/nodes/element.h>
|
|
||||||
#include <libxml++/nodes/textnode.h>
|
|
||||||
|
|
||||||
+
|
|
||||||
+namespace serialise
|
|
||||||
+{
|
|
||||||
+template<>
|
|
||||||
+class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
|
|
||||||
+{
|
|
||||||
+public:
|
|
||||||
+ typedef Glib::ustring data_type;
|
|
||||||
+
|
|
||||||
+ virtual std::string to_string(const data_type& from) const;
|
|
||||||
+};
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
namespace Gobby
|
|
||||||
{
|
|
||||||
|
|
||||||
@@ -460,15 +473,6 @@
|
|
||||||
};
|
|
||||||
|
|
||||||
template<>
|
|
||||||
-class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
|
|
||||||
-{
|
|
||||||
-public:
|
|
||||||
- typedef Glib::ustring data_type;
|
|
||||||
-
|
|
||||||
- virtual std::string to_string(const data_type& from) const;
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
-template<>
|
|
||||||
class default_context_from<Glib::ustring>:
|
|
||||||
public context_base_from<Glib::ustring>
|
|
||||||
{
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- ./inc/preferencesdialog.hpp.orig 2012-01-30 01:27:51.000000000 +0100
|
|
||||||
+++ ./inc/preferencesdialog.hpp 2014-07-24 13:12:17.000000000 +0200
|
|
||||||
@@ -198,7 +198,7 @@
|
|
||||||
protected:
|
|
||||||
struct LangCompare
|
|
||||||
{
|
|
||||||
- bool operator()(GtkSourceLanguage* first, GtkSourceLanguage* second)
|
|
||||||
+ bool operator()(const GtkSourceLanguage* first, const GtkSourceLanguage* second) const
|
|
||||||
{
|
|
||||||
return first < second;
|
|
||||||
}
|
|
|
@ -1 +1,5 @@
|
||||||
A free collaborative editor.
|
Gobby is a free collaborative editor. This means that it provides you with the
|
||||||
|
possibility to edit files simultaneously with other users over a network.
|
||||||
|
The platforms on which you could use Gobby are so far Microsoft Windows, Linux,
|
||||||
|
Mac OS X and other Unix-like ones. Developed with the GTK+ toolkit it
|
||||||
|
integrates nicely into the GNOME desktop environment if you want it to.
|
||||||
|
|
|
@ -1,55 +1,47 @@
|
||||||
bin/gobby
|
bin/gobby
|
||||||
|
share/applications/gobby-0.5.desktop
|
||||||
|
share/glib-2.0/schemas/de.0x539.gobby.gschema.xml
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrint/48x48/actions/chat.png
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrint/48x48/actions/document-list.png
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrint/48x48/actions/user-list.png
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrint/scalable/actions/chat.svg
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrint/scalable/actions/document-list.svg
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrint/scalable/actions/user-list.svg
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrintInverse/48x48/actions/chat.png
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrintInverse/48x48/actions/document-list.png
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrintInverse/48x48/actions/user-list.png
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrintInverse/scalable/actions/chat.svg
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrintInverse/scalable/actions/document-list.svg
|
||||||
|
%%DATADIR%%-0.5/icons/HighContrastLargePrintInverse/scalable/actions/user-list.svg
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/48x48/actions/chat.png
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/48x48/actions/document-list.png
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/48x48/actions/user-list.png
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/48x48/status/user-color-indicator.png
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/scalable/actions/chat.svg
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/scalable/actions/document-list.svg
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/scalable/actions/user-list.svg
|
||||||
|
%%DATADIR%%-0.5/icons/hicolor/scalable/status/user-color-indicator.svg
|
||||||
|
share/help/C/gobby/figures/main_window.png
|
||||||
|
share/help/C/gobby/figures/preferences_appearance.png
|
||||||
|
share/help/C/gobby/figures/preferences_editor.png
|
||||||
|
share/help/C/gobby/figures/preferences_security.png
|
||||||
|
share/help/C/gobby/figures/preferences_user.png
|
||||||
|
share/help/C/gobby/figures/preferences_view.png
|
||||||
|
share/help/C/gobby/index.docbook
|
||||||
|
share/icons/HighContrastLargePrint/48x48/apps/gobby-0.5.png
|
||||||
|
share/icons/HighContrastLargePrint/scalable/apps/gobby-0.5.svg
|
||||||
|
share/icons/HighContrastLargePrintInverse/48x48/apps/gobby-0.5.png
|
||||||
|
share/icons/HighContrastLargePrintInverse/scalable/apps/gobby-0.5.svg
|
||||||
|
share/icons/hicolor/48x48/apps/gobby-0.5.png
|
||||||
|
share/icons/hicolor/scalable/apps/gobby-0.5.svg
|
||||||
|
%%NLS%%share/locale/ca/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/de/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/el_GR/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/en_GB/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/fr/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/it_IT/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/ja/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/pt_BR/LC_MESSAGES/gobby05.mo
|
||||||
|
%%NLS%%share/locale/zh_TW/LC_MESSAGES/gobby05.mo
|
||||||
share/man/man1/gobby.1.gz
|
share/man/man1/gobby.1.gz
|
||||||
%%DATADIR%%/icons/HighContrastLargePrint/48x48/actions/chat.png
|
share/metainfo/gobby-0.5.metainfo.xml
|
||||||
%%DATADIR%%/icons/HighContrastLargePrint/48x48/actions/document-list.png
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrint/48x48/actions/user-list.png
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrint/scalable/actions/chat.svg
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrint/scalable/actions/document-list.svg
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrint/scalable/actions/user-list.svg
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrintInverse/48x48/actions/chat.png
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrintInverse/48x48/actions/document-list.png
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrintInverse/48x48/actions/user-list.png
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrintInverse/scalable/actions/chat.svg
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrintInverse/scalable/actions/document-list.svg
|
|
||||||
%%DATADIR%%/icons/HighContrastLargePrintInverse/scalable/actions/user-list.svg
|
|
||||||
%%DATADIR%%/icons/hicolor/48x48/actions/chat.png
|
|
||||||
%%DATADIR%%/icons/hicolor/48x48/actions/document-list.png
|
|
||||||
%%DATADIR%%/icons/hicolor/48x48/actions/user-list.png
|
|
||||||
%%DATADIR%%/icons/hicolor/scalable/actions/chat.svg
|
|
||||||
%%DATADIR%%/icons/hicolor/scalable/actions/document-list.svg
|
|
||||||
%%DATADIR%%/icons/hicolor/scalable/actions/user-list.svg
|
|
||||||
share/icons/HighContrastLargePrint/48x48/apps/gobby.png
|
|
||||||
share/icons/HighContrastLargePrint/scalable/apps/gobby.svg
|
|
||||||
share/icons/HighContrastLargePrintInverse/48x48/apps/gobby.png
|
|
||||||
share/icons/HighContrastLargePrintInverse/scalable/apps/gobby.svg
|
|
||||||
share/icons/hicolor/48x48/apps/gobby.png
|
|
||||||
share/icons/hicolor/scalable/apps/gobby.svg
|
|
||||||
%%NLS%%share/locale/ast/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/bg/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/ca/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/cs/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/da/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/de/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/el/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/en_GB/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/es/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/eu/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/fi/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/fr/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/gv/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/he/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/hr/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/it/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/ja/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/ko/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/nl/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/oc/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/pl/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/pt/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/pt_BR/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/ru/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/sv/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/th/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/uk/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gobby.mo
|
|
||||||
%%NLS%%share/locale/zh_TW/LC_MESSAGES/gobby.mo
|
|
||||||
|
|
Loading…
Add table
Reference in a new issue