mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
textproc/py-jq: update to 1.3.0
Supports Python 3.11. It would include oniguruma and jq libs in its sources, but let's continue using our separate ports for now. Add support for forcing self-tests under poudriere, masked by a variable that I can set from /usr/local/etc/poudriere.d/make.conf.
This commit is contained in:
parent
ab4b9a63e3
commit
be626dd645
3 changed files with 17 additions and 11 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= jq
|
||||
PORTVERSION= 1.2.2
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= CHEESESHOP LOCAL/mandree:mandree
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -22,16 +22,22 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${PY_FLAVOR}
|
|||
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
|
||||
|
||||
USES= localbase python:3.7-3.10
|
||||
USES= localbase python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
post-extract:
|
||||
# move tests into place - unchanged between 1.2.1 and 1.2.2
|
||||
${MV} ${WRKDIR}/jq-1.2.1/* ${WRKDIR}/jq-1.2.2/
|
||||
${MV} ${WRKDIR}/jq-1.2.1/* ${WRKSRC}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/jq*.so
|
||||
|
||||
.if defined(_MANDREE_FORCE_POUDRIERE_TEST_)
|
||||
BUILD_DEPENDS+= ${TEST_DEPENDS}
|
||||
pre-package:
|
||||
${MAKE} test
|
||||
.endif
|
||||
|
||||
do-test:
|
||||
cd ${WRKSRC} && ${SETENV} \
|
||||
PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
TIMESTAMP = 1644792897
|
||||
SHA256 (jq-1.2.2.tar.gz) = 86ace2c43f17b5a64a38887ede72c7b8ce2ab0bcfa81ee28ff6434e935010abe
|
||||
SIZE (jq-1.2.2.tar.gz) = 72440
|
||||
TIMESTAMP = 1663888297
|
||||
SHA256 (jq-1.3.0.tar.gz) = 96b66f41a91c9794f8051cc32d8fd3206c6409693f0076b22eacb4faa0bc504f
|
||||
SIZE (jq-1.3.0.tar.gz) = 2710829
|
||||
SHA256 (jq-1.2.1-tests.tar.gz) = 7648084f434896eda31bb5e09a4f6d32ebb561660c95655e08346c33be9b3ece
|
||||
SIZE (jq-1.2.1-tests.tar.gz) = 2856
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- setup.py.orig 2021-05-03 13:00:29 UTC
|
||||
--- setup.py.orig 2022-09-19 15:51:09 UTC
|
||||
+++ setup.py
|
||||
@@ -43,8 +43,6 @@ class jq_build_ext(build_ext):
|
||||
@@ -36,8 +36,6 @@ class jq_build_ext(build_ext):
|
||||
def run(self):
|
||||
if not os.path.exists(dependency_path(".")):
|
||||
os.makedirs(dependency_path("."))
|
||||
if not os.path.exists(_dep_build_path(".")):
|
||||
os.makedirs(_dep_build_path("."))
|
||||
- self._build_oniguruma()
|
||||
- self._build_libjq()
|
||||
build_ext.run(self)
|
||||
|
||||
def _build_oniguruma(self):
|
||||
@@ -103,11 +101,7 @@ jq_extension = Extension(
|
||||
@@ -87,11 +85,7 @@ jq_extension = Extension(
|
||||
"jq",
|
||||
sources=["jq.c"],
|
||||
include_dirs=[os.path.join(jq_lib_dir, "src")],
|
||||
|
|
Loading…
Add table
Reference in a new issue