textproc/py-mkdocs-material: Update to 8.5.11

Changelog since 8.4.4:

https://github.com/squidfunk/mkdocs-material/compare/8.4.4...8.5.11
This commit is contained in:
Kai Knoblich 2022-12-20 14:46:39 +01:00
parent 509d001aec
commit bd0faf19d0
3 changed files with 68 additions and 7 deletions

View file

@ -1,8 +1,9 @@
PORTNAME= mkdocs-material
DISTVERSION= 8.4.4
DISTVERSION= 8.5.11
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= mkdocs_material-${DISTVERSION}
MAINTAINER= kai@FreeBSD.org
COMMENT= Material Design theme for MkDocs
@ -13,14 +14,22 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.2:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}markdown>=3.2:textproc/py-markdown@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocs>=1.3.0:textproc/py-mkdocs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocs-material-extensions>=1.0.3:textproc/py-mkdocs-material-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocs>=1.4.0:textproc/py-mkdocs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mkdocs-material-extensions>=1.1:textproc/py-mkdocs-material-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygments>=2.12:textproc/py-pygments@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pymdown-extensions>=9.4:textproc/py-pymdown-extensions@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}pymdown-extensions>=9.4:textproc/py-pymdown-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.26:www/py-requests@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
# Avoid that pyproject.toml is read during setup otherwise build fails
post-extract:
@${MV} ${WRKSRC}/pyproject.toml ${WRKSRC}/pyproject.toml.dist
post-patch:
@${REINPLACE_CMD} -e 's/%%DISTVERSION%%/${DISTVERSION}/' ${WRKSRC}/setup.py
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1670065234
SHA256 (mkdocs-material-8.4.4.tar.gz) = 877cdaff642a224ea50e8f0f0a024c6e4a883c731c2efe4a6aaa4b958f3fd693
SIZE (mkdocs-material-8.4.4.tar.gz) = 3688110
TIMESTAMP = 1671529347
SHA256 (mkdocs_material-8.5.11.tar.gz) = b0ea0513fd8cab323e8a825d6692ea07fa83e917bb5db042e523afecc7064ab7
SIZE (mkdocs_material-8.5.11.tar.gz) = 3533290

View file

@ -0,0 +1,52 @@
Generated via adding
[tool.hatch.build.targets.sdist]
support-legacy = true
to setup.py and then run "hatchling build".
--- setup.py.orig 2022-12-20 10:46:10 UTC
+++ setup.py
@@ -0,0 +1,42 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='mkdocs-material',
+ version='%%DISTVERSION%%',
+ description='Documentation that simply works',
+ long_description='',
+ author_email='Martin Donath <martin.donath@squidfunk.com>',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Web Environment',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: JavaScript',
+ 'Programming Language :: Python',
+ 'Topic :: Documentation',
+ 'Topic :: Software Development :: Documentation',
+ 'Topic :: Text Processing :: Markup :: HTML',
+ ],
+ install_requires=[
+ 'jinja2>=3.0.2',
+ 'markdown>=3.2',
+ 'mkdocs-material-extensions>=1.1',
+ 'mkdocs>=1.4.0',
+ 'pygments>=2.12',
+ 'pymdown-extensions>=9.4',
+ 'requests>=2.26',
+ ],
+ entry_points={
+ 'mkdocs.plugins': [
+ 'search = material.plugins.search.plugin:SearchPlugin',
+ 'social = material.plugins.social.plugin:SocialPlugin',
+ 'tags = material.plugins.tags.plugin:TagsPlugin',
+ ],
+ 'mkdocs.themes': [
+ 'material = material',
+ ],
+ },
+ package_data={
+ '': ['*', '.icons/*', '.icons/*/*', '.icons/*/*/*'],
+ },
+)