mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 23:16:33 -04:00
- update dosbox from 0.58 to 0.60
- updated website address - Use USE_SDL instead of manually specifying devel/sdl12 as LIB_DEPENDS and setting SDL_CONFIG. - Enable screenshot and modem emulation support. - Install the dosbox(1) manual page. - Move the message displayed by the post-install target into a pkg-message so it also gets displayed when this port is installed via its package. - Use DOCSDIR. PR: 58174 Submitted by: Marius Strobl <marius@alchemy.franken.de> Approved by: maintainer
This commit is contained in:
parent
1587b71700
commit
bbe8d41dbd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92780
7 changed files with 45 additions and 39 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= dosbox
|
||||
PORTVERSION= 0.58
|
||||
PORTVERSION= 0.60
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -14,34 +14,38 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= knyghtmare@knyghtmare.com
|
||||
COMMENT= An emulator of a PC with DOS
|
||||
|
||||
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
|
||||
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
LIB_DEPENDS= SDL_net.0:${PORTSDIR}/net/sdl_net \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_SDL= yes
|
||||
|
||||
MAN1= dosbox.1
|
||||
PKGMESSAGE= ${WRKDIR}/pkg-message
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS+= --enable-core-inline
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's#"SDL.h"#<SDL11/SDL.h>#' \
|
||||
${WRKSRC}/src/gui/sdlmain.cpp ${WRKSRC}/src/hardware/mixer.cpp
|
||||
@${REINPLACE_CMD} -e 's#<SDL.h>#<SDL11/SDL.h>#' ${WRKSRC}/include/timer.h
|
||||
@${REINPLACE_CMD} -e 's#"SDL_thread.h"#<SDL11/SDL_thread.h>#' \
|
||||
${WRKSRC}/src/gui/sdlmain.cpp
|
||||
@${REINPLACE_CMD} -e 's#SDL\/#SDL11\/#g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's#\/usr\/share\/doc\/dosbox#${DOCSDIR}#g' \
|
||||
${WRKSRC}/docs/dosbox.1
|
||||
@${SED} 's#%%DOCSDIR%%#${DOCSDIR}#' ${PKGDIR}/pkg-message > \
|
||||
${WRKDIR}/pkg-message
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/dosbox ${PREFIX}/bin/dosbox
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/dosbox.1 ${PREFIX}/man/man1/
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/dosbox
|
||||
${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/dosbox
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dosbox
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD} "================================================="
|
||||
@${ECHO_CMD} "Be sure to read the README for usage instructions"
|
||||
@${ECHO_CMD} "located in ${PREFIX}/share/doc/dosbox by default"
|
||||
@${ECHO_CMD} "================================================="
|
||||
@${CAT} ${WRKDIR}/pkg-message
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (dosbox-0.58.tar.gz) = 91c49a597134f35f899d32a8b253205b
|
||||
MD5 (dosbox-0.60.tar.gz) = ca68955bcc3585630dcf17bab6ec185a
|
||||
|
|
11
emulators/dosbox/files/patch-configure
Normal file
11
emulators/dosbox/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Sun Oct 19 13:46:59 2003
|
||||
+++ configure Sun Oct 19 13:47:15 2003
|
||||
@@ -5350,7 +5350,7 @@
|
||||
|
||||
if test x$enable_core_inline = xyes ; then
|
||||
echo "$as_me:$LINENO: result: enabling inlined memory handling in CPU Core" >&5
|
||||
-echo "${ECHO_T}enabling inlined memory handling in CPU Core" >&6,
|
||||
+echo "${ECHO_T}enabling inlined memory handling in CPU Core" >&6
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define C_CORE_INLINE 1
|
||||
_ACEOF
|
|
@ -1,12 +0,0 @@
|
|||
--- src/gui/sdlmain.cpp.orig Sun May 11 14:05:10 2003
|
||||
+++ src/gui/sdlmain.cpp Sun May 11 14:06:05 2003
|
||||
@@ -39,9 +39,7 @@
|
||||
//#define DISABLE_JOYSTICK
|
||||
#define C_GFXTHREADED 1 //Enabled by default
|
||||
|
||||
-#if defined(MACOSX)
|
||||
extern char** environ;
|
||||
-#endif
|
||||
|
||||
struct SDL_Block {
|
||||
volatile bool active; //If this isn't set don't draw
|
|
@ -4,10 +4,10 @@ local file system for files.
|
|||
|
||||
Currently emulated is:
|
||||
|
||||
o CPU:286/386 realmode
|
||||
o GFX:VGA/EGS/CGA
|
||||
o CPU:286/386 realmode/pmode
|
||||
o GFX:VGA/EGS/CGA/SVGA/VESA
|
||||
o SND:PC-Speaker/Tandy 3-Voice/Adlib/SoundBlaster
|
||||
o MSC:Keyboard/Mouse
|
||||
o DOS:Director FileSystem/XMS/EMS
|
||||
o DOS:Directory FileSystem/XMS/EMS
|
||||
|
||||
WWW: http://dosbox.zophar.net/
|
||||
WWW: http://dosbox.sourceforge.net/
|
||||
|
|
4
emulators/dosbox/pkg-message
Normal file
4
emulators/dosbox/pkg-message
Normal file
|
@ -0,0 +1,4 @@
|
|||
=================================================
|
||||
Be sure to read the README for usage instructions
|
||||
located in %%DOCSDIR%% by default
|
||||
=================================================
|
|
@ -1,5 +1,4 @@
|
|||
bin/dosbox
|
||||
%%PORTDOCS%%share/doc/dosbox/NEWS
|
||||
%%PORTDOCS%%share/doc/dosbox/README
|
||||
%%PORTDOCS%%@dirrm share/doc/dosbox
|
||||
@dirrm share/dosbox
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Add table
Reference in a new issue