misc/{,py-}tvm: update 0.16.0 → 0.19.0

This commit is contained in:
Yuri Victorovich 2025-03-25 00:26:30 -07:00
parent f87e1a7a97
commit b9773e9a2b
6 changed files with 34 additions and 29 deletions

View file

@ -1,6 +1,6 @@
PORTNAME= tvm
DISTVERSIONPREFIX= v
DISTVERSION= 0.16.0
DISTVERSION= 0.19.0
CATEGORIES= misc # machine-learning
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -1,6 +1,6 @@
TIMESTAMP = 1714375347
SHA256 (apache-tvm-v0.16.0_GH0.tar.gz) = c58c316882d545a8cf462bf4ee476591a18de984ee77544589e212b2fae2fa60
SIZE (apache-tvm-v0.16.0_GH0.tar.gz) = 10551522
TIMESTAMP = 1742876552
SHA256 (apache-tvm-v0.19.0_GH0.tar.gz) = f70211dd99339123bddd55e9aadd95cecd0c80ecd113655d5d934a0ee431775e
SIZE (apache-tvm-v0.19.0_GH0.tar.gz) = 9946236
SHA256 (dmlc-dlpack-e2bdd3b_GH0.tar.gz) = e88e702277cf4cfa4814afdbb27b07b75041d80b3df60da387cdd7e0ebeb6817
SIZE (dmlc-dlpack-e2bdd3b_GH0.tar.gz) = 76235
SHA256 (dmlc-dmlc-core-09511cf_GH0.tar.gz) = 8b7ba0e19a9f2c5d65d49758ab14631e99c4f501b689842fa6535fc44a05c46f

View file

@ -0,0 +1,14 @@
- remove bogus paths causing build failure
--- python/setup.py.orig 2025-03-25 06:05:42 UTC
+++ python/setup.py
@@ -75,9 +75,7 @@ def get_lib_path():
"web",
"rust",
"golang",
- "include",
"src",
- "cmake",
"CMakeLists.txt",
]:
for name in lib_path:

View file

@ -1,16 +1,16 @@
PORTNAME= tvm
DISTVERSIONPREFIX= v
DISTVERSION= 0.16.0
DISTVERSION= 0.19.0
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
COMMENT= Deep learning compiler stack for cpu, gpu and specialized accelerators
WWW= https://tvm.ai/
WWW= https://tvm.ai \
https://github.com/apache/tvm
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= compilation fails with the latest dmlc-core, see https://github.com/apache/tvm/issues/17116
BROKEN_armv7= comilation fails: error: expected identifier before '__is_convertible'
BUILD_DEPENDS= dmlc-core>0:devel/dmlc-core \
@ -53,4 +53,10 @@ post-install: # remove empty directories
post-test: # 1 test fails, see https://github.com/apache/tvm/issues/13131
@cd ${TEST_WRKSRC} && ./cpptest
# tests as of 0.19.0, see https://github.com/apache/tvm/issues/17776:
# [ FAILED ] 3 tests, listed below:
# [ FAILED ] AProfileParser.DefaultSVESupportSVESupport
# [ FAILED ] AProfileParser.DefaultFP16Support
# [ FAILED ] InterfaceAPI.ContainsRunFunctionWithWorkspaceAndConstantPools
.include <bsd.port.mk>

View file

@ -1,5 +1,5 @@
TIMESTAMP = 1714370551
SHA256 (apache-tvm-v0.16.0_GH0.tar.gz) = c58c316882d545a8cf462bf4ee476591a18de984ee77544589e212b2fae2fa60
SIZE (apache-tvm-v0.16.0_GH0.tar.gz) = 10551522
TIMESTAMP = 1742872845
SHA256 (apache-tvm-v0.19.0_GH0.tar.gz) = f70211dd99339123bddd55e9aadd95cecd0c80ecd113655d5d934a0ee431775e
SIZE (apache-tvm-v0.19.0_GH0.tar.gz) = 9946236
SHA256 (dmlc-dlpack-e2bdd3b_GH0.tar.gz) = e88e702277cf4cfa4814afdbb27b07b75041d80b3df60da387cdd7e0ebeb6817
SIZE (dmlc-dlpack-e2bdd3b_GH0.tar.gz) = 76235

View file

@ -18,6 +18,7 @@ include/tvm/auto_scheduler/transform_step.h
include/tvm/driver/driver_api.h
include/tvm/ir/adt.h
include/tvm/ir/affine_type.h
include/tvm/ir/analysis.h
include/tvm/ir/attrs.h
include/tvm/ir/diagnostic.h
include/tvm/ir/env_func.h
@ -30,6 +31,7 @@ include/tvm/ir/memory_pools.h
include/tvm/ir/module.h
include/tvm/ir/name_supply.h
include/tvm/ir/op.h
include/tvm/ir/replace_global_vars.h
include/tvm/ir/si_builder.h
include/tvm/ir/source_map.h
include/tvm/ir/tensor_type.h
@ -78,6 +80,7 @@ include/tvm/relax/attrs/manipulate.h
include/tvm/relax/attrs/nn.h
include/tvm/relax/attrs/op.h
include/tvm/relax/attrs/qdq.h
include/tvm/relax/attrs/sampling.h
include/tvm/relax/attrs/search.h
include/tvm/relax/attrs/sorting.h
include/tvm/relax/attrs/statistical.h
@ -147,6 +150,7 @@ include/tvm/runtime/c_runtime_api.h
include/tvm/runtime/container/adt.h
include/tvm/runtime/container/array.h
include/tvm/runtime/container/base.h
include/tvm/runtime/container/boxed_primitive.h
include/tvm/runtime/container/closure.h
include/tvm/runtime/container/map.h
include/tvm/runtime/container/optional.h
@ -155,24 +159,6 @@ include/tvm/runtime/container/string.h
include/tvm/runtime/container/variant.h
include/tvm/runtime/contrib/libtorch_runtime.h
include/tvm/runtime/contrib/papi.h
include/tvm/runtime/crt/aot_executor.h
include/tvm/runtime/crt/aot_executor_module.h
include/tvm/runtime/crt/crt.h
include/tvm/runtime/crt/error_codes.h
include/tvm/runtime/crt/func_registry.h
include/tvm/runtime/crt/graph_executor.h
include/tvm/runtime/crt/graph_executor_module.h
include/tvm/runtime/crt/logging.h
include/tvm/runtime/crt/microtvm_rpc_server.h
include/tvm/runtime/crt/module.h
include/tvm/runtime/crt/packed_func.h
include/tvm/runtime/crt/page_allocator.h
include/tvm/runtime/crt/platform.h
include/tvm/runtime/crt/rpc_common/frame_buffer.h
include/tvm/runtime/crt/rpc_common/framing.h
include/tvm/runtime/crt/rpc_common/session.h
include/tvm/runtime/crt/rpc_common/write_stream.h
include/tvm/runtime/crt/stack_allocator.h
include/tvm/runtime/data_type.h
include/tvm/runtime/debug.h
include/tvm/runtime/device_api.h
@ -187,7 +173,6 @@ include/tvm/runtime/memory/memory_manager.h
include/tvm/runtime/metadata.h
include/tvm/runtime/metadata_base.h
include/tvm/runtime/metadata_types.h
include/tvm/runtime/micro/standalone/microtvm_runtime.h
include/tvm/runtime/module.h
include/tvm/runtime/name_transforms.h
include/tvm/runtime/ndarray.h