mirror of
https://git.freebsd.org/ports.git
synced 2025-05-04 15:37:40 -04:00
audio/vgmplay: switch to new upstream and update to 0.51.1
Changelog: https://github.com/ValleyBell/vgmplay-libvgm/blob/0.51.1/Updates.txt PR: 255297 Reported by: diizzy
This commit is contained in:
parent
7822ccbdbe
commit
b81e5e89ae
6 changed files with 34 additions and 85 deletions
|
@ -1,56 +1,37 @@
|
|||
PORTNAME= vgmplay
|
||||
PORTVERSION= 0.40.9
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.51.1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= https://github.com/vgmrips/${PORTNAME}/releases/download/${PORTVERSION}/
|
||||
DISTNAME= ${PORTNAME:S/vgmp/VGMP/}_${PORTVERSION:S/.//:S/./-/}_src
|
||||
|
||||
MAINTAINER= tagattie@FreeBSD.org
|
||||
COMMENT= Command-line player for VGM (video game music) files
|
||||
WWW= https://github.com/vgmrips/vgmplay
|
||||
WWW= https://vgmrips.net/
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/licenses/GPL.txt
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/vgm-player.pc:audio/libvgm
|
||||
LIB_DEPENDS= libinih.so:devel/inih
|
||||
|
||||
USES= 7z compiler dos2unix gmake
|
||||
USES= cmake iconv pkgconfig
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ValleyBell
|
||||
GH_PROJECT= ${PORTNAME}-libvgm
|
||||
|
||||
OPTIONS_SINGLE= AUDIO
|
||||
OPTIONS_SINGLE_AUDIO= OSS LIBAO
|
||||
OPTIONS_DEFAULT= OSS
|
||||
PLIST_FILES= bin/vgmplay \
|
||||
${EXAMPLESDIR}/vgmplay.ini
|
||||
|
||||
OSS_DESC= Use OSS (/dev/dsp)
|
||||
LIBAO_DESC= Use libao
|
||||
OPTIONS_DEFINE= MEDIACONTROLS
|
||||
OPTIONS_DEFAULT= # none
|
||||
|
||||
OSS_MAKE_ENV+= USE_LIBAO=0
|
||||
LIBAO_MAKE_ENV+= USE_LIBAO=1
|
||||
LIBAO_LIB_DEPENDS= libao.so:audio/libao
|
||||
LIBAO_USES= localbase:ldflags
|
||||
MEDIACONTROLS_DESC= Media Controls via D-Bus
|
||||
|
||||
MAKE_ENV+= PREFIX=${LOCALBASE} ${MAKE_ENV_${ARCH}}
|
||||
MAKE_ENV_powerpc= BYTE_ORDER=2
|
||||
MAKE_ENV_powerpc64= BYTE_ORDER=2
|
||||
MAKE_ENV_powerpc64le= BYTE_ORDER=1
|
||||
MAKE_ENV_powerpcspe= BYTE_ORDER=2
|
||||
|
||||
PLIST_FILES= bin/vgmplay bin/vgm2pcm bin/vgm2wav share/man/man1/vgmplay.1.gz ${EXAMPLESDIR}/vgmplay.ini
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
MEDIACONTROLS_CMAKE_ON= -DMEDIA_CONTROLS:STRING="DBUS"
|
||||
MEDIACONTROLS_CMAKE_OFF=-DMEDIA_CONTROLS:STRING="OFF"
|
||||
MEDIACONTROLS_LIB_DEPENDS= libdbus-1.so:devel/dbus
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/@//' ${WRKSRC}/Makefile
|
||||
.if ${CHOSEN_COMPILER_TYPE} != clang
|
||||
${REINPLACE_CMD} -e 's/-Wno-unused-but-set-variable//' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|; s|/usr/share/vgmplay|${EXAMPLESDIR}|; s|VGMPlay|vgmplay|g;' ${WRKSRC}/vgmplay.1
|
||||
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/main.cpp
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/vgmplay ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/vgm2pcm ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/vgm2wav ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/vgmplay.1 ${STAGEDIR}${PREFIX}/share/man/man1
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/VGMPlay.ini ${STAGEDIR}${EXAMPLESDIR}/vgmplay.ini
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1546946539
|
||||
SHA256 (VGMPlay_040-9_src.7z) = 4f799bb21ba288893a627b0c6d71db84e2d8a74ec8852a092845ad831de8e19a
|
||||
SIZE (VGMPlay_040-9_src.7z) = 586532
|
||||
TIMESTAMP = 1706530727
|
||||
SHA256 (ValleyBell-vgmplay-libvgm-0.51.1_GH0.tar.gz) = 6f9d4817dfb057193d9704e1c5b4aec6dc1226d97aea1bf66546a086e8f61aee
|
||||
SIZE (ValleyBell-vgmplay-libvgm-0.51.1_GH0.tar.gz) = 57618
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- Makefile.orig 2021-01-07 10:55:33 UTC
|
||||
+++ Makefile
|
||||
@@ -58,7 +58,9 @@ endif
|
||||
|
||||
|
||||
|
||||
+ifndef CC
|
||||
CC = gcc
|
||||
+endif
|
||||
ifndef PREFIX
|
||||
PREFIX = /usr/local
|
||||
#PREFIX = $(HOME)/.local
|
||||
@@ -101,7 +103,7 @@ endif
|
||||
|
||||
# -- General Compile Flags --
|
||||
ifeq ($(DEBUG), 0)
|
||||
-CFLAGS := -O3 -g0 $(CFLAGS)
|
||||
+CFLAGS := -g0 $(CFLAGS)
|
||||
else
|
||||
CFLAGS := -g $(CFLAGS)
|
||||
endif
|
|
@ -1,11 +0,0 @@
|
|||
--- Stream.c.orig 2019-01-08 12:56:30 UTC
|
||||
+++ Stream.c
|
||||
@@ -16,6 +16,8 @@
|
||||
#include <fcntl.h>
|
||||
#ifdef __NetBSD__
|
||||
#include <sys/audioio.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+#include <sys/soundcard.h>
|
||||
#elif defined(__APPLE__) || defined(__OpenBSD__)
|
||||
// nothing
|
||||
#else
|
|
@ -1,11 +0,0 @@
|
|||
--- VGMPlay_AddFmts.c.orig 2021-01-06 02:49:31 UTC
|
||||
+++ VGMPlay_AddFmts.c
|
||||
@@ -117,7 +117,7 @@ extern INT32 VGMSmplPlayed;
|
||||
extern INT32 VGMSampleRate;
|
||||
extern UINT32 BlocksSent;
|
||||
extern UINT32 BlocksPlayed;
|
||||
-bool VGMEnd;
|
||||
+extern bool VGMEnd;
|
||||
extern bool EndPlay;
|
||||
extern bool PausePlay;
|
||||
extern bool FadePlay;
|
11
audio/vgmplay/files/patch-main.cpp
Normal file
11
audio/vgmplay/files/patch-main.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- main.cpp.orig 2024-01-29 12:48:26 UTC
|
||||
+++ main.cpp
|
||||
@@ -44,7 +44,7 @@
|
||||
#include "version.h"
|
||||
|
||||
#ifndef SHARE_PREFIX
|
||||
-#define SHARE_PREFIX "/usr"
|
||||
+#define SHARE_PREFIX "%%PREFIX%%"
|
||||
#endif
|
||||
|
||||
|
Loading…
Add table
Reference in a new issue