mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 15:51:51 -04:00
multimedia/wireplumber: Update to 0.5.5
This commit is contained in:
parent
38348ee7d9
commit
b74ea4414a
4 changed files with 9 additions and 110 deletions
|
@ -1,6 +1,5 @@
|
||||||
PORTNAME= wireplumber
|
PORTNAME= wireplumber
|
||||||
DISTVERSION= 0.4.90
|
DISTVERSION= 0.5.5
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= multimedia
|
CATEGORIES= multimedia
|
||||||
|
|
||||||
MAINTAINER= arrowd@FreeBSD.org
|
MAINTAINER= arrowd@FreeBSD.org
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1710556110
|
TIMESTAMP = 1721584922
|
||||||
SHA256 (wireplumber-0.4.90.tar.bz2) = dea5d162f73a94d6b2d834ec4a5ea011e4917343c10869b8fcd72dbad461f32f
|
SHA256 (wireplumber-0.5.5.tar.bz2) = 4926399cffe3da12f1338e1feec53ef944e86ae7c719384bff87490d7e3edbc7
|
||||||
SIZE (wireplumber-0.4.90.tar.bz2) = 398538
|
SIZE (wireplumber-0.5.5.tar.bz2) = 411519
|
||||||
|
|
|
@ -1,98 +0,0 @@
|
||||||
https://gitlab.freedesktop.org/pipewire/wireplumber/-/commit/e9d8eeedefa8
|
|
||||||
|
|
||||||
--- lib/wp/log.h.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ lib/wp/log.h
|
|
||||||
@@ -59,10 +59,12 @@ struct _WpLogTopic {
|
|
||||||
WP_LOG_TOPIC_STATIC(WP_LOCAL_LOG_TOPIC, t)
|
|
||||||
|
|
||||||
/* make glib log functions also use the local log topic */
|
|
||||||
-#ifdef G_LOG_DOMAIN
|
|
||||||
-# undef G_LOG_DOMAIN
|
|
||||||
+#ifdef WP_USE_LOCAL_LOG_TOPIC_IN_G_LOG
|
|
||||||
+# ifdef G_LOG_DOMAIN
|
|
||||||
+# undef G_LOG_DOMAIN
|
|
||||||
+# endif
|
|
||||||
+# define G_LOG_DOMAIN (WP_LOCAL_LOG_TOPIC->topic_name)
|
|
||||||
#endif
|
|
||||||
-#define G_LOG_DOMAIN (WP_LOCAL_LOG_TOPIC->topic_name)
|
|
||||||
|
|
||||||
WP_API
|
|
||||||
void wp_log_topic_init (WpLogTopic *topic);
|
|
||||||
--- lib/wp/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ lib/wp/meson.build
|
|
||||||
@@ -126,6 +126,7 @@ wp_lib = library('wireplumber-' + wireplumber_api_vers
|
|
||||||
c_args : [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
'-DBUILDING_WP',
|
|
||||||
],
|
|
||||||
install: true,
|
|
||||||
--- modules/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ modules/meson.build
|
|
||||||
@@ -1,6 +1,7 @@ common_c_args = [
|
|
||||||
common_c_args = [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
]
|
|
||||||
|
|
||||||
shared_library(
|
|
||||||
--- modules/module-lua-scripting/wplua/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ modules/module-lua-scripting/wplua/meson.build
|
|
||||||
@@ -19,6 +19,7 @@ wplua_lib = static_library('wplua-' + wireplumber_api_
|
|
||||||
c_args : [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
],
|
|
||||||
install: false,
|
|
||||||
include_directories: wplua_include_dir,
|
|
||||||
--- src/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ src/meson.build
|
|
||||||
@@ -33,6 +33,7 @@ if build_daemon
|
|
||||||
c_args : [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
],
|
|
||||||
install: true,
|
|
||||||
dependencies : [gobject_dep, gio_dep, wp_dep, pipewire_dep],
|
|
||||||
--- src/tools/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ src/tools/meson.build
|
|
||||||
@@ -3,6 +3,7 @@ executable('wpctl',
|
|
||||||
c_args : [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
],
|
|
||||||
install: true,
|
|
||||||
dependencies : [gobject_dep, gio_dep, wp_dep, pipewire_dep],
|
|
||||||
@@ -18,6 +19,7 @@ executable('wpexec',
|
|
||||||
c_args : [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
],
|
|
||||||
install: true,
|
|
||||||
dependencies : [gobject_dep, gio_dep, wp_dep, pipewire_dep],
|
|
||||||
--- tests/modules/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ tests/modules/meson.build
|
|
||||||
@@ -5,6 +5,7 @@ common_args = [
|
|
||||||
common_args = [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
]
|
|
||||||
|
|
||||||
if get_option('dbus-tests')
|
|
||||||
--- tests/wp/meson.build.orig 2024-03-04 17:29:09 UTC
|
|
||||||
+++ tests/wp/meson.build
|
|
||||||
@@ -5,6 +5,7 @@ common_args = [
|
|
||||||
common_args = [
|
|
||||||
'-D_GNU_SOURCE',
|
|
||||||
'-DG_LOG_USE_STRUCTURED',
|
|
||||||
+ '-DWP_USE_LOCAL_LOG_TOPIC_IN_G_LOG',
|
|
||||||
]
|
|
||||||
|
|
||||||
test(
|
|
|
@ -44,7 +44,7 @@ include/wireplumber-0.5/wp/wpversion.h
|
||||||
%%DOXYGEN%%lib/girepository-1.0/Wp-0.5.typelib
|
%%DOXYGEN%%lib/girepository-1.0/Wp-0.5.typelib
|
||||||
lib/libwireplumber-0.5.so
|
lib/libwireplumber-0.5.so
|
||||||
lib/libwireplumber-0.5.so.0
|
lib/libwireplumber-0.5.so.0
|
||||||
lib/libwireplumber-0.5.so.0.4.90
|
lib/libwireplumber-0.5.so.0.505.0
|
||||||
lib/wireplumber-0.5/libwireplumber-module-dbus-connection.so
|
lib/wireplumber-0.5/libwireplumber-module-dbus-connection.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-default-nodes-api.so
|
lib/wireplumber-0.5/libwireplumber-module-default-nodes-api.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-file-monitor-api.so
|
lib/wireplumber-0.5/libwireplumber-module-file-monitor-api.so
|
||||||
|
@ -55,7 +55,6 @@ lib/wireplumber-0.5/libwireplumber-module-portal-permissionstore.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-reserve-device.so
|
lib/wireplumber-0.5/libwireplumber-module-reserve-device.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-settings.so
|
lib/wireplumber-0.5/libwireplumber-module-settings.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-si-audio-adapter.so
|
lib/wireplumber-0.5/libwireplumber-module-si-audio-adapter.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-si-audio-virtual.so
|
|
||||||
lib/wireplumber-0.5/libwireplumber-module-si-node.so
|
lib/wireplumber-0.5/libwireplumber-module-si-node.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-si-standard-link.so
|
lib/wireplumber-0.5/libwireplumber-module-si-standard-link.so
|
||||||
lib/wireplumber-0.5/libwireplumber-module-standard-event-source.so
|
lib/wireplumber-0.5/libwireplumber-module-standard-event-source.so
|
||||||
|
@ -134,23 +133,23 @@ libdata/pkgconfig/wireplumber-0.5.pc
|
||||||
%%DATADIR%%/scripts/device/state-profile.lua
|
%%DATADIR%%/scripts/device/state-profile.lua
|
||||||
%%DATADIR%%/scripts/device/state-routes.lua
|
%%DATADIR%%/scripts/device/state-routes.lua
|
||||||
%%DATADIR%%/scripts/fallback-sink.lua
|
%%DATADIR%%/scripts/fallback-sink.lua
|
||||||
%%DATADIR%%/scripts/intended-roles.lua
|
|
||||||
%%DATADIR%%/scripts/lib/common-utils.lua
|
%%DATADIR%%/scripts/lib/common-utils.lua
|
||||||
%%DATADIR%%/scripts/lib/device-info-cache.lua
|
%%DATADIR%%/scripts/lib/device-info-cache.lua
|
||||||
%%DATADIR%%/scripts/lib/filter-utils.lua
|
%%DATADIR%%/scripts/lib/filter-utils.lua
|
||||||
%%DATADIR%%/scripts/lib/linking-utils.lua
|
%%DATADIR%%/scripts/lib/linking-utils.lua
|
||||||
%%DATADIR%%/scripts/lib/monitor-utils.lua
|
%%DATADIR%%/scripts/lib/monitor-utils.lua
|
||||||
|
%%DATADIR%%/scripts/lib/node-utils.lua
|
||||||
%%DATADIR%%/scripts/linking/find-best-target.lua
|
%%DATADIR%%/scripts/linking/find-best-target.lua
|
||||||
%%DATADIR%%/scripts/linking/find-default-target.lua
|
%%DATADIR%%/scripts/linking/find-default-target.lua
|
||||||
%%DATADIR%%/scripts/linking/find-defined-target.lua
|
%%DATADIR%%/scripts/linking/find-defined-target.lua
|
||||||
%%DATADIR%%/scripts/linking/find-filter-target.lua
|
%%DATADIR%%/scripts/linking/find-filter-target.lua
|
||||||
|
%%DATADIR%%/scripts/linking/find-media-role-target.lua
|
||||||
%%DATADIR%%/scripts/linking/find-user-target.lua.example
|
%%DATADIR%%/scripts/linking/find-user-target.lua.example
|
||||||
%%DATADIR%%/scripts/linking/find-virtual-target.lua
|
|
||||||
%%DATADIR%%/scripts/linking/get-filter-from-target.lua
|
%%DATADIR%%/scripts/linking/get-filter-from-target.lua
|
||||||
%%DATADIR%%/scripts/linking/link-target.lua
|
%%DATADIR%%/scripts/linking/link-target.lua
|
||||||
%%DATADIR%%/scripts/linking/prepare-link.lua
|
%%DATADIR%%/scripts/linking/prepare-link.lua
|
||||||
%%DATADIR%%/scripts/linking/rescan-virtual-links.lua
|
|
||||||
%%DATADIR%%/scripts/linking/rescan.lua
|
%%DATADIR%%/scripts/linking/rescan.lua
|
||||||
|
%%DATADIR%%/scripts/linking/rescan-media-role-links.lua
|
||||||
%%DATADIR%%/scripts/metadata.lua
|
%%DATADIR%%/scripts/metadata.lua
|
||||||
%%DATADIR%%/scripts/monitors/alsa-midi.lua
|
%%DATADIR%%/scripts/monitors/alsa-midi.lua
|
||||||
%%DATADIR%%/scripts/monitors/alsa.lua
|
%%DATADIR%%/scripts/monitors/alsa.lua
|
||||||
|
@ -167,11 +166,10 @@ libdata/pkgconfig/wireplumber-0.5.pc
|
||||||
%%DATADIR%%/scripts/monitors/v4l2/name-device.lua
|
%%DATADIR%%/scripts/monitors/v4l2/name-device.lua
|
||||||
%%DATADIR%%/scripts/monitors/v4l2/name-node.lua
|
%%DATADIR%%/scripts/monitors/v4l2/name-node.lua
|
||||||
%%DATADIR%%/scripts/node/create-item.lua
|
%%DATADIR%%/scripts/node/create-item.lua
|
||||||
%%DATADIR%%/scripts/node/create-virtual-item.lua
|
|
||||||
%%DATADIR%%/scripts/node/filter-forward-format.lua
|
%%DATADIR%%/scripts/node/filter-forward-format.lua
|
||||||
|
%%DATADIR%%/scripts/node/software-dsp.lua
|
||||||
%%DATADIR%%/scripts/node/state-stream.lua
|
%%DATADIR%%/scripts/node/state-stream.lua
|
||||||
%%DATADIR%%/scripts/node/suspend-node.lua
|
%%DATADIR%%/scripts/node/suspend-node.lua
|
||||||
%%DATADIR%%/scripts/policy-dsp.lua
|
|
||||||
%%DATADIR%%/scripts/sm-objects.lua
|
%%DATADIR%%/scripts/sm-objects.lua
|
||||||
%%DATADIR%%/wireplumber.conf
|
%%DATADIR%%/wireplumber.conf
|
||||||
%%DATADIR%%/wireplumber.conf.d/alsa-vm.conf
|
%%DATADIR%%/wireplumber.conf.d/alsa-vm.conf
|
||||||
|
|
Loading…
Add table
Reference in a new issue