audio/py-soxr: update 0.3.7 → 0.4.0

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2024-07-26 00:48:04 -07:00
parent 63806c7d1f
commit b618c1a1cb
3 changed files with 13 additions and 8 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= soxr
DISTVERSION= 0.3.7
DISTVERSION= 0.4.0
CATEGORIES= audio python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -14,13 +14,14 @@ LICENSE_COMB= multi
BROKEN_i386= fails to compile: ...requires target feature 'sse', but would be inlined into function 'h8' that is compiled without support for 'sse'
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}cython3>0:lang/cython3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-scm>0:devel/py-setuptools-scm@${PY_FLAVOR} \
${PYNUMPY} \
${PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
USES= python
USE_PYTHON= pep517 cython autoplist pytest
USE_PYTHON= pep517 autoplist pytest
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1704347538
SHA256 (soxr-0.3.7.tar.gz) = 436ddff00c6eb2c75b79c19cfdca7527b1e31b5fad738652f044045ba6258593
SIZE (soxr-0.3.7.tar.gz) = 296432
TIMESTAMP = 1721972280
SHA256 (soxr-0.4.0.tar.gz) = 02385e3de07e28ddbc19ab41216075d889575895e778ce2ada950d5f46cf6a52
SIZE (soxr-0.4.0.tar.gz) = 300434

View file

@ -1,13 +1,17 @@
--- pyproject.toml.orig 2023-08-15 13:45:59 UTC
--- pyproject.toml.orig 2024-07-25 13:58:38 UTC
+++ pyproject.toml
@@ -2,9 +2,9 @@
@@ -2,13 +2,13 @@ requires = [
requires = [
"setuptools>=42",
"wheel",
- "Cython>=3.0a7",
+ "Cython",
"setuptools_scm[toml]>=6.2",
- "oldest-supported-numpy"
# Note for packagers: this constraint is specific to wheels
# for PyPI; it is also supported to build against 1.xx still.
# If you do so, please ensure to include a `numpy<2.0`
# runtime requirement for those binary packages.
- "numpy>=2.0.0rc1"
+ "numpy"
]
build-backend = "setuptools.build_meta"