mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
net/bctoolbox: Update version 5.2.94=>5.4.2
Changelog: https://gitlab.linphone.org/BC/public/bctoolbox/-/tags/5.4.2 Sponsored by: Cybermancer Infosec
This commit is contained in:
parent
3f91dfca84
commit
b3cfd4f7da
5 changed files with 28 additions and 42 deletions
|
@ -1,6 +1,5 @@
|
||||||
PORTNAME= bctoolbox
|
PORTNAME= bctoolbox
|
||||||
DISTVERSION= 5.2.94
|
DISTVERSION= 5.4.2
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= net
|
CATEGORIES= net
|
||||||
|
|
||||||
MAINTAINER= bofh@FreeBSD.org
|
MAINTAINER= bofh@FreeBSD.org
|
||||||
|
@ -10,14 +9,11 @@ WWW= https://gitlab.linphone.org/BC/public/bctoolbox
|
||||||
LICENSE= GPLv3
|
LICENSE= GPLv3
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||||
|
|
||||||
DEPRECATED= Depends on expired security/mbedtls2
|
IGNORE_FreeBSD_13= is not supported on systems with OpenSSL 1.1.1
|
||||||
EXPIRATION_DATE=2025-03-31
|
|
||||||
|
|
||||||
BUILD_DEPENDS= mbedtls2>=2.3.0_2:security/mbedtls2
|
BUILD_DEPENDS= ${LOCALBASE}/lib/libbcunit.a:devel/bcunit
|
||||||
LIB_DEPENDS= libbcunit.so:devel/bcunit \
|
|
||||||
libmbedtls.so:security/mbedtls2
|
|
||||||
|
|
||||||
USES= cmake compiler:c++17-lang
|
USES= cmake compiler:c++17-lang ssl
|
||||||
USE_GITLAB= yes
|
USE_GITLAB= yes
|
||||||
GL_SITE= https://gitlab.linphone.org/BC
|
GL_SITE= https://gitlab.linphone.org/BC
|
||||||
GL_ACCOUNT= public
|
GL_ACCOUNT= public
|
||||||
|
@ -25,9 +21,12 @@ USE_LDCONFIG= yes
|
||||||
|
|
||||||
CMAKE_ARGS= -DENABLE_STATIC=NO -DENABLE_STRICT=NO \
|
CMAKE_ARGS= -DENABLE_STATIC=NO -DENABLE_STRICT=NO \
|
||||||
-DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
-DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
||||||
-DCMAKE_SKIP_INSTALL_RPATH=ON
|
-DCMAKE_SKIP_INSTALL_RPATH=ON \
|
||||||
|
-DENABLE_MBEDTLS=OFF -DENABLE_OPENSSL=ON \
|
||||||
|
-DENABLE_UNIT_TESTS=OFF
|
||||||
|
|
||||||
CFLAGS+= -DHAVE_ARC4RANDOM
|
CFLAGS+= -DHAVE_ARC4RANDOM
|
||||||
|
LDFLAGS+= -lpthread
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} '/clock_gettime/d' ${WRKSRC}/CMakeLists.txt
|
@${REINPLACE_CMD} '/clock_gettime/d' ${WRKSRC}/CMakeLists.txt
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1690557275
|
TIMESTAMP = 1743002376
|
||||||
SHA256 (bctoolbox-5.2.94.tar.bz2) = d4e81d6e7aeb19e0d2bb4f7aa0645273469507cf1f3ab66ae742f39944cd2503
|
SHA256 (bctoolbox-5.4.2.tar.bz2) = c81ec178f267bc8bd459fe5631df222aefa9b3f458db06bdd30ee81deffc79cc
|
||||||
SIZE (bctoolbox-5.2.94.tar.bz2) = 159511
|
SIZE (bctoolbox-5.4.2.tar.bz2) = 170953
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- src/CMakeLists.txt.orig 2023-03-14 19:53:03 UTC
|
|
||||||
+++ src/CMakeLists.txt
|
|
||||||
@@ -195,6 +195,7 @@ if(ENABLE_SHARED)
|
|
||||||
)
|
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
+ target_link_libraries(bctoolbox PRIVATE execinfo)
|
|
||||||
if(HAVE_LIBRT)
|
|
||||||
target_link_libraries(bctoolbox PRIVATE rt)
|
|
||||||
endif()
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- src/utils/port.c.orig 2023-03-14 19:53:03 UTC
|
--- src/utils/port.c.orig 2025-03-11 08:53:26 UTC
|
||||||
+++ src/utils/port.c
|
+++ src/utils/port.c
|
||||||
@@ -371,7 +371,7 @@ void bctbx_set_self_thread_name(const char *name){
|
@@ -361,7 +361,7 @@ void bctbx_set_self_thread_name(const char *name) {
|
||||||
prctl(PR_SET_NAME, name, NULL, NULL, NULL);
|
prctl(PR_SET_NAME, name, NULL, NULL, NULL);
|
||||||
#elif TARGET_OS_MAC
|
#elif TARGET_OS_MAC
|
||||||
pthread_setname_np(name);
|
pthread_setname_np(name);
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
bctbx_warning("bctbx_set_self_thread_name(): not implemented on this platform.");
|
bctbx_warning("bctbx_set_self_thread_name(): not implemented on this platform.");
|
||||||
#endif
|
#endif
|
||||||
}
|
}
|
||||||
@@ -1642,7 +1642,7 @@ void bctbx_sockaddr_remove_nat64_mapping(const struct
|
@@ -1639,7 +1639,7 @@ void bctbx_sockaddr_remove_nat64_mapping(const struct
|
||||||
if (htonl(0x0064ff9b) ==
|
if (htonl(0x0064ff9b) ==
|
||||||
#ifdef _MSC_VER
|
#ifdef _MSC_VER
|
||||||
((in6->sin6_addr.u.Word[0] << 16) & in6->sin6_addr.u.Word[1])
|
((in6->sin6_addr.u.Word[0] << 16) & in6->sin6_addr.u.Word[1])
|
||||||
|
|
|
@ -1,4 +1,3 @@
|
||||||
bin/bctoolbox_tester
|
|
||||||
include/bctoolbox/charconv.h
|
include/bctoolbox/charconv.h
|
||||||
include/bctoolbox/compiler.h
|
include/bctoolbox/compiler.h
|
||||||
include/bctoolbox/crypto.h
|
include/bctoolbox/crypto.h
|
||||||
|
@ -19,18 +18,16 @@ include/bctoolbox/vconnect.h
|
||||||
include/bctoolbox/vfs.h
|
include/bctoolbox/vfs.h
|
||||||
include/bctoolbox/vfs_encrypted.hh
|
include/bctoolbox/vfs_encrypted.hh
|
||||||
include/bctoolbox/vfs_standard.h
|
include/bctoolbox/vfs_standard.h
|
||||||
lib/libbctoolbox.so
|
lib/libbctoolbox.a
|
||||||
lib/libbctoolbox.so.1
|
lib/libbctoolbox-tester.a
|
||||||
lib/libbctoolbox-tester.so
|
|
||||||
lib/libbctoolbox-tester.so.1
|
|
||||||
libdata/pkgconfig/bctoolbox.pc
|
libdata/pkgconfig/bctoolbox.pc
|
||||||
libdata/pkgconfig/bctoolbox-tester.pc
|
libdata/pkgconfig/bctoolbox-tester.pc
|
||||||
%%DATADIR%%/cmake/ConfigureSpecfile.cmake
|
share/BCToolbox/cmake/ConfigureSpecfile.cmake
|
||||||
%%DATADIR%%/cmake/MakeArchive.cmake
|
share/BCToolbox/cmake/MakeArchive.cmake
|
||||||
%%DATADIR%%/cmake/bctoolboxCMakeUtils.cmake
|
share/BCToolbox/cmake/BCToolboxCMakeUtils.cmake
|
||||||
%%DATADIR%%/cmake/bctoolboxConfig.cmake
|
share/BCToolbox/cmake/BCToolboxConfig.cmake
|
||||||
%%DATADIR%%/cmake/bctoolboxConfigVersion.cmake
|
share/BCToolbox/cmake/BCToolboxConfigVersion.cmake
|
||||||
%%DATADIR%%/cmake/bctoolboxTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
share/BCToolbox/cmake/BCToolboxTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||||
%%DATADIR%%/cmake/bctoolboxTargets.cmake
|
share/BCToolbox/cmake/BCToolboxTargets.cmake
|
||||||
%%DATADIR%%/cmake/BcGitVersion.cmake
|
share/BCToolbox/cmake/BCGitVersion.cmake
|
||||||
%%DATADIR%%/cmake/gitversion.h.in
|
share/BCToolbox/cmake/gitversion.h.in
|
||||||
|
|
Loading…
Add table
Reference in a new issue