mirror of
https://git.freebsd.org/ports.git
synced 2025-05-04 23:47:37 -04:00
mail/notmuch: Update to 0.31
Changelog: https://notmuchmail.org/news/release-0.31/ Add patch to fix a build issue with mail/notmuch-emacs.
This commit is contained in:
parent
e18e1fe025
commit
b39c55cd11
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548369
7 changed files with 34 additions and 9 deletions
|
@ -57,6 +57,8 @@ do-configure:
|
||||||
WITH_EMACS=1 \
|
WITH_EMACS=1 \
|
||||||
${CONFIGURE_ARGS} \
|
${CONFIGURE_ARGS} \
|
||||||
> ${WRKSRC}/Makefile.config
|
> ${WRKSRC}/Makefile.config
|
||||||
|
@${PRINTF} "tags.add('WITH_EMACS')\nrsti_dir = '${WRKSRC}/emacs'\n" \
|
||||||
|
> ${WRKSRC}/sphinx.config
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@${GZIP_CMD} ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}/*.el
|
@${GZIP_CMD} ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}/*.el
|
||||||
|
|
|
@ -2,7 +2,7 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= notmuch
|
PORTNAME= notmuch
|
||||||
PORTVERSION= 0.30
|
PORTVERSION= 0.31
|
||||||
PORTREVISION?= 0
|
PORTREVISION?= 0
|
||||||
CATEGORIES?= mail
|
CATEGORIES?= mail
|
||||||
MASTER_SITES= https://notmuchmail.org/releases/
|
MASTER_SITES= https://notmuchmail.org/releases/
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1596897922
|
TIMESTAMP = 1599486775
|
||||||
SHA256 (notmuch-0.30.tar.xz) = 5e3baa6fe11d65c67e26ae488be11b320bae04e336acc9c64621f7e3449096fa
|
SHA256 (notmuch-0.31.tar.xz) = 571fa0e1539c86612b1f2b2c80a398e08ecfef52e27ef7e48cf8e3b84fa18394
|
||||||
SIZE (notmuch-0.30.tar.xz) = 711904
|
SIZE (notmuch-0.31.tar.xz) = 713144
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- configure.orig 2020-07-11 01:25:04 UTC
|
--- configure.orig 2020-09-06 00:50:03 UTC
|
||||||
+++ configure
|
+++ configure
|
||||||
@@ -753,6 +753,7 @@ if command -v ${BASHCMD} > /dev/null; then
|
@@ -734,6 +734,7 @@ if command -v ${BASHCMD} > /dev/null; then
|
||||||
printf "Yes (%s).\n" "$bash_absolute"
|
printf "Yes (%s).\n" "$bash_absolute"
|
||||||
else
|
else
|
||||||
have_bash=0
|
have_bash=0
|
||||||
|
@ -8,7 +8,7 @@
|
||||||
printf "No. (%s not found)\n" "${BASHCMD}"
|
printf "No. (%s not found)\n" "${BASHCMD}"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@@ -763,6 +764,7 @@ if command -v ${PERL} > /dev/null; then
|
@@ -744,6 +745,7 @@ if command -v ${PERL} > /dev/null; then
|
||||||
printf "Yes (%s).\n" "$perl_absolute"
|
printf "Yes (%s).\n" "$perl_absolute"
|
||||||
else
|
else
|
||||||
have_perl=0
|
have_perl=0
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
--- emacs/notmuch-emacs-mua.orig 2017-07-18 20:34:56 UTC
|
--- emacs/notmuch-emacs-mua.orig 2020-09-06 00:50:03 UTC
|
||||||
+++ emacs/notmuch-emacs-mua
|
+++ emacs/notmuch-emacs-mua
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env bash
|
-#!/usr/bin/env bash
|
||||||
|
@ -33,3 +33,4 @@
|
||||||
+if [ -z "$USE_EMACSCLIENT" ] || [ -n "$CREATE_FRAME" ] || [ -n "$NO_WINDOW" ]; then
|
+if [ -z "$USE_EMACSCLIENT" ] || [ -n "$CREATE_FRAME" ] || [ -n "$NO_WINDOW" ]; then
|
||||||
ELISP="${ELISP} (message-add-action #'save-buffers-kill-terminal 'exit)"
|
ELISP="${ELISP} (message-add-action #'save-buffers-kill-terminal 'exit)"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
22
mail/notmuch/files/patch-emacs_notmuch-tree.el
Normal file
22
mail/notmuch/files/patch-emacs_notmuch-tree.el
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
From: William Casarin <jackbox55@gmail.com>
|
||||||
|
|
||||||
|
Some are running into undeclarated function errors
|
||||||
|
|
||||||
|
> emacs/notmuch-tree.el:1143:1:Warning: the following functions are
|
||||||
|
> not known to be defined: notmuch-search-previous-thread,
|
||||||
|
> notmuch-search-next-thread, notmuch-tree-from-search-thread
|
||||||
|
|
||||||
|
Reported-by: Danilo G. Baio <dbaio@FreeBSD.org>
|
||||||
|
Signed-off-by: William Casarin <jb55@jb55.com>
|
||||||
|
--- emacs/notmuch-tree.el.orig 2020-09-06 00:50:03 UTC
|
||||||
|
+++ emacs/notmuch-tree.el
|
||||||
|
@@ -41,6 +41,9 @@
|
||||||
|
(declare-function notmuch-read-query "notmuch" (prompt))
|
||||||
|
(declare-function notmuch-search-find-thread-id "notmuch" (&optional bare))
|
||||||
|
(declare-function notmuch-search-find-subject "notmuch" ())
|
||||||
|
+(declare-function notmuch-search-next-thread "notmuch" ())
|
||||||
|
+(declare-function notmuch-search-previous-thread "notmuch" ())
|
||||||
|
+(declare-function notmuch-tree-from-search-thread "notmuch" ())
|
||||||
|
|
||||||
|
;; the following variable is defined in notmuch.el
|
||||||
|
(defvar notmuch-search-query-string)
|
|
@ -21,7 +21,7 @@ bin/notmuch
|
||||||
include/notmuch.h
|
include/notmuch.h
|
||||||
lib/libnotmuch.so
|
lib/libnotmuch.so
|
||||||
lib/libnotmuch.so.5
|
lib/libnotmuch.so.5
|
||||||
lib/libnotmuch.so.5.2.0
|
lib/libnotmuch.so.5.3.0
|
||||||
share/bash-completion/completions/notmuch
|
share/bash-completion/completions/notmuch
|
||||||
share/zsh/site-functions/_email-notmuch
|
share/zsh/site-functions/_email-notmuch
|
||||||
share/zsh/site-functions/_notmuch
|
share/zsh/site-functions/_notmuch
|
||||||
|
|
Loading…
Add table
Reference in a new issue