mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
textproc/py-vbuild: Fix BUILD_DEPENDS
- While I'm here, remove incorrect/unnecessary patch-pyproject.toml for python and pscript in tool.poetry.dependencies section - Bump PORTREVISION for package change Approved by: portmgr (blanket) With hat: python
This commit is contained in:
parent
bf835f906e
commit
af95c62c12
2 changed files with 9 additions and 11 deletions
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= vbuild
|
||||
DISTVERSION= 0.8.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -11,7 +12,7 @@ WWW= https://github.com/manatlan/vbuild
|
|||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry>=0:devel/py-poetry@${PY_FLAVOR}
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pscript>=0:textproc/py-pscript@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
|
|
|
@ -1,13 +1,10 @@
|
|||
--- pyproject.toml.orig 2024-10-26 18:30:53 UTC
|
||||
--- pyproject.toml.orig 2023-08-03 09:26:18 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -16,8 +16,8 @@ classifiers = [
|
||||
]
|
||||
@@ -30,5 +30,5 @@ enum-compat = { version = "^0.0.2", python = "~2.7" }
|
||||
|
||||
[tool.poetry.dependencies]
|
||||
-python = "^2.7 || ^3.6"
|
||||
-pscript = "^0.7.0"
|
||||
+python = "^3.11"
|
||||
+pscript = "^0.7.7"
|
||||
|
||||
[tool.poetry.dev-dependencies]
|
||||
pytest = "^3.0"
|
||||
[build-system]
|
||||
-requires = ["poetry>=0.12"]
|
||||
-build-backend = "poetry.masonry.api"
|
||||
+requires = ["poetry-core>=1.0.0"]
|
||||
+build-backend = "poetry.core.masonry.api"
|
||||
|
|
Loading…
Add table
Reference in a new issue