Split the postgresql ports into a server and a client part.

The tcltk interface has been removed from the main distribution, so
fixate the version number to the latest released version, 7.4.6.

PR:		75344
Approved by:	portmgr@ (kris), ade & sean (mentors)
This commit is contained in:
Palle Girgensohn 2005-01-31 00:20:43 +00:00
parent efcaba0c16
commit ae2c26ad44
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127736
4 changed files with 19 additions and 49 deletions

View file

@ -1,23 +1,26 @@
# New ports collection makefile for: PostgreSQL JDBC
# New ports collection makefile for: PostgreSQL Tcl/Tk
# Date created: January 14, 2002
# Whom: Palle Girgensohn <girgen@partitur.se>
#
# $FreeBSD$
#
PORTREVISION= 1
CATEGORIES= databases tcl${TCLVERSION:S/.//}
PORTNAME= postgresql
PORTREVISION= 0
CATEGORIES?= databases tcl${TCLVERSION:C/[^0-9]//g}
PKGNAMESUFFIX= -tcltk
MAINTAINER= girgen@FreeBSD.org
COMMENT= An TCL interface to the database PostgreSQL, including a tk GUI
COMMENT= A TCL interface to the database PostgreSQL, including a tk GUI
POSTGRESQL_PORT?= databases/postgresql7
POSTGRESQL_SUBPORT=YES
.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
TCLPORTDIR?= ${PORTSDIR}/lang/tcl
TKPORTDIR?= ${PORTSDIR}/x11-toolkits/tk
LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${TCLPORTDIR}${TCLVERSION:C/[^0-9]//g}
LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//} \
pq:${PORTSDIR}/${POSTGRESQL_PORT}
USE_PGSQL= yes
MASTERDIR= ${.CURDIR}/../../databases/postgresql74-server
CONFLICTS= ${PORTNAME}${PKGNAMESUFFIX}-7.[0-3]*
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
TCLVERSION?= 8.4
@ -47,26 +50,21 @@ PLIST_SUB+= TK="@comment "
CONFIGURE_ARGS+= --with-tkconfig="${TKCONFIG}"
TK_INCDIR= ${LOCALBASE}/include/tk${TCLVERSION}
CONFIGURE_ENV+= WISH=${LOCALBASE}/bin/wish${TCLVERSION}
LIB_DEPENDS+= tk${TCLVERSION:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCLVERSION:S/.//}
LIB_DEPENDS+= tk${TCLVERSION:S/.//}:${TKPORTDIR}${TCLVERSION:C/[^0-9]//g}
TKCONFIG= ${LOCALBASE}/lib/tk${TCLVERSION}
INCDIRS= ${TCL_INCDIR}:${TK_INCDIR}
PLIST_SUB+= TK=""
CATEGORIES+= tk${TCLVERSION:S/.//}
CATEGORIES+= tk${TCLVERSION:C/[^0-9]//g}
.endif
pre-build:
cd ${WRKSRC}/src/port; ${GMAKE}
BUILD_DIRS= src/port ${INSTALL_DIRS}
INSTALL_DIRS= src/bin/pgtclsh src/interfaces/libpgtcl
SLAVE_ONLY= yes
do-build:
@ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/bin/pgtclsh
@ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/interfaces/libpgtcl
do-install:
@ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/bin/pgtclsh install
@ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/interfaces/libpgtcl install
post-install:
# Preparing a loadable TCL-package (pkgIndex.tcl)
@${MKDIR} ${PREFIX}/lib/tcl${TCLVERSION}/Pgtcl1.3
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pkgIndex.tcl.in \
> ${PREFIX}/lib/tcl${TCLVERSION}/Pgtcl1.3/pkgIndex.tcl
.include <bsd.port.mk>
.include "${MASTERDIR}/Makefile"

View file

@ -1,11 +0,0 @@
--- src/interfaces/libpgtcl/Makefile.orig Tue Feb 10 08:26:48 2004
+++ src/interfaces/libpgtcl/Makefile Thu Mar 11 21:12:25 2004
@@ -21,7 +21,7 @@
OBJS= pgtcl.o pgtclCmds.o pgtclId.o
SHLIB_LINK = $(libpq) $(TCL_LIB_SPEC) $(TCL_LIBS) \
- $(filter -lintl -lssl -lcrypto -lkrb5 -lcrypt, $(LIBS)) $(THREAD_LIBS)
+ $(filter -lintl -lssl -lcrypto -lkrb5 -lcrypt -L% -ltcl83 -ltcl84, $(LIBS)) $(THREAD_LIBS)
all: submake-libpq all-lib

View file

@ -1,8 +0,0 @@
libpgtcl is a library that implements Tcl commands for front-end
clients to interact with the Postgresql backends.
pgaccess is a great graphical database management tool for PostgreSQL.
This software is part of the standard PostgreSQL distribution.
WWW: http://www.postgresql.org/

View file

@ -1,9 +0,0 @@
bin/pgtclsh
include/libpgtcl.h
lib/tcl%%TCLVERSION%%/Pgtcl1.3/pkgIndex.tcl
@dirrm lib/tcl%%TCLVERSION%%/Pgtcl1.3
@dirrm lib/tcl%%TCLVERSION%%
lib/libpgtcl.a
lib/libpgtcl.so
lib/libpgtcl.so.2
%%TK%%bin/pgtksh