Unbreak for 5.X.

Use the same CONFIGURE_TARGET as other ports.
Allow the manpage to be compressed.

Submitted by:	Sergey Kolobov <sergei@kolobov.com>
Approved by:	maintainer (timeout after > 1 month)
PR:		53178
This commit is contained in:
Sergey A. Osokin 2003-07-15 12:49:20 +00:00
parent 1502fdc1db
commit add2a21336
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84917
3 changed files with 40 additions and 11 deletions

View file

@ -14,19 +14,11 @@ MAINTAINER= bjk@m-net.arbornet.org
COMMENT= Show information about local users
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= ui.1
MANCOMPRESSED= no
CONFIGURE_TARGET=
pre-build:
${CP} ${WRKSRC}/doc/ui.man ${WRKSRC}/doc/ui.1
${MV} ${WRKSRC}/doc/ui.man ${WRKSRC}/doc/ui.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
BROKEN= "Doesn't work on 5.x, mainainter informed - 2003-04-07"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- src/common.h.orig Sat Jun 14 02:45:40 2003
+++ src/common.h Sat Jun 14 02:21:13 2003
@@ -16,6 +16,7 @@
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
+#include <sys/types.h>
#include <pwd.h>
#include "config.h"

View file

@ -0,0 +1,27 @@
--- src/process.c.orig Sat Jun 14 02:33:21 2003
+++ src/process.c Sat Jun 14 02:42:29 2003
@@ -63,15 +63,24 @@
}
for (i = 0; i < cnt; i++) {
+#if __FreeBSD_version < 500000
if (kp[i].kp_eproc.e_flag & EPROC_SLEADER && kp[i].kp_eproc.e_tdev !=
-1) {
pid = kp[i].kp_proc.p_pid;
+#else
+ if (kp[i].ki_kiflag & KI_SLEADER && kp[i].ki_tdev != -1) {
+ pid = kp[i].ki_pid;
+#endif
break;
}
}
if (!pid)
+#if __FreeBSD_version < 500000
pid = kp[0].kp_eproc.e_ppid;
+#else
+ pid = kp[0].ki_ppid;
+#endif
return (pid > 1) ? pid : -1;
}