mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
comms/hamlib: Update to 4.6.2
Fixed missing README.md in pkg-plist Version 4.6.2 * Add missing levels for IC746/PRO RIG_LEVEL_RFPOWER_METER,RIG_LEVEL_RFPOWER_METER_WATTS,RIG_LEVEL_SWR,RIG_LEVEL_ALC * Fix IC905 for gpredict * Fix potential segfault on QMX * Fix pmr171 Version 4.6.1 * Fix C++ builds failing on rig_list_foreach function * Fix IC9100 rigctld startup to end up on VFOA * Fix grig build by removing sys/socket.h -- apparently not needed * Add new QMX entry to fix incompability with QDX * Fix IC746/PROT to not use data byte * FLRig to add DATA-U DATA-L modes * Fix TS570 RIG_LEVEL_STRENGTH with cal table * Remove get_powerstat from IC785X -- not supported * Fix SDRConsole by removing lots of things it does not have PR: ports/285061 Reported by: takefu@airport.fm
This commit is contained in:
parent
6958a06301
commit
adcfc4eaba
6 changed files with 29 additions and 32 deletions
|
@ -1,6 +1,5 @@
|
||||||
PORTNAME= hamlib
|
PORTNAME= hamlib
|
||||||
PORTVERSION= 4.5.5
|
PORTVERSION= 4.6.2
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= comms hamradio
|
CATEGORIES= comms hamradio
|
||||||
MASTER_SITES= SF
|
MASTER_SITES= SF
|
||||||
|
|
||||||
|
@ -23,7 +22,6 @@ USE_PYTHON= py3kplist
|
||||||
# $TCL_INCLUDE_SPEC
|
# $TCL_INCLUDE_SPEC
|
||||||
SHEBANG_FILES= bindings/perltest.pl
|
SHEBANG_FILES= bindings/perltest.pl
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
|
||||||
CONFIGURE_ARGS= --with-perl-binding \
|
CONFIGURE_ARGS= --with-perl-binding \
|
||||||
--with-tcl-binding --with-tcl=${TCL_LIBDIR} \
|
--with-tcl-binding --with-tcl=${TCL_LIBDIR} \
|
||||||
--with-libusb \
|
--with-libusb \
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1681402649
|
TIMESTAMP = 1740612702
|
||||||
SHA256 (hamlib-4.5.5.tar.gz) = 601c89f32ed225e9527ade3d64d0d05d23202c05ae21ffa77e59d70ee4597fcd
|
SHA256 (hamlib-4.6.2.tar.gz) = b2ac73f44dd1161e95fdee6c95276144757647bf92d7fdb369ee2fe41ed47ae8
|
||||||
SIZE (hamlib-4.5.5.tar.gz) = 2603846
|
SIZE (hamlib-4.6.2.tar.gz) = 2909790
|
||||||
|
|
10
comms/hamlib/files/patch-rigs_dummy_rot__pstrotator.c
Normal file
10
comms/hamlib/files/patch-rigs_dummy_rot__pstrotator.c
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- rigs/dummy/rot_pstrotator.c.orig 2025-02-09 21:22:13 UTC
|
||||||
|
+++ rigs/dummy/rot_pstrotator.c
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
#include <math.h>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <errno.h>
|
||||||
|
+#include <sys/socket.h>
|
||||||
|
|
||||||
|
#include "hamlib/rotator.h"
|
||||||
|
#include "dummy_common.h"
|
|
@ -1,12 +0,0 @@
|
||||||
--- src/misc.c.orig 2023-01-01 00:12:52 UTC
|
|
||||||
+++ src/misc.c
|
|
||||||
@@ -2581,7 +2581,8 @@ char *date_strget(char *buf, int buflen, int localtime
|
|
||||||
if (localtime)
|
|
||||||
{
|
|
||||||
mytm = localtime_r(&t, &result);
|
|
||||||
- mytimezone = timezone;
|
|
||||||
+ /* For FreeBSD */
|
|
||||||
+ mytimezone = mytm->tm_gmtoff;
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
|
@ -1,7 +1,4 @@
|
||||||
The Ham Radio Control Libraries, Hamlib for short, is a development effort
|
The Ham Radio Control Library hamlib, for short is a project to provide programs
|
||||||
to provide a consistent interface for programmers wanting to incorporate
|
with a consistent Application Programming Interface (API) for controlling the
|
||||||
radio control in their programs.
|
myriad of radios and rotators available to amateur radio and communications
|
||||||
Hamlib will allow authors of software logging programs, digital communications
|
users.
|
||||||
programs, or those wanting to develop the ultimate radio control software to
|
|
||||||
concentrate on the user interface and the basic function of the program rather
|
|
||||||
than radio control.
|
|
||||||
|
|
|
@ -3,15 +3,20 @@ bin/ampctld
|
||||||
bin/rigctl
|
bin/rigctl
|
||||||
bin/rigctlcom
|
bin/rigctlcom
|
||||||
bin/rigctld
|
bin/rigctld
|
||||||
|
bin/rigctlsync
|
||||||
|
bin/rigctltcp
|
||||||
|
bin/rigfreqwalk
|
||||||
bin/rigmem
|
bin/rigmem
|
||||||
bin/rigsmtr
|
bin/rigsmtr
|
||||||
bin/rigswr
|
bin/rigswr
|
||||||
|
bin/rigtestmcast
|
||||||
|
bin/rigtestmcastrx
|
||||||
bin/rotctl
|
bin/rotctl
|
||||||
bin/rotctld
|
bin/rotctld
|
||||||
include/hamlib/ampclass.h
|
include/hamlib/ampclass.h
|
||||||
include/hamlib/amplifier.h
|
include/hamlib/amplifier.h
|
||||||
include/hamlib/amplist.h
|
include/hamlib/amplist.h
|
||||||
include/hamlib/config.h
|
include/hamlib/multicast.h
|
||||||
include/hamlib/rig.h
|
include/hamlib/rig.h
|
||||||
include/hamlib/rig_dll.h
|
include/hamlib/rig_dll.h
|
||||||
include/hamlib/rigclass.h
|
include/hamlib/rigclass.h
|
||||||
|
@ -19,12 +24,10 @@ include/hamlib/riglist.h
|
||||||
include/hamlib/rotator.h
|
include/hamlib/rotator.h
|
||||||
include/hamlib/rotclass.h
|
include/hamlib/rotclass.h
|
||||||
include/hamlib/rotlist.h
|
include/hamlib/rotlist.h
|
||||||
lib/libhamlib++.a
|
|
||||||
lib/libhamlib++.la
|
lib/libhamlib++.la
|
||||||
lib/libhamlib++.so
|
lib/libhamlib++.so
|
||||||
lib/libhamlib++.so.4
|
lib/libhamlib++.so.4
|
||||||
lib/libhamlib++.so.4.0.6
|
lib/libhamlib++.so.4.0.6
|
||||||
lib/libhamlib.a
|
|
||||||
lib/libhamlib.la
|
lib/libhamlib.la
|
||||||
lib/libhamlib.so
|
lib/libhamlib.so
|
||||||
lib/libhamlib.so.4
|
lib/libhamlib.so.4
|
||||||
|
@ -33,22 +36,23 @@ lib/libhamlib.so.4.0.6
|
||||||
%%SITE_ARCH%%/auto/Hamlib/Hamlib.so
|
%%SITE_ARCH%%/auto/Hamlib/Hamlib.so
|
||||||
%%SITE_ARCH%%/perltest.pl
|
%%SITE_ARCH%%/perltest.pl
|
||||||
%%PYTHON_SITELIBDIR%%/Hamlib.py
|
%%PYTHON_SITELIBDIR%%/Hamlib.py
|
||||||
%%PYTHON_SITELIBDIR%%/_Hamlib.a
|
|
||||||
%%PYTHON_SITELIBDIR%%/_Hamlib.la
|
%%PYTHON_SITELIBDIR%%/_Hamlib.la
|
||||||
%%PYTHON_SITELIBDIR%%/_Hamlib.so
|
%%PYTHON_SITELIBDIR%%/_Hamlib.so
|
||||||
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.opt-1.pyc
|
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.opt-1.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.opt-2.pyc
|
||||||
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.pyc
|
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.pyc
|
||||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-4.6.so
|
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-4.6.so
|
||||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.a
|
|
||||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.la
|
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.la
|
||||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.so
|
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.so
|
||||||
lib/tcl%%TCL_VER%%/Hamlib/pkgIndex.tcl
|
lib/tcl%%TCL_VER%%/Hamlib/pkgIndex.tcl
|
||||||
libdata/pkgconfig/hamlib.pc
|
libdata/pkgconfig/hamlib.pc
|
||||||
|
share/aclocal/hamlib.m4
|
||||||
share/man/man1/ampctl.1.gz
|
share/man/man1/ampctl.1.gz
|
||||||
share/man/man1/ampctld.1.gz
|
share/man/man1/ampctld.1.gz
|
||||||
share/man/man1/rigctl.1.gz
|
share/man/man1/rigctl.1.gz
|
||||||
share/man/man1/rigctlcom.1.gz
|
share/man/man1/rigctlcom.1.gz
|
||||||
share/man/man1/rigctld.1.gz
|
share/man/man1/rigctld.1.gz
|
||||||
|
share/man/man1/rigctlsync.1.gz
|
||||||
share/man/man1/rigmem.1.gz
|
share/man/man1/rigmem.1.gz
|
||||||
share/man/man1/rigsmtr.1.gz
|
share/man/man1/rigsmtr.1.gz
|
||||||
share/man/man1/rigswr.1.gz
|
share/man/man1/rigswr.1.gz
|
||||||
|
@ -57,7 +61,6 @@ share/man/man1/rotctld.1.gz
|
||||||
share/man/man7/hamlib-primer.7.gz
|
share/man/man7/hamlib-primer.7.gz
|
||||||
share/man/man7/hamlib-utilities.7.gz
|
share/man/man7/hamlib-utilities.7.gz
|
||||||
share/man/man7/hamlib.7.gz
|
share/man/man7/hamlib.7.gz
|
||||||
share/aclocal/hamlib.m4
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING.LIB
|
%%PORTDOCS%%%%DOCSDIR%%/COPYING.LIB
|
||||||
|
@ -69,9 +72,10 @@ share/aclocal/hamlib.m4
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README.betatester
|
%%PORTDOCS%%%%DOCSDIR%%/README.betatester
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README.developer
|
%%PORTDOCS%%%%DOCSDIR%%/README.developer
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README.osx
|
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README.freqranges
|
%%PORTDOCS%%%%DOCSDIR%%/README.freqranges
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/README.md
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README.multicast
|
%%PORTDOCS%%%%DOCSDIR%%/README.multicast
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/README.osx
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/THANKS
|
%%PORTDOCS%%%%DOCSDIR%%/THANKS
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/examples/perltest.pl
|
%%PORTDOCS%%%%DOCSDIR%%/examples/perltest.pl
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/examples/py3test.py
|
%%PORTDOCS%%%%DOCSDIR%%/examples/py3test.py
|
||||||
|
|
Loading…
Add table
Reference in a new issue