math/zimpl: update 3.3.6 → 3.6.2

This commit is contained in:
Yuri Victorovich 2024-11-08 20:37:33 -08:00
parent 45331f089d
commit ac1b64a79b
5 changed files with 27 additions and 9 deletions

View file

@ -1,12 +1,11 @@
PORTNAME= zimpl
DISTVERSION= 3.3.6
PORTREVISION= 1
DISTVERSION= 3.6.2
CATEGORIES= math
MASTER_SITES= https://zimpl.zib.de/download/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Language to translate the LP models into .lp or .mps
WWW= https://zimpl.zib.de
WWW= https://zimpl.zib.de \
https://github.com/scipopt/zimpl
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE
@ -20,6 +19,10 @@ LIB_DEPENDS= libgmp.so:math/gmp
USES= cmake tar:tgz
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= scipopt
GH_TAGNAME= v${DISTVERSION:S/.//g}
CMAKE_ON= BUILD_SHARED_LIBS
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1541970033
SHA256 (zimpl-3.3.6.tgz) = 1f3f0bc2b9710a87b04985d9f14cc1bc207add8b2e16a8b373cb540b8fbe1326
SIZE (zimpl-3.3.6.tgz) = 746262
TIMESTAMP = 1731123417
SHA256 (scipopt-zimpl-3.6.2-v362_GH0.tar.gz) = d99bdfa227d8871560b92dd90026280b185ce8f28b0d3fe295b871f0eca8d4f1
SIZE (scipopt-zimpl-3.6.2-v362_GH0.tar.gz) = 5257233

View file

@ -0,0 +1,13 @@
- https://github.com/scipopt/zimpl/issues/1
--- CMakeLists.txt.orig 2024-11-09 04:34:10 UTC
+++ CMakeLists.txt
@@ -47,8 +47,6 @@ set(CMAKE_C_STANDARD 99)
# use C99 standard
set(CMAKE_C_STANDARD 99)
-set(CMAKE_C_VISIBILITY_PRESET hidden)
-set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
option(ZLIB "use ZLIB" ON)
option(SANITIZE_ADDRESS "should the address sanitizer be enabled in debug mode if available" OFF)

View file

@ -1,8 +1,8 @@
- Allow to build shared libs.
--- src/CMakeLists.txt.orig 2021-08-01 07:59:48 UTC
--- src/CMakeLists.txt.orig 2024-09-13 05:08:28 UTC
+++ src/CMakeLists.txt
@@ -116,12 +116,12 @@ if(MSVC)
@@ -118,12 +118,12 @@ endif()
endif()
#create zimpl with pic

View file

@ -1,4 +1,5 @@
bin/zimpl
include/zimpl/attribute.h
include/zimpl/blkmem.h
include/zimpl/bound.h
include/zimpl/code.h
@ -37,6 +38,7 @@ include/zimpl/tuple.h
include/zimpl/xlpglue.h
include/zimpl/zimpllib.h
include/zimpl/zlpglue.h
lib/cmake/zimpl/zimpl-config-version.cmake
lib/cmake/zimpl/zimpl-config.cmake
lib/cmake/zimpl/zimpl-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/zimpl/zimpl-targets.cmake