net/py-casttube: Add missing RUN_DEPENDS

- Update WWW
- Convert to USE_PYTHON=pep517
- Add NO_ARCH
- Update pkg-descr
- Bump PORTREVISION for dependency and package change
- Take maintainership
This commit is contained in:
Po-Chuan Hsieh 2024-08-05 01:08:45 +08:00
parent f938eb04fc
commit aae465d6ed
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
3 changed files with 30 additions and 13 deletions

View file

@ -1,16 +1,24 @@
PORTNAME= casttube PORTNAME= casttube
DISTVERSION= 0.2.1 PORTVERSION= 0.2.1
PORTREVISION= 1
CATEGORIES= net python CATEGORIES= net python
MASTER_SITES= PYPI MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@freebsd.org MAINTAINER= sunpoet@FreeBSD.org
COMMENT= YouTube Chromecast api COMMENT= YouTube Chromecast API
WWW= https://pypi.org/project/casttube/ WWW= https://github.com/ur1katz/casttube
LICENSE= MIT LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
USES= python USES= python
USE_PYTHON= distutils autoplist USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- setup.py.orig 2020-04-08 12:40:53 UTC
+++ setup.py
@@ -12,7 +12,6 @@ setup(name='casttube',
author='Uri Katz',
author_email='4urikatz@gmail.com',
license='MIT',
- data_files = [("", ["LICENSE"])],
packages=['casttube'],
zip_safe=False,
keywords = ['youtube', 'chromecast', 'youtube-api'],

View file

@ -1,10 +1,9 @@
casttube provides a way to interact with the YouTube Chromecast API. CastTube provides a way to interact with the Youtube Chromecast API.
Features: Features:
- Play video
* Play video - Play a playlist
* Play a playlist - Add video to the end of the play queue
* Add video to the end of the play queue - Play next
* Play next - Remove video
* Remove video - Clear the entire queue
* Clear the entire queue