comms/py-streamdeck: Update to 0.9.6

- Mark port as NO_ARCH

ChangeLog:
https://github.com/abcminiuser/python-elgato-streamdeck/blob/0.9.6/CHANGELOG

PR:		285239
This commit is contained in:
gatekeeper 2025-03-13 23:33:09 +00:00 committed by Nuno Teixeira
parent 2e65f870a6
commit aa5252bd33
3 changed files with 6 additions and 14 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= streamdeck PORTNAME= streamdeck
DISTVERSION= 0.9.5 DISTVERSION= 0.9.6
CATEGORIES= comms python CATEGORIES= comms python
MASTER_SITES= PYPI MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -27,4 +27,6 @@ TEST_WRKSRC= ${WRKSRC}/test
DO_MAKE_TEST= ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER} DO_MAKE_TEST= ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER}
TEST_TARGET= test.py TEST_TARGET= test.py
NO_ARCH= yes
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1713635550 TIMESTAMP = 1741397217
SHA256 (streamdeck-0.9.5.tar.gz) = 04796266b44577ae03f940f5c5ca69d87007e03d19eed89b6b02686c030ceb91 SHA256 (streamdeck-0.9.6.tar.gz) = ec42d9b711b352ea274ad305a6eb48ece1eed3a5bffe70b928e082dce0f788f0
SIZE (streamdeck-0.9.5.tar.gz) = 2555109 SIZE (streamdeck-0.9.6.tar.gz) = 2556726

View file

@ -1,10 +0,0 @@
--- src/StreamDeck/Transport/LibUSBHIDAPI.py.orig 2024-04-08 21:05:19 UTC
+++ src/StreamDeck/Transport/LibUSBHIDAPI.py
@@ -154,6 +154,7 @@ class LibUSBHIDAPI(Transport):
"Windows": ["hidapi.dll", "libhidapi-0.dll", "./hidapi.dll"],
"Linux": ["libhidapi-libusb.so", "libhidapi-libusb.so.0"],
"Darwin": ["libhidapi.dylib"],
+ "FreeBSD": ["libhidapi.so"],
}
self.platform_name = platform.system()