mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
textproc/py-youseedee: Update to 0.6.0
Changes: https://github.com/simoncozens/youseedee/releases https://github.com/simoncozens/youseedee/commits/master
This commit is contained in:
parent
5496159a9b
commit
a6714fb2d1
4 changed files with 23 additions and 12 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= youseedee
|
||||
PORTVERSION= 0.5.3
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -11,7 +10,8 @@ WWW= https://github.com/simoncozens/youseedee
|
|||
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=8.0.4:devel/py-setuptools-scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}filelock>=0:sysutils/py-filelock@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1708449488
|
||||
SHA256 (youseedee-0.5.3.tar.gz) = 850908f2476ba292e23bce8b5c3cba79099adc5120e3c80b95d53b6c583d7732
|
||||
SIZE (youseedee-0.5.3.tar.gz) = 14724
|
||||
TIMESTAMP = 1726487386
|
||||
SHA256 (youseedee-0.6.0.tar.gz) = f70eb2af6f33ab42e03af329e5f08568718ec0ae306db0e8fe0d631f8524cb41
|
||||
SIZE (youseedee-0.6.0.tar.gz) = 17389
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- lib/youseedee/__init__.py.orig 2023-12-13 13:22:08 UTC
|
||||
--- lib/youseedee/__init__.py.orig 2024-09-11 19:36:00 UTC
|
||||
+++ lib/youseedee/__init__.py
|
||||
@@ -23,7 +23,7 @@ UCD_URL = "https://unicode.org/Public/UCD/latest/ucd/U
|
||||
|
||||
@@ -38,7 +38,7 @@ def ucd_dir():
|
||||
|
||||
def ucd_dir():
|
||||
- ucddir = os.path.expanduser("~/.youseedee")
|
||||
"""Return the directory where Unicode data is stored"""
|
||||
- ucddir = expanduser("~/.youseedee")
|
||||
+ ucddir = "%%UCDDIR%%"
|
||||
if not os.path.isdir(ucddir):
|
||||
try:
|
||||
os.mkdir(ucddir)
|
||||
return ucddir
|
||||
except FileExistsError:
|
||||
|
|
11
textproc/py-youseedee/files/patch-pyproject.toml
Normal file
11
textproc/py-youseedee/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pyproject.toml.orig 2024-09-11 19:36:00 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -18,7 +18,7 @@ repository = "https://github.com/simoncozens/youseedee
|
||||
repository = "https://github.com/simoncozens/youseedee"
|
||||
|
||||
[build-system]
|
||||
-requires = ["setuptools>=74.1.0", "setuptools_scm[toml]>=8.1.0"]
|
||||
+requires = ["setuptools>=61", "setuptools_scm[toml]>=8.0.4"]
|
||||
build-backend = "setuptools.build_meta"
|
||||
|
||||
[tool.setuptools.packages.find]
|
Loading…
Add table
Reference in a new issue