mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 03:56:39 -04:00
- Add custom LICENSE (IBM Public License 1.0)
- Respect CFLAGS (CC was already respected) - Stagify and simplify FreeBSD handling in source code - Improve COMMENT and port description while here
This commit is contained in:
parent
308e8e616b
commit
a5794020d8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=340554
4 changed files with 44 additions and 32 deletions
|
@ -7,28 +7,23 @@ CATEGORIES= sysutils
|
|||
MASTER_SITES= http://www.porcupine.org/forensics/
|
||||
|
||||
MAINTAINER= onatan@gmail.com
|
||||
COMMENT= Forensic utility for memory-dumping
|
||||
COMMENT= Forensic utility for memory dumping
|
||||
|
||||
LICENSE= IBM
|
||||
LICENSE_NAME= IBM Public License 1.0
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
ALL_TARGET= what
|
||||
MAKE_ARGS= OPT="${CFLAGS}" DEBUG=''
|
||||
|
||||
PLIST_FILES= bin/memdump
|
||||
PORTDOCS= README LICENSE
|
||||
MAN1= memdump.1
|
||||
PORTDOCS= README
|
||||
PLIST_FILES= bin/memdump man/man1/memdump.1.gz
|
||||
|
||||
NO_STAGE= yes
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/memdump ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/memdump.1 ${MANPREFIX}/man/man1
|
||||
. if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
|
||||
. endif
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/memdump ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/memdump.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 900000
|
||||
BROKEN= unsupported FreeBSD version
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +1,21 @@
|
|||
--- ./makedefs.orig 2005-08-30 23:03:40.000000000 +0000
|
||||
+++ ./makedefs 2007-11-30 18:54:11.000000000 +0000
|
||||
@@ -14,6 +14,8 @@
|
||||
@@ -2,17 +2,7 @@ SYSTEM=`(uname -s) 2>/dev/null`
|
||||
RELEASE=`(uname -r) 2>/dev/null`
|
||||
|
||||
case "$SYSTEM.$RELEASE" in
|
||||
- FreeBSD.2*) DEFS="-DFREEBSD2"
|
||||
- ;;
|
||||
- FreeBSD.3*) DEFS="-DFREEBSD3"
|
||||
- ;;
|
||||
- FreeBSD.4*) DEFS="-DFREEBSD4"
|
||||
- ;;
|
||||
- FreeBSD.5*) DEFS="-DFREEBSD5"
|
||||
- ;;
|
||||
- FreeBSD.6*) DEFS="-DFREEBSD6"
|
||||
- ;;
|
||||
- FreeBSD.7*) DEFS="-DFREEBSD7"
|
||||
+ FreeBSD.*) DEFS="-DFREEBSD"
|
||||
;;
|
||||
FreeBSD.7*) DEFS="-DFREEBSD7"
|
||||
;;
|
||||
+ FreeBSD.8*) DEFS="-DFREEBSD8"
|
||||
+ ;;
|
||||
OpenBSD.2*) DEFS="-DOPENBSD2"
|
||||
;;
|
||||
OpenBSD.3*) DEFS="-DOPENBSD3"
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
--- ./memdump.c.orig 2005-08-30 23:04:18.000000000 +0000
|
||||
+++ ./memdump.c 2007-11-30 18:54:11.000000000 +0000
|
||||
@@ -109,6 +109,7 @@
|
||||
@@ -107,8 +107,7 @@
|
||||
#define SUPPORTED
|
||||
#endif
|
||||
|
||||
#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
|
||||
|| defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
|
||||
+ || defined(FREEBSD8) \
|
||||
-#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
|
||||
- || defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
|
||||
+#if defined(FREEBSD) \
|
||||
|| defined(OPENBSD2) || defined(OPENBSD3) \
|
||||
|| defined(BSDI2) || defined(BSDI3) || defined(BSDI4)
|
||||
#include <sys/param.h>
|
||||
|
|
|
@ -1,5 +1,10 @@
|
|||
This program dumps system memory to the standard output stream,
|
||||
skipping over holes in memory maps.
|
||||
By default, the program dumps the contents of physical memory.
|
||||
This program dumps system memory to the standard output stream, skipping
|
||||
over holes in memory maps. By default, the program dumps the contents of
|
||||
physical memory.
|
||||
|
||||
Note: consider using Brian Carrier's Sleuthkit, available as `sysutils/
|
||||
sleuthkit' port. It is the official successor, based on parts from TCT.
|
||||
Development of the Coroner's Toolkit was stopped years ago. It is only
|
||||
updated for bugfixes, which are very rare.
|
||||
|
||||
WWW: http://www.porcupine.org/forensics/tct.html
|
||||
|
|
Loading…
Add table
Reference in a new issue