Add katoob 0.3.5, a light-weight, bidirectional editor for arabic

texts.

PR:		57511
Submitted by:	Pav Lucistnik <pav@oook.cz> through
		Samy Al Bahra <samy@kerneled.com> (maintainer)
This commit is contained in:
Will Andrews 2003-11-09 16:35:38 +00:00
parent 050af2cc08
commit a3b1dbe9f1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93558
6 changed files with 85 additions and 0 deletions

View file

@ -1,5 +1,6 @@
# $FreeBSD$ # $FreeBSD$
# #
SUBDIR += katoob
SUBDIR += openoffice-1.1 SUBDIR += openoffice-1.1
.include <bsd.port.subdir.mk> .include <bsd.port.subdir.mk>

38
arabic/katoob/Makefile Normal file
View file

@ -0,0 +1,38 @@
# New ports collection makefile for: katoob
# Date created: 13th September 2003
# Whom: Pav Lucistnik <pav@oook.cz>
#
# $FreeBSD$
#
PORTNAME= katoob
PORTVERSION= 0.3.5
CATEGORIES= arabic
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= arabeyes
MAINTAINER= samy@kerneled.com
COMMENT= Light-weight, bidirectional editor for arabic texts
MAN1= katoob.1
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gtk20
USE_LIBTOOL= yes
USE_GETOPT_LONG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
.if defined(WITH_HIGHLIGHTING) || exists(${X11BASE}/libdata/pkgconfig/gtksourceview-1.0.pc)
CONFIGURE_ARGS+= "--enable-highlight"
USE_GNOME+= gtksourceview
.endif
.if defined(WITH_SPELLCHECKER) || exists(${LOCALBASE}/lib/libaspell.so.15)
CONFIGURE_ARGS+= "--enable-spell"
LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
.endif
.include <bsd.port.post.mk>

1
arabic/katoob/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (katoob-0.3.5.tar.gz) = a05723c7aee914c51226270aa3d61ff9

View file

@ -0,0 +1,21 @@
--- src/init.c Tue Aug 26 07:54:35 2003
+++ /home/samy/development/katoob/src/init.c Thu Aug 28 00:36:48 2003
@@ -101,7 +101,18 @@
katoob->xkb_grps[i] =
XGetAtomName (GDK_DISPLAY (), kbinfo->names->groups[i]);
}
+ else
+ {
+ katoob->xkb_grps[i] = NULL;
+ }
}
+ }
+
+/* Let's NULL all the remaining array. */
+ while (grpnum < XkbNumKbdGroups)
+ {
+ katoob->xkb_grps[grpnum] = NULL;
+ ++grpnum;
}
XkbGetControls (GDK_DISPLAY (), XkbAllControlsMask, kbinfo);

8
arabic/katoob/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
Katoob is a light weight, multi lingual,
BIDI-aware text editor based on the Gtk+ 2
library. It supports opening and saving files
in multiple encodings. The main support was
for Arabic language but more languages are
currently supported.
WWW: http://www.arabeyes.org/project.php?proj=Katoob

16
arabic/katoob/pkg-plist Normal file
View file

@ -0,0 +1,16 @@
bin/katoob
share/gnome/applications/katoob.desktop
share/gnome/katoob/close.png
share/gnome/katoob/emulator/arabic
share/gnome/katoob/green.png
share/gnome/katoob/katoob.png
share/gnome/katoob/katoob-small.png
share/gnome/katoob/landscape.png
share/gnome/katoob/portrait.png
share/gnome/katoob/red.png
share/gnome/pixmaps/katoob-icon.png
share/locale/ar/LC_MESSAGES/katoob.mo
share/locale/pl/LC_MESSAGES/katoob.mo
share/locale/sv/LC_MESSAGES/katoob.mo
@dirrm share/gnome/katoob/emulator
@dirrm share/gnome/katoob