multimedia/mkclean: Update to 0.9.0

ChangeLog:
https://github.com/Matroska-Org/foundation-source/blob/mkclean-0.9.0/mkclean/ChangeLog.txt

PR:	262041
Reported by:	sega01@go-beyond.org
This commit is contained in:
Fernando Apesteguía 2022-02-24 08:10:47 +01:00
parent 177c860967
commit a2c1dc5539
5 changed files with 25 additions and 53 deletions

View file

@ -1,37 +1,41 @@
PORTNAME= mkclean
PORTVERSION= 0.8.7
PORTREVISION= 2
PORTVERSION= 0.9.0
CATEGORIES= multimedia
MASTER_SITES= SF/matroska/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Clean and optimize Matroska and WebM files
LICENSE= BSD3CLAUSE
BROKEN_aarch64= Does not install: arm-none-linux-gnueabi-gcc: Command not found
BROKEN_armv6= Does not install: arm-none-linux-gnueabi-gcc: Command not found
BROKEN_armv7= Does not install: arm-none-linux-gnueabi-gcc: Command not found
BROKEN_mips64= Does not install: mipsel-linux-gcc: Command not found
BROKEN_riscv64= Does not compile: cc: invalid arch name 'i486', string must begin with rv32{i,e,g} or rv64{i,g}
BROKEN_sparc64= Does not install: gmake: GNUmakefile: No such file or directory
# These may work better now with cmake.
BROKEN_aarch64= does not install: arm-none-linux-gnueabi-gcc: Command not found
BROKEN_armv6= does not install: arm-none-linux-gnueabi-gcc: Command not found
BROKEN_armv7= does not install: arm-none-linux-gnueabi-gcc: Command not found
BROKEN_mips64= does not install: mipsel-linux-gcc: Command not found
BROKEN_riscv64= does not compile: cc: invalid arch name 'i486', string must begin with rv32{i,e,g} or rv64{i,g}
BROKEN_sparc64= does not install: gmake: GNUmakefile: No such file or directory
HAS_CONFIGURE= yes
USES= cmake compiler:c++11-lang cpe iconv localbase:ldflags
USES= compiler:c++11-lang cpe iconv localbase:ldflags gmake tar:bzip2
CPE_VENDOR= matroska
LDFLAGS+= ${ICONV_LIB}
USE_GITHUB= yes
GH_ACCOUNT= Matroska-Org
GH_PROJECT= foundation-source
GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
MAKE_ENV= "LFLAGS=${LDFLAGS}"
MAKEFILE= GNUmakefile
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
NO_INSTALL= yes
post-extract:
@${REINPLACE_CMD} -e 's/vfs.h/mount.h/' ${WRKSRC}/corec/corec/helpers/file/file_libc.c
LDFLAGS+= ${ICONV_LIB}
PLIST_FILES= bin/mkclean \
bin/mkWDclean
post-extract:
@${REINPLACE_CMD} -e 's,/usr/local,$$(DESTDIR)$$(PREFIX),g' ${WRKSRC}/corec/tools/coremake/gcc_mak.inc
@${RM} ${WRKSRC}/libmatroska2/test/test.proj
post-stage:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}/mkclean ${STAGEDIR}${LOCALBASE}/bin
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}/mkWDclean ${STAGEDIR}${LOCALBASE}/bin
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (mkclean-0.8.7.tar.bz2) = 88713065a172d1ab7fd34c8854a42f6bf8d0e794957265340328a2f692ad46d9
SIZE (mkclean-0.8.7.tar.bz2) = 737877
TIMESTAMP = 1645167021
SHA256 (Matroska-Org-foundation-source-0.9.0-mkclean-0.9.0_GH0.tar.gz) = d42123ceb22be6f682105fd4fc28b6657ca86ab2bb9450f753054bf17b65ad1e
SIZE (Matroska-Org-foundation-source-0.9.0-mkclean-0.9.0_GH0.tar.gz) = 718527

View file

@ -1,11 +0,0 @@
--- corec/corec/helpers/file/file_libc.c.orig 2012-08-26 13:26:55 UTC
+++ corec/corec/helpers/file/file_libc.c
@@ -40,7 +40,7 @@
#include <unistd.h>
#include <dirent.h>
#include <errno.h>
-#if defined(TARGET_OSX)
+#if defined(TARGET_OSX) || defined(TARGET_FREEBSD)
#include <sys/mount.h>
#else
#include <sys/vfs.h>

View file

@ -1,12 +0,0 @@
--- corec/corec/portab.h.orig 2012-08-26 13:26:56 UTC
+++ corec/corec/portab.h
@@ -159,6 +159,9 @@
#elif defined(__linux__) || defined(__CYGWIN__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#if defined(__FreeBSD__)
+#define TARGET_FREEBSD
+#endif
#define TARGET_LINUX
#ifndef TARGET_QTOPIA // qtopia defines desktop manually

View file

@ -1,10 +0,0 @@
--- root.proj.orig 2012-08-26 13:26:56 UTC
+++ root.proj
@@ -12,6 +12,7 @@ WORKSPACE(CONFIG_MATROSKA2) matroska
USE matroska2
USE mkvtests
USE mkclean
+ USE mkWDclean
USE mkvalidator
}