mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
math/qwtplot3d: Update to 0.3.0
- Switch upstream from abandoned SF to SciDAVis repo. - Depend on print/gl2ps instead of building private copy - Drop stale patches
This commit is contained in:
parent
5d7a532437
commit
a0a77dcb2a
8 changed files with 140 additions and 121 deletions
|
@ -1,18 +1,23 @@
|
||||||
PORTNAME= qwtplot3d
|
PORTNAME= qwtplot3d
|
||||||
PORTVERSION= 0.2.7
|
PORTVERSION= 0.3.0.g20210210
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= math
|
CATEGORIES= math
|
||||||
MASTER_SITES= SF
|
|
||||||
PKGNAMESUFFIX= -qt5
|
PKGNAMESUFFIX= -qt5
|
||||||
|
|
||||||
MAINTAINER= makc@FreeBSD.org
|
MAINTAINER= makc@FreeBSD.org
|
||||||
COMMENT= 3D plotting widgets for Qt
|
COMMENT= 3D plotting widgets for Qt
|
||||||
|
|
||||||
USES= compiler:c++11-lang dos2unix gl qmake qt:5 tar:tgz
|
LIB_DEPENDS= libgl2ps.so:print/gl2ps
|
||||||
USE_QT= core gui opengl widgets buildtools_build
|
|
||||||
USE_GL= gl glu
|
|
||||||
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
|
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
USES= cmake compiler:c++17-lang gl qt:5
|
||||||
|
USE_QT= core gui opengl widgets buildtools_build qmake_build
|
||||||
|
USE_GL= gl glu
|
||||||
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_ACCOUNT= SciDAVis
|
||||||
|
GH_TAGNAME= 438c855d
|
||||||
|
|
||||||
|
CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_Qt6=True \
|
||||||
|
-DBUILD_SHARED_LIBS=True
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1543181657
|
TIMESTAMP = 1620335349
|
||||||
SHA256 (qwtplot3d-0.2.7.tgz) = 1208336b15e82e7a9d22cbc743e46f27e2fad716094a9c133138f259fa299a42
|
SHA256 (SciDAVis-qwtplot3d-0.3.0.g20210210-438c855d_GH0.tar.gz) = 4dbc0c1e35f11ab81022da9046e61d7d7ed0496982a326ac14ba4bf36e985b81
|
||||||
SIZE (qwtplot3d-0.2.7.tgz) = 183836
|
SIZE (SciDAVis-qwtplot3d-0.3.0.g20210210-438c855d_GH0.tar.gz) = 162347
|
||||||
|
|
91
math/qwtplot3d/files/patch-CMakeLists.txt
Normal file
91
math/qwtplot3d/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,91 @@
|
||||||
|
--- CMakeLists.txt.orig 2021-02-10 16:16:17 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -73,7 +73,7 @@ set( SRCS
|
||||||
|
"src/qwt3d_io_gl2ps.cpp"
|
||||||
|
)
|
||||||
|
|
||||||
|
-set( HEADERS
|
||||||
|
+set( HEADERS_PUBLIC
|
||||||
|
"include/qwt3d_color.h"
|
||||||
|
"include/qwt3d_global.h"
|
||||||
|
"include/qwt3d_types.h"
|
||||||
|
@@ -105,50 +105,65 @@ set( HEADERS
|
||||||
|
)
|
||||||
|
configure_file( "include/qwt3d_version.h.in" "qwt3d_version.h" @ONLY )
|
||||||
|
|
||||||
|
-add_library( qwtplot3d ${SRCS} ${HEADERS} )
|
||||||
|
+set( QWTPLOT3D "qwtplot3d-qt${QT_VERSION_MAJOR}" )
|
||||||
|
|
||||||
|
-target_link_libraries( qwtplot3d
|
||||||
|
+add_library( ${QWTPLOT3D} ${SRCS} ${HEADERS_PUBLIC} )
|
||||||
|
+set_target_properties( ${QWTPLOT3D} PROPERTIES
|
||||||
|
+ VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}
|
||||||
|
+ SOVERSION ${PROJECT_VERSION_MAJOR}
|
||||||
|
+ )
|
||||||
|
+
|
||||||
|
+target_link_libraries( ${QWTPLOT3D}
|
||||||
|
Qt${QT_VERSION_MAJOR}::Core
|
||||||
|
Qt${QT_VERSION_MAJOR}::Gui
|
||||||
|
OpenGL::GLU
|
||||||
|
)
|
||||||
|
|
||||||
|
if( QT_VERSION_MAJOR VERSION_GREATER_EQUAL 6 )
|
||||||
|
- target_link_libraries( qwtplot3d Qt${QT_VERSION_MAJOR}::OpenGLWidgets )
|
||||||
|
+ target_link_libraries( ${QWTPLOT3D} Qt${QT_VERSION_MAJOR}::OpenGLWidgets )
|
||||||
|
else()
|
||||||
|
- target_link_libraries( qwtplot3d Qt${QT_VERSION_MAJOR}::OpenGL )
|
||||||
|
+ target_link_libraries( ${QWTPLOT3D} Qt${QT_VERSION_MAJOR}::OpenGL )
|
||||||
|
endif()
|
||||||
|
|
||||||
|
|
||||||
|
-target_include_directories( qwtplot3d PUBLIC include ${CMAKE_CURRENT_BINARY_DIR} )
|
||||||
|
+target_include_directories( ${QWTPLOT3D} PUBLIC include ${CMAKE_CURRENT_BINARY_DIR} )
|
||||||
|
|
||||||
|
if( NOT GL2PS_LIBRARY )
|
||||||
|
enable_language( C )
|
||||||
|
- target_sources( qwtplot3d PRIVATE "3rdparty/gl2ps/gl2ps.c" "3rdparty/gl2ps/gl2ps.h" )
|
||||||
|
- target_include_directories( qwtplot3d PRIVATE "3rdparty/gl2ps" )
|
||||||
|
+ target_sources( ${QWTPLOT3D} PRIVATE "3rdparty/gl2ps/gl2ps.c" "3rdparty/gl2ps/gl2ps.h" )
|
||||||
|
+ target_include_directories( ${QWTPLOT3D} PRIVATE "3rdparty/gl2ps" )
|
||||||
|
else()
|
||||||
|
- target_link_libraries( qwtplot3d ${GL2PS_LIBRARY} )
|
||||||
|
- target_include_directories( qwtplot3d PRIVATE ${GL2PS_INCLUDE_DIR} )
|
||||||
|
+ target_link_libraries( ${QWTPLOT3D} ${GL2PS_LIBRARY} )
|
||||||
|
+ target_include_directories( ${QWTPLOT3D} PRIVATE ${GL2PS_INCLUDE_DIR} )
|
||||||
|
endif()
|
||||||
|
|
||||||
|
if( WIN32 AND BUILD_SHARED_LIBS )
|
||||||
|
- target_compile_definitions( qwtplot3d PRIVATE QWT3D_DLL QWT3D_MAKEDLL )
|
||||||
|
+ target_compile_definitions( ${QWTPLOT3D} PRIVATE QWT3D_DLL QWT3D_MAKEDLL )
|
||||||
|
endif()
|
||||||
|
|
||||||
|
if( ${CMAKE_SOURCE_DIR} STREQUAL ${PROJECT_SOURCE_DIR} )
|
||||||
|
- add_subdirectory( examples )
|
||||||
|
+# add_subdirectory( examples )
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+include(GNUInstallDirs)
|
||||||
|
# Don't install qwtplot3d static library and headers if it is built as a subproject
|
||||||
|
if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
|
||||||
|
- install( TARGETS qwtplot3d
|
||||||
|
+ install( TARGETS ${QWTPLOT3D}
|
||||||
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||||
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
|
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
|
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qwtplot3d
|
||||||
|
+ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
|
||||||
|
)
|
||||||
|
+ install(
|
||||||
|
+ FILES ${HEADERS_PUBLIC}
|
||||||
|
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/${QWTPLOT3D}"
|
||||||
|
+ )
|
||||||
|
+ install(
|
||||||
|
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/qwt3d_version.h"
|
||||||
|
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/${QWTPLOT3D}"
|
||||||
|
+ )
|
||||||
|
elseif( BUILD_SHARED_LIBS )
|
||||||
|
- install( TARGETS qwtplot3d
|
||||||
|
+ install( TARGETS ${QWTPLOT3D}
|
||||||
|
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||||
|
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||||
|
)
|
|
@ -1,10 +0,0 @@
|
||||||
--- include/qwt3d_openglhelper.h.orig 2018-11-26 20:04:53 UTC
|
|
||||||
+++ include/qwt3d_openglhelper.h
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
#include <qgl.h>
|
|
||||||
#else
|
|
||||||
#include <QtOpenGL/qgl.h>
|
|
||||||
+#include <GL/glu.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
namespace Qwt3D
|
|
|
@ -1,56 +0,0 @@
|
||||||
--- qwtplot3d.pro.orig 2018-11-26 20:18:41 UTC
|
|
||||||
+++ qwtplot3d.pro
|
|
||||||
@@ -1,9 +1,9 @@
|
|
||||||
# pro file for building the makefile for qwtplot3d
|
|
||||||
#
|
|
||||||
|
|
||||||
-TARGET = qwtplot3d
|
|
||||||
+TARGET = qwtplot3d-qt5
|
|
||||||
TEMPLATE = lib
|
|
||||||
-CONFIG += qt warn_on opengl thread zlib debug
|
|
||||||
+CONFIG += qt warn_on opengl thread zlib
|
|
||||||
MOC_DIR = tmp
|
|
||||||
OBJECTS_DIR = tmp
|
|
||||||
INCLUDEPATH = include
|
|
||||||
@@ -11,6 +11,7 @@ DEPENDPATH = include src
|
|
||||||
DESTDIR = lib
|
|
||||||
#DESTDIR = ../../../lib
|
|
||||||
QT += opengl
|
|
||||||
+unix:LIBS += -lGLU
|
|
||||||
|
|
||||||
win32:TEMPLATE = vclib
|
|
||||||
win32:CONFIG += dll exceptions
|
|
||||||
@@ -21,7 +22,7 @@ win32:QMAKE_CXXFLAGS += $$QMAKE_CFLA
|
|
||||||
win32:CONFIG -= zlib
|
|
||||||
|
|
||||||
linux-g++:TMAKE_CXXFLAGS += -fno-exceptions
|
|
||||||
-unix:VERSION = 0.2.6
|
|
||||||
+unix:VERSION = 0.2.7
|
|
||||||
|
|
||||||
# Input
|
|
||||||
SOURCES += src/qwt3d_axis.cpp \
|
|
||||||
@@ -81,8 +82,8 @@ HEADERS += include/qwt3d_surfaceplot.h \
|
|
||||||
include/qwt3d_multiplot.h
|
|
||||||
|
|
||||||
# gl2ps support
|
|
||||||
-HEADERS+=3rdparty/gl2ps/gl2ps.h \
|
|
||||||
- include/qwt3d_io_gl2ps.h
|
|
||||||
+# HEADERS+=3rdparty/gl2ps/gl2ps.h \
|
|
||||||
+HEADERS+= include/qwt3d_io_gl2ps.h
|
|
||||||
|
|
||||||
SOURCES+=src/qwt3d_io_gl2ps.cpp \
|
|
||||||
3rdparty/gl2ps/gl2ps.c
|
|
||||||
@@ -92,4 +93,11 @@ zlib {
|
|
||||||
DEFINES += GL2PS_HAVE_ZLIB
|
|
||||||
win32:LIBS += zlib.lib
|
|
||||||
unix:LIBS += -lz
|
|
||||||
-}
|
|
||||||
\ No newline at end of file
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+target.path = $$[QT_INSTALL_LIBS]
|
|
||||||
+
|
|
||||||
+headers.files = $$HEADERS
|
|
||||||
+headers.path = $$[QT_INSTALL_HEADERS]/qwtplot3d-qt5
|
|
||||||
+
|
|
||||||
+INSTALLS += target headers
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- src/qwt3d_lighting.cpp.orig 2018-11-26 20:04:53 UTC
|
|
||||||
+++ src/qwt3d_lighting.cpp
|
|
||||||
@@ -175,7 +175,7 @@ void Plot3D::applyLight(unsigned light)
|
|
||||||
glRotatef( lights_[light].rot.x-90, 1.0, 0.0, 0.0 );
|
|
||||||
glRotatef( lights_[light].rot.y , 0.0, 1.0, 0.0 );
|
|
||||||
glRotatef( lights_[light].rot.z , 0.0, 0.0, 1.0 );
|
|
||||||
- GLfloat lightPos[4] = { lights_[light].shift.x, lights_[light].shift.y, lights_[light].shift.z, 1.0};
|
|
||||||
+ GLfloat lightPos[4] = { static_cast<GLfloat>(lights_[light].shift.x), static_cast<GLfloat>(lights_[light].shift.y), static_cast<GLfloat>(lights_[light].shift.z), 1.0};
|
|
||||||
GLenum le = lightEnum(light);
|
|
||||||
glLightfv(le, GL_POSITION, lightPos);
|
|
||||||
}
|
|
|
@ -1,4 +1,4 @@
|
||||||
QwtPlot3d is a feature-rich Qt/OpenGL-based C++ library. It provides
|
QwtPlot3d is a feature-rich Qt/OpenGL-based C++ library. It provides
|
||||||
Qt widgets for 3D plotting.
|
Qt widgets for 3D plotting.
|
||||||
|
|
||||||
WWW: http://qwtplot3d.sourceforge.net
|
WWW: https://github.com/SciDAVis/qwtplot3d
|
||||||
|
|
|
@ -1,32 +1,32 @@
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_autoptr.h
|
include/qwtplot3d-qt5/qwt3d_autoptr.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_autoscaler.h
|
include/qwtplot3d-qt5/qwt3d_autoscaler.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_axis.h
|
include/qwtplot3d-qt5/qwt3d_axis.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_color.h
|
include/qwtplot3d-qt5/qwt3d_color.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_colorlegend.h
|
include/qwtplot3d-qt5/qwt3d_colorlegend.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_coordsys.h
|
include/qwtplot3d-qt5/qwt3d_coordsys.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_drawable.h
|
include/qwtplot3d-qt5/qwt3d_drawable.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_enrichment.h
|
include/qwtplot3d-qt5/qwt3d_enrichment.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_enrichment_std.h
|
include/qwtplot3d-qt5/qwt3d_enrichment_std.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_function.h
|
include/qwtplot3d-qt5/qwt3d_function.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_global.h
|
include/qwtplot3d-qt5/qwt3d_global.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_graphplot.h
|
include/qwtplot3d-qt5/qwt3d_graphplot.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_gridmapping.h
|
include/qwtplot3d-qt5/qwt3d_gridmapping.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_helper.h
|
include/qwtplot3d-qt5/qwt3d_helper.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_io.h
|
include/qwtplot3d-qt5/qwt3d_io.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_io_gl2ps.h
|
include/qwtplot3d-qt5/qwt3d_io_gl2ps.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_io_reader.h
|
include/qwtplot3d-qt5/qwt3d_io_reader.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_label.h
|
include/qwtplot3d-qt5/qwt3d_label.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_mapping.h
|
include/qwtplot3d-qt5/qwt3d_mapping.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_multiplot.h
|
include/qwtplot3d-qt5/qwt3d_multiplot.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_openglhelper.h
|
include/qwtplot3d-qt5/qwt3d_openglhelper.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_parametricsurface.h
|
include/qwtplot3d-qt5/qwt3d_parametricsurface.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_plot.h
|
include/qwtplot3d-qt5/qwt3d_plot.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_portability.h
|
include/qwtplot3d-qt5/qwt3d_portability.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_scale.h
|
include/qwtplot3d-qt5/qwt3d_scale.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_surfaceplot.h
|
include/qwtplot3d-qt5/qwt3d_surfaceplot.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_types.h
|
include/qwtplot3d-qt5/qwt3d_types.h
|
||||||
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_volumeplot.h
|
include/qwtplot3d-qt5/qwt3d_version.h
|
||||||
%%QT_LIBDIR%%/libqwtplot3d-qt5.so
|
include/qwtplot3d-qt5/qwt3d_volumeplot.h
|
||||||
%%QT_LIBDIR%%/libqwtplot3d-qt5.so.0
|
lib/libqwtplot3d-qt5.so
|
||||||
%%QT_LIBDIR%%/libqwtplot3d-qt5.so.0.2
|
lib/libqwtplot3d-qt5.so.0
|
||||||
%%QT_LIBDIR%%/libqwtplot3d-qt5.so.0.2.7
|
lib/libqwtplot3d-qt5.so.0.3.0
|
||||||
|
|
Loading…
Add table
Reference in a new issue