mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
converters/py-rencode: Sync with main, restore build with cython
PR: 276744 Reported by: agh@riseup.net
This commit is contained in:
parent
2f1558e221
commit
a02b73e321
3 changed files with 23 additions and 33 deletions
|
@ -1,8 +1,7 @@
|
||||||
PORTNAME= rencode
|
PORTNAME= rencode
|
||||||
PORTVERSION= 1.0.6
|
PORTVERSION= 1.0.6
|
||||||
PORTREVISION= 1
|
PORTREVISION= 2
|
||||||
CATEGORIES= converters devel python
|
CATEGORIES= converters devel python
|
||||||
MASTER_SITES= PYPI
|
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
|
||||||
MAINTAINER= python@FreeBSD.org
|
MAINTAINER= python@FreeBSD.org
|
||||||
|
@ -12,9 +11,17 @@ WWW= https://github.com/aresch/rencode
|
||||||
LICENSE= GPLv3
|
LICENSE= GPLv3
|
||||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython3>0:lang/cython3@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= cpe python
|
USES= cpe python
|
||||||
CPE_VENDOR= ${PORTNAME}_project
|
CPE_VENDOR= ${PORTNAME}_project
|
||||||
USE_PYTHON= autoplist distutils
|
USE_PYTHON= autoplist pep517
|
||||||
|
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_ACCOUNT= aresch
|
||||||
|
GH_TAGNAME= 572ff74586d9b1daab904c6f7f7009ce0143bb75
|
||||||
|
|
||||||
# Make setup.py test target work with setup.py:test_suite
|
# Make setup.py test target work with setup.py:test_suite
|
||||||
# See: files/patch-setup.py
|
# See: files/patch-setup.py
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1540227451
|
TIMESTAMP = 1706773577
|
||||||
SHA256 (rencode-1.0.6.tar.gz) = 2586435c4ea7d45f74e26765ad33d75309de7cf47c4d762e8efabd39905c0718
|
SHA256 (aresch-rencode-1.0.6-572ff74586d9b1daab904c6f7f7009ce0143bb75_GH0.tar.gz) = af3c1193a54713ac036c35fe516a6bea391c38442d81ff9721e06bf777335f7c
|
||||||
SIZE (rencode-1.0.6.tar.gz) = 74660
|
SIZE (aresch-rencode-1.0.6-572ff74586d9b1daab904c6f7f7009ce0143bb75_GH0.tar.gz) = 25887
|
||||||
|
|
|
@ -1,37 +1,20 @@
|
||||||
# 1) converters/py-rencode: Fails to configure if cython is installed
|
# 1) make setup.py test command work via test_suite directive
|
||||||
# 2) make setup.py test command work via test_suite directive
|
# 2) Honour/respect user CFLAGS
|
||||||
# 3) Honour/respect user CFLAGS
|
|
||||||
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233561
|
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233561
|
||||||
|
|
||||||
--- setup.py.orig 2018-10-21 17:41:35 UTC
|
--- setup.py.orig 2024-01-31 07:33:33 UTC
|
||||||
+++ setup.py
|
+++ setup.py
|
||||||
@@ -29,19 +29,14 @@ from distutils.errors import CCompilerError, Distutils
|
@@ -42,7 +42,6 @@ ext_modules = [
|
||||||
from setuptools import setup
|
|
||||||
from setuptools.extension import Extension
|
|
||||||
|
|
||||||
-try:
|
|
||||||
- from Cython.Build import build_ext
|
|
||||||
- from Cython.Build import cythonize
|
|
||||||
-except ImportError as ex:
|
|
||||||
- from setuptools.command.build_ext import build_ext
|
|
||||||
- cythonize = False
|
|
||||||
+from setuptools.command.build_ext import build_ext
|
|
||||||
+cythonize = False
|
|
||||||
|
|
||||||
source_ext = ".pyx" if cythonize else ".c"
|
|
||||||
|
|
||||||
ext_modules = [
|
ext_modules = [
|
||||||
Extension(
|
Extension(
|
||||||
"rencode._rencode",
|
"rencode._rencode",
|
||||||
- extra_compile_args=["-O3"],
|
- extra_compile_args=["-O3"],
|
||||||
sources=["rencode/rencode" + source_ext],
|
sources=["rencode/_rencode" + source_ext],
|
||||||
),
|
),
|
||||||
]
|
]
|
||||||
@@ -92,5 +87,6 @@ setup(
|
@@ -97,4 +96,5 @@ setup(
|
||||||
url="https://github.com/aresch/rencode",
|
cmdclass={"build_ext": optional_build_ext},
|
||||||
cmdclass={'build_ext': optional_build_ext},
|
|
||||||
ext_modules=ext_modules,
|
ext_modules=ext_modules,
|
||||||
- setup_requires=['setuptools', 'wheel'],
|
setup_requires=["setuptools"],
|
||||||
+ setup_requires=['setuptools'],
|
|
||||||
+ test_suite='tests',
|
+ test_suite='tests',
|
||||||
)
|
)
|
||||||
|
|
Loading…
Add table
Reference in a new issue