mirror of
https://git.freebsd.org/ports.git
synced 2025-05-19 18:43:13 -04:00
multimedia/libvpx: unblock build on mips*
mips* cannot use lang/gcc*, so let it use GCC 4.2 in base. Other archs may work as well but x86 won't per r422956.
This commit is contained in:
parent
3c521411c8
commit
a013e66d91
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=451562
2 changed files with 16 additions and 5 deletions
|
@ -18,7 +18,7 @@ BUILD_DEPENDS= yasm:devel/yasm
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= webmproject
|
||||
|
||||
USES= compiler:c11 cpe gmake perl5 shebangfix
|
||||
USES= cpe gmake perl5 shebangfix
|
||||
CPE_VENDOR= john_koleszar
|
||||
HAS_CONFIGURE= yes
|
||||
USE_PERL5= build
|
||||
|
|
|
@ -1,8 +1,19 @@
|
|||
--- libs.mk.orig
|
||||
--- libs.mk.orig 2017-01-12 20:27:27 UTC
|
||||
+++ libs.mk
|
||||
@@ -232,8 +232,8 @@
|
||||
$(qexec)echo 'Libs: -L$${libdir} -lvpx' >> $@
|
||||
$(qexec)echo 'Libs.private: -lm -pthread' >> $@
|
||||
@@ -117,8 +117,8 @@ endif
|
||||
$(BUILD_PFX)third_party/googletest/%.cc.o: CXXFLAGS += -Wno-missing-field-initializers
|
||||
# Suppress -Wextra warnings in first party code pending investigation.
|
||||
# https://bugs.chromium.org/p/webm/issues/detail?id=1069
|
||||
-$(BUILD_PFX)vp8/encoder/onyx_if.c.o: CFLAGS += -Wno-unknown-warning-option -Wno-clobbered
|
||||
-$(BUILD_PFX)vp8/decoder/onyxd_if.c.o: CFLAGS += -Wno-unknown-warning-option -Wno-clobbered
|
||||
+$(BUILD_PFX)vp8/encoder/onyx_if.c.o: CFLAGS += -Wno-extra
|
||||
+$(BUILD_PFX)vp8/decoder/onyxd_if.c.o: CFLAGS += -Wno-extra
|
||||
|
||||
ifeq ($(CONFIG_MSVS),yes)
|
||||
CODEC_LIB=$(if $(CONFIG_STATIC_MSVCRT),vpxmt,vpxmd)
|
||||
@@ -339,8 +339,8 @@ else
|
||||
$(qexec)echo 'Libs.private: -lm' >> $@
|
||||
endif
|
||||
$(qexec)echo 'Cflags: -I$${includedir}' >> $@
|
||||
-INSTALL-LIBS-yes += $(LIBSUBDIR)/pkgconfig/vpx.pc
|
||||
-INSTALL_MAPS += $(LIBSUBDIR)/pkgconfig/%.pc %.pc
|
||||
|
|
Loading…
Add table
Reference in a new issue