mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
science/py-pnetcdf: Add py-pnetcdf 1.0.0
PnetCDF-Python is a Python interface to PnetCDF, a high-performance I/O library for accessing NetCDF files in parallel. It can provide MPI-based parallel python programs to achieve a scalable I/O performance.
This commit is contained in:
parent
942018fffd
commit
9e122cc43f
5 changed files with 48 additions and 0 deletions
|
@ -394,6 +394,7 @@
|
|||
SUBDIR += py-periodictable
|
||||
SUBDIR += py-phono3py
|
||||
SUBDIR += py-phonopy
|
||||
SUBDIR += py-pnetcdf
|
||||
SUBDIR += py-pupynere
|
||||
SUBDIR += py-py3Dmol
|
||||
SUBDIR += py-pyaixi
|
||||
|
|
30
science/py-pnetcdf/Makefile
Normal file
30
science/py-pnetcdf/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
PORTNAME= pnetcdf
|
||||
PORTVERSION= 1.0.0
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Object-oriented python interface to the PnetCDF library
|
||||
WWW= https://github.com/Parallel-NetCDF/PnetCDF-Python
|
||||
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py-mpich>=3.1.4:net/py-mpi4py-mpich@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=23.1:devel/py-packaging@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
LIB_DEPENDS= libpnetcdf.so:science/pnetcdf@mpich
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py-mpich>=3.1.4:net/py-mpi4py-mpich@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
|
||||
|
||||
USES= localbase mpi:mpich python
|
||||
USE_PYTHON= autoplist concurrent cython cython_run pep517
|
||||
|
||||
CFLAGS+= -I${MPI_HOME}/include
|
||||
|
||||
post-install:
|
||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||
|
||||
.include <bsd.port.mk>
|
3
science/py-pnetcdf/distinfo
Normal file
3
science/py-pnetcdf/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1736671165
|
||||
SHA256 (pnetcdf-1.0.0.tar.gz) = b2de14944e921a10072b7b51e7f4664c7aa175dd54c3d61f50bd88c902a673cb
|
||||
SIZE (pnetcdf-1.0.0.tar.gz) = 87294
|
11
science/py-pnetcdf/files/patch-pyproject.toml
Normal file
11
science/py-pnetcdf/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pyproject.toml.orig 2024-09-10 15:35:50 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -2,7 +2,7 @@ requires = [
|
||||
requires = [
|
||||
"Cython>=0.29",
|
||||
"numpy",
|
||||
- "setuptools>=65",
|
||||
+ "setuptools>=61",
|
||||
"mpi4py>=3.1.4",
|
||||
"packaging>=23.1",
|
||||
"wheel"
|
3
science/py-pnetcdf/pkg-descr
Normal file
3
science/py-pnetcdf/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
PnetCDF-Python is a Python interface to PnetCDF, a high-performance I/O library
|
||||
for accessing NetCDF files in parallel. It can provide MPI-based parallel python
|
||||
programs to achieve a scalable I/O performance.
|
Loading…
Add table
Reference in a new issue