mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
repo-copy sgrep to sgrep2 and upgrade sgrep2 to 1.92a
set CONFLICT in sgrep and sgrep2 Makefile
This commit is contained in:
parent
6dec496765
commit
9a4ad553c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93206
8 changed files with 33 additions and 65 deletions
|
@ -441,6 +441,7 @@
|
|||
SUBDIR += sgmltools
|
||||
SUBDIR += sgmltools-lite
|
||||
SUBDIR += sgrep
|
||||
SUBDIR += sgrep2
|
||||
SUBDIR += sk-aspell
|
||||
SUBDIR += smartdoc
|
||||
SUBDIR += smartdoc-devel
|
||||
|
|
|
@ -7,12 +7,15 @@
|
|||
|
||||
PORTNAME= sgrep
|
||||
PORTVERSION= 0.99
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/
|
||||
|
||||
MAINTAINER= jkoshy@freebsd.org
|
||||
COMMENT= A `grep' for structured text like SGML and HTML
|
||||
|
||||
CONFLICT= sgrep2
|
||||
|
||||
MAN1= sgrep.1
|
||||
|
||||
# Override the install target in the supplied makefile
|
||||
|
|
|
@ -1,24 +1,25 @@
|
|||
# New ports collection makefile for: sgrep
|
||||
# Date created: Apr 29 1998
|
||||
# Whom: <koshy@india.hp.com>
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: sgrep2
|
||||
# Date created: Oct 31, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sgrep
|
||||
PORTVERSION= 0.99
|
||||
PORTNAME= sgrep2
|
||||
PORTVERSION= 1.92a
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/
|
||||
DISTNAME= sgrep-${PORTVERSION}
|
||||
|
||||
MAINTAINER= jkoshy@freebsd.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A `grep' for structured text like SGML and HTML
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --datadir=${DATADIR}
|
||||
|
||||
CONFLICT= sgrep
|
||||
|
||||
MAN1= sgrep.1
|
||||
|
||||
# Override the install target in the supplied makefile
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sgrep ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/sgrep.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/sample.sgreprc ${PREFIX}/share/sgreprc
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (sgrep-0.99.tar.gz) = af09a90c4f1929bfae4818c8962a8907
|
||||
MD5 (sgrep-1.92a.tar.gz) = 99eb1ed515648f653fc7be45e0896378
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
--- Makefile-- Wed Apr 29 12:08:55 1998
|
||||
+++ Makefile Wed Apr 29 12:20:29 1998
|
||||
@@ -10,11 +10,11 @@
|
||||
#
|
||||
|
||||
# This is where the executable goes
|
||||
-BINDIR = /usr/local/bin/
|
||||
+BINDIR = ${PREFIX}/bin
|
||||
# Where sgrep library files are placed (sgreprc)
|
||||
-LIBDIR = /usr/local/lib
|
||||
+LIBDIR = ${PREFIX}/share
|
||||
# Where the manual page goes
|
||||
-MANFILE = /usr/local/man/man1/sgrep.1
|
||||
+MANFILE = ${PREFIX}/man/man1/sgrep.1
|
||||
# Where the sample rc file goes
|
||||
RCFILE = $(LIBDIR)/sgreprc
|
||||
# If you can't install as root you might wan't to use this as rc file
|
||||
@@ -45,11 +45,7 @@
|
||||
clean:
|
||||
-rm -f $(OBJECTS)
|
||||
|
||||
-install: sgrep
|
||||
- cp sgrep $(BINDIR)/sgrep
|
||||
- chmod 755 $(BINDIR)/sgrep
|
||||
- cp sgrep.1 $(MANFILE)
|
||||
- chmod 644 $(MANFILE)
|
||||
+install:
|
||||
|
||||
install.rc: sample.sgreprc
|
||||
cp sample.sgreprc $(RCFILE)
|
|
@ -1,11 +0,0 @@
|
|||
--- sgrep.1-- Wed Apr 29 12:26:40 1998
|
||||
+++ sgrep.1 Wed Apr 29 12:26:49 1998
|
||||
@@ -91,7 +91,7 @@
|
||||
\fB$HOME/.sgreprc,\fP
|
||||
or if it doesn't exist,
|
||||
from file
|
||||
-\fB/usr/lib/sgreprc, \fP
|
||||
+\fB/usr/local/share/sgreprc, \fP
|
||||
and then from the command line. Different behavior
|
||||
can be specified through command line options.
|
||||
.Pp
|
|
@ -1,13 +1,16 @@
|
|||
`sgrep' (structured grep) is a tool for searching text files and
|
||||
filtering text streams using structural criteria. Complex criteria
|
||||
can be specified as macros using M4.
|
||||
sgrep (structured grep) is a tool for searching and indexing text, SGML,XML
|
||||
and HTML files and filtering text streams using structural criteria. The data
|
||||
model of sgrep is based on regions, which are nonempty substrings of text.
|
||||
Regions are typically occurrences of constant strings, SGML-tags, or meaningful
|
||||
text elements, which are recognizable through some delimiting strings or the
|
||||
builtin SGML, XML and HTML parser. Regions can be arbitrarily long, arbitrarily
|
||||
overlapping, and arbitrarily nested.
|
||||
|
||||
Sgrep was created by:
|
||||
|
||||
Jani Jaakkola, email:Jani.Jaakkola@helsinki.fi
|
||||
Pekka Kilpelainen, email: Pekka.Kilpelainen@helsinki.fi
|
||||
Sgrep is a convenient tool for making queries to almost any kind of text files
|
||||
with some well kown structure. These include programs, mail folders, news
|
||||
folders, HTML, SGML, etc... With relatively simple queries you can display mail
|
||||
messages by their subject or sender, extract titles or links or any regions
|
||||
from HTML files, function prototypes from C or make complex queries to SGML
|
||||
files based on the DTD of the file.
|
||||
|
||||
WWW: http://www.cs.helsinki.fi/u/jjaakkol/sgrep.html
|
||||
|
||||
- Koshy
|
||||
<jkoshy@acm.org>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
bin/sgrep
|
||||
share/sgreprc
|
||||
%%DATADIR%%/sample.sgreprc
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Add table
Reference in a new issue