- Unbreak: the self-tests included with bglibs contains several

network related tests (namely, in net/connect4.c and net/tcp4.c)
  that fails in our package build cluster environment.
  Thus, disable running self-tests during build process - create
  a separate "selftest" Makefile target that would allow users
  to run self-tests manually with "make selftest"
- Add USE_LDCONFIG

Nagged by:	pointyhat via kris
Discussed with:	oliver
This commit is contained in:
Sergei Kolobov 2006-09-20 10:40:31 +00:00
parent 782dc24ee3
commit 97c91ba03d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=173455
2 changed files with 15 additions and 4 deletions

View file

@ -13,10 +13,6 @@ MASTER_SITES= http://untroubled.org/${PORTNAME}/
MAINTAINER= sergei@FreeBSD.org
COMMENT= One stop library package by Bruce Guenter
BROKEN= Fails self-tests
DEPRECATED= ${BROKEN}
EXPIRATION_DATE=2006-12-01
NOT_FOR_ARCHS= alpha
USE_GPG= yes
@ -27,6 +23,7 @@ USE_AUTOTOOLS= libtool:15:env
LDFLAGS?= -s
BGLIBS_INC= ${PREFIX}/include/${PORTNAME}
BGLIBS_LIB= ${PREFIX}/lib/${PORTNAME}
USE_LDCONFIG= ${BGLIBS_LIB}
DOCS= NEWS README TODO doc/html/*
MAN1= cli-generate.1
@ -46,4 +43,7 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
selftest: build
cd ${WRKSRC} && ${SH} selftests.sh
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- Makefile.orig Wed Sep 20 13:44:49 2006
+++ Makefile Wed Sep 20 13:45:05 2006
@@ -126,7 +126,7 @@ adt/hashs.lo: libcompile adt/hashs.c adt
adt/hashs.o: compile adt/hashs.c adt/common.h
./compile adt/hashs.c
-all: dotlibs sysdeps.h libraries bg-installer cli-generate selftests
+all: dotlibs sysdeps.h libraries bg-installer cli-generate
base64/asc2bin.lo: libcompile base64/asc2bin.c base64/base64.h str/str.h
./libcompile base64/asc2bin.c