mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
textproc/py-gensim: update 4.3.2 → 4.3.3
Reported by: portscout
This commit is contained in:
parent
9241aded7b
commit
96886ab6fd
3 changed files with 20 additions and 17 deletions
|
@ -1,6 +1,5 @@
|
||||||
PORTNAME= gensim
|
PORTNAME= gensim
|
||||||
DISTVERSION= 4.3.2
|
DISTVERSION= 4.3.3
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= textproc python
|
CATEGORIES= textproc python
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -12,18 +11,23 @@ WWW= https://radimrehurek.com/gensim/
|
||||||
LICENSE= LGPL21
|
LICENSE= LGPL21
|
||||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
PY_DEPENDS= ${PYNUMPY} \
|
|
||||||
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
|
|
||||||
${PYTHON_PKGNAMEPREFIX}smart-open>=1.8.1:net/py-smart-open@${PY_FLAVOR}
|
|
||||||
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
|
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
|
||||||
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
|
${PYNUMPY} \
|
||||||
${PY_DEPENDS}
|
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
|
||||||
RUN_DEPENDS= ${PY_DEPENDS}
|
RUN_DEPENDS= ${PYNUMPY} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}scipy>=1.7.0:science/py-scipy@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}smart-open>=1.8.1:net/py-smart-open@${PY_FLAVOR}
|
||||||
|
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}testfixtures>0:devel/py-testfixtures@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= compiler:c++11-lang python
|
USES= compiler:c++11-lang python
|
||||||
USE_PYTHON= pep517 cython autoplist pytest # tests fail, see https://github.com/RaRe-Technologies/gensim/issues/3491
|
USE_PYTHON= pep517 cython autoplist pytest # tests fail unde PyTest, see https://github.com/RaRe-Technologies/gensim/issues/3561
|
||||||
|
|
||||||
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
|
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
|
||||||
|
TEST_WRKSRC= ${WRKSRC}/gensim/test
|
||||||
|
|
||||||
|
# python setup.py build_ext --inplace
|
||||||
|
xPYDISTUTILS_BUILD_TARGET= build_ext
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name "*.so" | ${XARGS} ${STRIP_CMD}
|
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name "*.so" | ${XARGS} ${STRIP_CMD}
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1693202511
|
TIMESTAMP = 1726687146
|
||||||
SHA256 (gensim-4.3.2.tar.gz) = 99ac6af6ffd40682e70155ed9f92ecbf4384d59fb50af120d343ea5ee1b308ab
|
SHA256 (gensim-4.3.3.tar.gz) = 84852076a6a3d88d7dac5be245e24c21c3b819b565e14c1b61fa3e5ee76dcf57
|
||||||
SIZE (gensim-4.3.2.tar.gz) = 23263982
|
SIZE (gensim-4.3.3.tar.gz) = 23258708
|
||||||
|
|
|
@ -1,13 +1,12 @@
|
||||||
--- pyproject.toml.orig 2023-08-28 06:12:49 UTC
|
--- pyproject.toml.orig 2024-07-19 13:32:36 UTC
|
||||||
+++ pyproject.toml
|
+++ pyproject.toml
|
||||||
@@ -7,8 +7,8 @@ requires = [
|
@@ -7,8 +7,7 @@ requires = [
|
||||||
"Cython>=0.29.32,<3.0.0",
|
"Cython>=0.29.32,<3.0.0",
|
||||||
# oldest supported Numpy for this platform is 1.17 but the oldest supported by Gensim
|
# oldest supported Numpy for this platform is 1.17 but the oldest supported by Gensim
|
||||||
# is 1.18.5, remove the line when they increase oldest supported Numpy for this platform
|
# is 1.18.5, remove the line when they increase oldest supported Numpy for this platform
|
||||||
- "numpy==1.18.5; python_version=='3.8' and platform_machine not in 'arm64|aarch64'",
|
- "numpy==1.18.5; python_version=='3.8' and platform_machine not in 'arm64|aarch64'",
|
||||||
- "oldest-supported-numpy; python_version>'3.8' or platform_machine in 'arm64|aarch64'",
|
- "oldest-supported-numpy; python_version>'3.8' or platform_machine in 'arm64|aarch64'",
|
||||||
+ #"numpy==1.18.5; python_version=='3.8' and platform_machine not in 'arm64|aarch64'",
|
+ "numpy; python_version>'3.8' or platform_machine in 'arm64|aarch64'",
|
||||||
+ "numpy>0; python_version>'3.8' or platform_machine in 'arm64|aarch64'",
|
|
||||||
"scipy",
|
|
||||||
"setuptools",
|
"setuptools",
|
||||||
"wheel",
|
"wheel",
|
||||||
|
]
|
||||||
|
|
Loading…
Add table
Reference in a new issue