mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
New port ta2as version 0.8: TASM to AT&T asm syntax converter
(GNU AS)
This commit is contained in:
parent
d407f0f560
commit
9605ff64f8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151859
6 changed files with 97 additions and 0 deletions
|
@ -79,6 +79,7 @@
|
||||||
SUBDIR += shftool
|
SUBDIR += shftool
|
||||||
SUBDIR += showkey
|
SUBDIR += showkey
|
||||||
SUBDIR += siconv
|
SUBDIR += siconv
|
||||||
|
SUBDIR += ta2as
|
||||||
SUBDIR += tnef
|
SUBDIR += tnef
|
||||||
SUBDIR += trans
|
SUBDIR += trans
|
||||||
SUBDIR += tuc
|
SUBDIR += tuc
|
||||||
|
|
54
converters/ta2as/Makefile
Normal file
54
converters/ta2as/Makefile
Normal file
|
@ -0,0 +1,54 @@
|
||||||
|
# New ports collection makefile for: TASM TO AT&T asm
|
||||||
|
# Date created: Thu Dec 22 14:46:11 UTC 2005
|
||||||
|
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= ta2as
|
||||||
|
PORTVERSION= 0.8
|
||||||
|
CATEGORIES= converters devel
|
||||||
|
MASTER_SITES= ftp://ftp.delorie.com/pub/djgpp/contrib/ \
|
||||||
|
ftp://x2ftp.oulu.fi/pub/msdos/programming/convert/
|
||||||
|
DISTNAME= ta2asv${PORTVERSION:S/.//}
|
||||||
|
|
||||||
|
MAINTAINER= lioux@FreeBSD.org
|
||||||
|
COMMENT= TASM to AT&T asm syntax converter (GNU AS)
|
||||||
|
|
||||||
|
USE_ZIP= yes
|
||||||
|
USE_REINPLACE= yes
|
||||||
|
NO_WRKSUBDIR= yes
|
||||||
|
|
||||||
|
EXTRACT_BEFORE_ARGS= -q -a -L
|
||||||
|
|
||||||
|
PLIST_FILES= bin/${PORTNAME}
|
||||||
|
|
||||||
|
.ifndef(NOPORTDOCS)
|
||||||
|
PORTDOCS= readme.doc
|
||||||
|
.endif
|
||||||
|
|
||||||
|
post-extract:
|
||||||
|
@${CP} ${FILESDIR}/strtolower.c ${WRKSRC}
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
@${REINPLACE_CMD} -E \
|
||||||
|
-e 's|stricmp|strcasecmp|' \
|
||||||
|
-e 's|strnicmp|strncasecmp|' \
|
||||||
|
-e 's|strlwr|strtolower|' \
|
||||||
|
${WRKSRC}/${PORTNAME}.c
|
||||||
|
|
||||||
|
do-build:
|
||||||
|
@cd ${WRKSRC} && \
|
||||||
|
${CC} ${CFLAGS} \
|
||||||
|
-s meen.c strtolower.c ta2as.c \
|
||||||
|
-o ${PORTNAME}
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
.ifndef(NOPORTDOCS)
|
||||||
|
@${MKDIR} ${DOCSDIR}
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/readme.doc ${DOCSDIR}
|
||||||
|
.endif
|
||||||
|
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
|
||||||
|
${PREFIX}/bin
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
converters/ta2as/distinfo
Normal file
3
converters/ta2as/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
MD5 (ta2asv08.zip) = d6996109f025faa2c9b6b53c6dfaa179
|
||||||
|
SHA256 (ta2asv08.zip) = fa2362b464ced0ace0bc6eeee17e822fd009e5896d791982fc16308b5266543f
|
||||||
|
SIZE (ta2asv08.zip) = 27208
|
10
converters/ta2as/files/patch-ta2as.c
Normal file
10
converters/ta2as/files/patch-ta2as.c
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- ta2as.c.orig Thu Dec 22 14:30:47 2005
|
||||||
|
+++ ta2as.c Thu Dec 22 14:29:17 2005
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
#include "ta2as.h"
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <string.h>
|
||||||
|
+#include <strings.h>
|
||||||
|
|
||||||
|
char rarray[38][4]=
|
||||||
|
{
|
12
converters/ta2as/files/strtolower.c
Normal file
12
converters/ta2as/files/strtolower.c
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
#include <ctype.h>
|
||||||
|
|
||||||
|
char *
|
||||||
|
strtolower(char *str)
|
||||||
|
{
|
||||||
|
char *s;
|
||||||
|
|
||||||
|
for (s = str; *s; ++s);
|
||||||
|
*s = tolower(*s);
|
||||||
|
|
||||||
|
return(str);
|
||||||
|
}
|
17
converters/ta2as/pkg-descr
Normal file
17
converters/ta2as/pkg-descr
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
[ excerpt from distfile's README with modifications ]
|
||||||
|
|
||||||
|
This is the first version of TASM to AT&T converter (TA2AS). Frank
|
||||||
|
van Dijk, member of SPiRiT!, wrote this utility. It reads in a
|
||||||
|
source file with TASM syntax and tries(first version remember? :))
|
||||||
|
to convert it to AT&T syntax. It hasn't been tested very well. So
|
||||||
|
email all your bugreports to one of the SPiRiT emailaddresses (see
|
||||||
|
below). Also for wanted features! But the sourcefile is included
|
||||||
|
so why don't you try first :)
|
||||||
|
|
||||||
|
This is one of the utilities we wrote, to make life easier when
|
||||||
|
working with DJGPP! :)
|
||||||
|
|
||||||
|
|
||||||
|
WWW: http://udrecsuite.sourceforge.net/
|
||||||
|
|
||||||
|
-- lioux@FreeBSD.org
|
Loading…
Add table
Reference in a new issue