- Revivify and unbreak by fixing problematic code and

suppressing dreaded C++11 narrowing warnings/errors
- Convert to USES+=localbase and optimize away LIBS+=
- Remove excessive vertical whitespace from one patch
- Chase HTTP redirection in the WWW line of pkg-descr
This commit is contained in:
Alexey Dokuchaev 2021-03-04 14:46:55 +00:00
parent 49a4f7c7b3
commit 92e06c2342
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=567316
13 changed files with 711 additions and 1 deletions

1
MOVED
View file

@ -12657,7 +12657,6 @@ games/voxelands-server||2019-05-09|Has expired: Broken for more than 6 months
games/warsow||2019-05-09|Has expired: Broken for more than 6 months
graphics/apvlv||2019-05-09|Has expired: Broken for more than 6 months
graphics/qslim||2019-05-09|Has expired: Broken for more than 6 months
graphics/rawstudio||2019-05-09|Has expired: Broken for more than 6 months
graphics/tulip||2019-05-09|Has expired: Broken for more than 6 months
lang/qore||2019-05-09|Has expired: Broken for more than 6 months
math/goblin||2019-05-09|Has expired: Broken for more than 6 months

View file

@ -931,6 +931,7 @@
SUBDIR += radius-engine
SUBDIR += rapid-photo-downloader
SUBDIR += raster3d
SUBDIR += rawstudio
SUBDIR += rawtherapee
SUBDIR += rayshade
SUBDIR += reactphysics3d

View file

@ -0,0 +1,43 @@
# Created by: Alex Samorukov <samm@os2.kiev.ua>
# $FreeBSD$
PORTNAME= rawstudio
PORTVERSION= 2.0
PORTREVISION= 19
CATEGORIES= graphics
MASTER_SITES= http://rawstudio.org/files/release/
MAINTAINER= samm@os2.kiev.ua
COMMENT= Open-source program to read and manipulate RAW photo images
LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
liblcms.so:graphics/lcms \
libexiv2.so:graphics/exiv2 \
libdbus-1.so:devel/dbus \
libfftw3f.so:math/fftw3-float \
liblensfun.so:graphics/lensfun \
libflickcurl.so:www/flickcurl \
libgphoto2.so:graphics/libgphoto2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
BROKEN_powerpc64= fails to link: libicuuc.so. undefined reference to __cxa_throw_bad_array_new_length
USES= compiler:c++11-lang desktop-file-utils gettext gmake \
gnome jpeg libtool localbase pathfix pkgconfig sqlite
GNU_CONFIGURE= yes
USE_GNOME= gtk20 libxml2 gconf2
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CXXFLAGS+= -Wno-c++11-narrowing
post-patch:
@${REINPLACE_CMD} -e '/^pkg_modules=/s,libssl,gthread-2.0,' \
${WRKSRC}/configure
# lensfun 0.3.0 had removed support for LF_MODIFY_CCI
@${REINPLACE_CMD} -e 's, | LF_MODIFY_CCI,,' \
${WRKSRC}/plugins/lensfun/lensfun.c
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (rawstudio-2.0.tar.gz) = 14cd5aff315ca9a28ec359ed2da0d993f0022b548a1751f208463ea823b2a7fc
SIZE (rawstudio-2.0.tar.gz) = 1537703

View file

@ -0,0 +1,33 @@
--- librawstudio/rs-exif.cc.orig
+++ librawstudio/rs-exif.cc
@@ -21,6 +21,8 @@
#include <iomanip>
#include <exiv2/image.hpp>
#include <exiv2/exif.hpp>
+#include <exiv2/error.hpp>
+#include <exiv2/version.hpp>
#include "rs-exif.h"
#include <assert.h>
#include "rs-library.h"
--- plugins/load-gdk/exiv2-colorspace.cpp.orig
+++ plugins/load-gdk/exiv2-colorspace.cpp
@@ -22,6 +22,8 @@
#include <iomanip>
#include <exiv2/image.hpp>
#include <exiv2/exif.hpp>
+#include <exiv2/version.hpp>
+#include <exiv2/error.hpp>
#include <assert.h>
#include "exiv2-colorspace.h"
#include <math.h>
--- plugins/meta-exiv2/exiv2-metadata.cpp.orig
+++ plugins/meta-exiv2/exiv2-metadata.cpp
@@ -22,6 +22,8 @@
#include <iomanip>
#include <exiv2/image.hpp>
#include <exiv2/exif.hpp>
+#include <exiv2/version.hpp>
+#include <exiv2/error.hpp>
#include <assert.h>
#include "exiv2-metadata.h"
#include <math.h>

View file

@ -0,0 +1,35 @@
--- plugins/output-pngfile/output-pngfile.c
+++ plugins/output-pngfile/output-pngfile.c
@@ -23,6 +23,7 @@
#include <gettext.h>
#include "config.h"
#include <png.h>
+#include <zlib.h>
#define RS_TYPE_PNGFILE (rs_pngfile_type)
#define RS_PNGFILE(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), RS_TYPE_PNGFILE, RSPngfile))
@@ -198,7 +199,7 @@
rs_icc_profile_get_data(profile, &data, &data_length);
// FIXME: Insert correct profile name
- png_set_iCCP(png_ptr, info_ptr, "Profile name", PNG_COMPRESSION_TYPE_BASE, data, data_length);
+ png_set_iCCP(png_ptr, info_ptr, "Profile name", PNG_COMPRESSION_TYPE_BASE, (png_const_bytep)data, data_length);
if (pngfile->save16bit)
png_set_gAMA(png_ptr, info_ptr, 1.0);
}
--- plugins/load-gdk/exiv2-colorspace.cpp
+++ plugins/load-gdk/exiv2-colorspace.cpp
@@ -125,11 +125,11 @@
int compression_type;
/* Extract embedded ICC profile */
- if (info_ptr->valid & PNG_INFO_iCCP)
+ if (png_get_valid(png_ptr, info_ptr, TRUE) & PNG_INFO_iCCP)
{
png_uint_32 retval = png_get_iCCP (png_ptr, info_ptr,
(png_charpp) &icc_profile_title, &compression_type,
- (png_charpp) &icc_profile, (png_uint_32*) &icc_profile_size);
+ (png_byte**) &icc_profile, (png_uint_32*) &icc_profile_size);
if (retval != 0)
{
RSIccProfile *icc = rs_icc_profile_new_from_memory((gchar*)icc_profile, icc_profile_size, TRUE);

View file

@ -0,0 +1,38 @@
--- plugins/denoise/fftwindow.cpp.orig 2011-02-15 17:28:03 UTC
+++ plugins/denoise/fftwindow.cpp
@@ -174,7 +174,7 @@ void FFTWindow::applyAnalysisWindowSSE(
if ((uintptr_t)src1 & 15) {
asm volatile
(
- "loop_analysis_sse_ua:\n"
+ "1:\n"
"prefetchnta (%4)\n" // Prefetch next line (Used once only, so don't pollute cache)
"movups (%1), %%xmm0\n" // src1 pt1
"movups 16(%1), %%xmm1\n" // src1 pt2
@@ -193,7 +193,7 @@ void FFTWindow::applyAnalysisWindowSSE(
"add $64, %2\n"
"add $64, %4\n"
"dec %3\n"
- "jnz loop_analysis_sse_ua\n"
+ "jnz 1b\n"
: /* no output registers */
: "r" (analysis.getLine(y)), "r" (src1), "r" (dst->getLine(y)), "r" (sizew), "r" (&src1[image->pitch])
@@ -202,7 +202,7 @@ void FFTWindow::applyAnalysisWindowSSE(
} else {
asm volatile
(
- "loop_analysis_sse_a:\n"
+ "1:\n"
"prefetchnta (%4)\n" // Prefetch next line (Used once only, so don't pollute cache)
"movaps (%1), %%xmm0\n" // src1 pt1
"movaps 16(%1), %%xmm1\n" // src1 pt2
@@ -221,7 +221,7 @@ void FFTWindow::applyAnalysisWindowSSE(
"add $64, %2\n"
"add $64, %4\n"
"dec %3\n"
- "jnz loop_analysis_sse_a\n"
+ "jnz 1b\n"
: /* no output registers */
: "r" (analysis.getLine(y)), "r" (src1), "r" (dst->getLine(y)), "r" (sizew), "r" (&src1[image->pitch])

View file

@ -0,0 +1,21 @@
--- plugins/load-dcraw/dcraw.cc.orig 2015-05-29 01:03:46 UTC
+++ plugins/load-dcraw/dcraw.cc
@@ -869,7 +869,8 @@ struct jhead {
int CLASS ljpeg_start (struct jhead *jh, int info_only)
{
- int c, tag, len;
+ int c, tag;
+ ushort len;
uchar data[0x10000];
const uchar *dp;
@@ -8605,7 +8606,7 @@ void CLASS tiff_head (struct tiff_hdr *th, int full)
strncpy (th->desc, desc, 512);
strncpy (th->make, make, 64);
strncpy (th->model, model, 64);
- strcpy (th->soft, "dcraw v"DCRAW_VERSION);
+ strcpy (th->soft, "dcraw v" DCRAW_VERSION);
t = gmtime (&timestamp);
sprintf (th->date, "%04d:%02d:%02d %02d:%02d:%02d",
t->tm_year+1900,t->tm_mon+1,t->tm_mday,t->tm_hour,t->tm_min,t->tm_sec);

View file

@ -0,0 +1,16 @@
--- librawstudio/rs-macros.h 2014-02-19 06:34:15.000000000 +0100
+++ librawstudio/rs-macros.h 2014-02-19 06:34:21.000000000 +0100
@@ -51,12 +51,12 @@
#if __GNUC__ >= 3
#define likely(x) __builtin_expect (!!(x), 1)
#define unlikely(x) __builtin_expect (!!(x), 0)
-#define align(x) __attribute__ ((aligned (x)))
+// #define align(x) __attribute__ ((aligned (x)))
#define __deprecated __attribute__ ((deprecated))
#else
#define likely(x) (x)
#define unlikely(x) (x)
-#define align(x)
+// #define align(x)
#define __deprecated
#endif

View file

@ -0,0 +1,26 @@
--- src/rs-tag-gui.c.orig 2011-02-15 18:28:05.000000000 +0100
+++ src/rs-tag-gui.c 2014-02-14 18:36:48.000000000 +0100
@@ -93,11 +93,6 @@
return box;
}
-GtkWidget *
-rs_library_tag_entry_new(RSLibrary *library)
-{
- g_assert(RS_IS_LIBRARY(library));
-
gboolean
selected(GtkEntryCompletion *completion, GtkTreeModel *model, GtkTreeIter *iter, gpointer user_data)
{
@@ -179,6 +174,11 @@
return found;
}
+GtkWidget *
+rs_library_tag_entry_new(RSLibrary *library)
+{
+ g_assert(RS_IS_LIBRARY(library));
+
GtkWidget *entry = gtk_entry_new();
GtkEntryCompletion *completion = gtk_entry_completion_new();
GtkListStore *store = gtk_list_store_new(1, G_TYPE_STRING);

View file

@ -0,0 +1,11 @@
--- src/rs-batch.c.orig 2011-04-07 18:05:03 UTC
+++ src/rs-batch.c
@@ -830,7 +830,7 @@ static void
filetype_changed(gpointer active, gpointer user_data)
{
RS_QUEUE *queue = (RS_QUEUE *) user_data;
- GType filetype = GPOINTER_TO_INT(active);
+ GType filetype = (GType)active;
if (!filetype)
return;

View file

@ -0,0 +1,12 @@
Rawstudio is an open-source program to read and manipulate RAW images from
digital cameras. It will convert your RAW files into JPEG, PNG, or TIFF
images which you can then print or send to friends and clients. You can
also upload photos directly to Picasa, Flickr, and Facebook galleries.
Rawstudio is intended to be the first tool in your image processing chain.
After you have made your overall image adjustments to your image, you can
use an image editing application to further work on your images. Rawstudio
itself is a highly specialized application for reviewing and processing RAW
images, not a fully featured image editing application.
WWW: https://rawstudio.org/

View file

@ -0,0 +1,473 @@
bin/rawstudio
include/rawstudio-2.0/rawstudio.h
include/rawstudio-2.0/rs-1d-function.h
include/rawstudio-2.0/rs-color-space-icc.h
include/rawstudio-2.0/rs-color-space-selector.h
include/rawstudio-2.0/rs-color-space.h
include/rawstudio-2.0/rs-color.h
include/rawstudio-2.0/rs-curve.h
include/rawstudio-2.0/rs-dcp-file.h
include/rawstudio-2.0/rs-debug.h
include/rawstudio-2.0/rs-exif.h
include/rawstudio-2.0/rs-filetypes.h
include/rawstudio-2.0/rs-filter-param.h
include/rawstudio-2.0/rs-filter-request.h
include/rawstudio-2.0/rs-filter-response.h
include/rawstudio-2.0/rs-filter.h
include/rawstudio-2.0/rs-gui-functions.h
include/rawstudio-2.0/rs-huesat-map.h
include/rawstudio-2.0/rs-icc-profile.h
include/rawstudio-2.0/rs-image.h
include/rawstudio-2.0/rs-image16.h
include/rawstudio-2.0/rs-io-job-checksum.h
include/rawstudio-2.0/rs-io-job-metadata.h
include/rawstudio-2.0/rs-io-job-prefetch.h
include/rawstudio-2.0/rs-io-job-tagging.h
include/rawstudio-2.0/rs-io-job.h
include/rawstudio-2.0/rs-io.h
include/rawstudio-2.0/rs-job-queue.h
include/rawstudio-2.0/rs-lens-db-editor.h
include/rawstudio-2.0/rs-lens-db.h
include/rawstudio-2.0/rs-lens-fix.h
include/rawstudio-2.0/rs-lens.h
include/rawstudio-2.0/rs-library.h
include/rawstudio-2.0/rs-macros.h
include/rawstudio-2.0/rs-math.h
include/rawstudio-2.0/rs-metadata.h
include/rawstudio-2.0/rs-output.h
include/rawstudio-2.0/rs-plugin-manager.h
include/rawstudio-2.0/rs-plugin.h
include/rawstudio-2.0/rs-profile-camera.h
include/rawstudio-2.0/rs-profile-factory.h
include/rawstudio-2.0/rs-profile-selector.h
include/rawstudio-2.0/rs-rawfile.h
include/rawstudio-2.0/rs-settings.h
include/rawstudio-2.0/rs-spline.h
include/rawstudio-2.0/rs-stock.h
include/rawstudio-2.0/rs-tiff-ifd-entry.h
include/rawstudio-2.0/rs-tiff-ifd.h
include/rawstudio-2.0/rs-tiff.h
include/rawstudio-2.0/rs-types.h
include/rawstudio-2.0/rs-utils.h
include/rawstudio-2.0/x86-cpu.h
lib/librawstudio-2.0.a
lib/librawstudio-2.0.so
lib/librawstudio-2.0.so.0
lib/librawstudio-2.0.so.0.0.0
libdata/pkgconfig/rawstudio-2.0.pc
share/applications/rawstudio.desktop
share/icons/rawstudio.png
share/locale/ca/LC_MESSAGES/rawstudio.mo
share/locale/cs/LC_MESSAGES/rawstudio.mo
share/locale/da/LC_MESSAGES/rawstudio.mo
share/locale/de/LC_MESSAGES/rawstudio.mo
share/locale/en/LC_MESSAGES/rawstudio.mo
share/locale/es/LC_MESSAGES/rawstudio.mo
share/locale/fi/LC_MESSAGES/rawstudio.mo
share/locale/fr/LC_MESSAGES/rawstudio.mo
share/locale/hu/LC_MESSAGES/rawstudio.mo
share/locale/it/LC_MESSAGES/rawstudio.mo
share/locale/ja/LC_MESSAGES/rawstudio.mo
share/locale/nb/LC_MESSAGES/rawstudio.mo
share/locale/nl/LC_MESSAGES/rawstudio.mo
share/locale/pl/LC_MESSAGES/rawstudio.mo
share/locale/pt_BR/LC_MESSAGES/rawstudio.mo
share/locale/ru/LC_MESSAGES/rawstudio.mo
share/locale/sv/LC_MESSAGES/rawstudio.mo
share/pixmaps/rawstudio/camera-photo.png
share/pixmaps/rawstudio/cursor-color-picker.png
share/pixmaps/rawstudio/cursor-crop.png
share/pixmaps/rawstudio/cursor-rotate.png
share/pixmaps/rawstudio/overlay_deleted.png
share/pixmaps/rawstudio/overlay_exported.png
share/pixmaps/rawstudio/overlay_priority1.png
share/pixmaps/rawstudio/overlay_priority2.png
share/pixmaps/rawstudio/overlay_priority3.png
share/pixmaps/rawstudio/tool-color-picker.png
share/pixmaps/rawstudio/tool-crop.png
share/pixmaps/rawstudio/tool-rotate.png
share/pixmaps/rawstudio/transform_180.png
share/pixmaps/rawstudio/transform_270.png
share/pixmaps/rawstudio/transform_90.png
share/pixmaps/rawstudio/transform_flip.png
share/pixmaps/rawstudio/transform_mirror.png
share/rawspeed/cameras.xml
%%DATADIR%%/lens_fix.xml
%%DATADIR%%/plugins/cache.a
%%DATADIR%%/plugins/cache.so
%%DATADIR%%/plugins/colorspace_adobergb.a
%%DATADIR%%/plugins/colorspace_adobergb.so
%%DATADIR%%/plugins/colorspace_prophoto.a
%%DATADIR%%/plugins/colorspace_prophoto.so
%%DATADIR%%/plugins/colorspace_srgb.a
%%DATADIR%%/plugins/colorspace_srgb.so
%%DATADIR%%/plugins/colorspace_transform.a
%%DATADIR%%/plugins/colorspace_transform.so
%%DATADIR%%/plugins/crop.a
%%DATADIR%%/plugins/crop.so
%%DATADIR%%/plugins/dcp.a
%%DATADIR%%/plugins/dcp.so
%%DATADIR%%/plugins/demosaic.a
%%DATADIR%%/plugins/demosaic.so
%%DATADIR%%/plugins/denoise.a
%%DATADIR%%/plugins/denoise.so
%%DATADIR%%/plugins/exposure_mask.a
%%DATADIR%%/plugins/exposure_mask.so
%%DATADIR%%/plugins/facebook-logo.svg
%%DATADIR%%/plugins/flickr-logo.svg
%%DATADIR%%/plugins/fuji_rotate.a
%%DATADIR%%/plugins/fuji_rotate.so
%%DATADIR%%/plugins/input_file.a
%%DATADIR%%/plugins/input_file.so
%%DATADIR%%/plugins/input_image16.a
%%DATADIR%%/plugins/input_image16.so
%%DATADIR%%/plugins/lensfun.a
%%DATADIR%%/plugins/lensfun.so
%%DATADIR%%/plugins/load_dcraw.a
%%DATADIR%%/plugins/load_dcraw.so
%%DATADIR%%/plugins/load_gdk.a
%%DATADIR%%/plugins/load_gdk.so
%%DATADIR%%/plugins/load_rawspeed.a
%%DATADIR%%/plugins/load_rawspeed.so
%%DATADIR%%/plugins/meta_ciff.a
%%DATADIR%%/plugins/meta_ciff.so
%%DATADIR%%/plugins/meta_exiv2.a
%%DATADIR%%/plugins/meta_exiv2.so
%%DATADIR%%/plugins/meta_mrw.a
%%DATADIR%%/plugins/meta_mrw.so
%%DATADIR%%/plugins/meta_raf.a
%%DATADIR%%/plugins/meta_raf.so
%%DATADIR%%/plugins/meta_tiff.a
%%DATADIR%%/plugins/meta_tiff.so
%%DATADIR%%/plugins/meta_x3f.a
%%DATADIR%%/plugins/meta_x3f.so
%%DATADIR%%/plugins/output_facebook.a
%%DATADIR%%/plugins/output_facebook.so
%%DATADIR%%/plugins/output_flickr.a
%%DATADIR%%/plugins/output_flickr.so
%%DATADIR%%/plugins/output_jpegfile.a
%%DATADIR%%/plugins/output_jpegfile.so
%%DATADIR%%/plugins/output_picasa.a
%%DATADIR%%/plugins/output_picasa.so
%%DATADIR%%/plugins/output_pngfile.a
%%DATADIR%%/plugins/output_pngfile.so
%%DATADIR%%/plugins/output_tifffile.a
%%DATADIR%%/plugins/output_tifffile.so
%%DATADIR%%/plugins/picasa-logo.svg
%%DATADIR%%/plugins/resample.a
%%DATADIR%%/plugins/resample.so
%%DATADIR%%/plugins/rotate.a
%%DATADIR%%/plugins/rotate.so
%%DATADIR%%/profiles/AGFAPHOTO_DC-833m-simple.dcp
%%DATADIR%%/profiles/Apple_QuickTake-simple.dcp
%%DATADIR%%/profiles/CASIO_EX-S20-simple.dcp
%%DATADIR%%/profiles/CASIO_EX-Z750-simple.dcp
%%DATADIR%%/profiles/CINE-simple.dcp
%%DATADIR%%/profiles/CINE_650-simple.dcp
%%DATADIR%%/profiles/CINE_660-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1DS-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1D_Mark_II-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1D_Mark_III-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1D_Mark_II_N-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1D_Mark_IV-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1Ds_Mark_II-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-1Ds_Mark_III-simple.dcp
%%DATADIR%%/profiles/Canon_EOS-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_1000D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_10D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_1100D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_20D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_20Da-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_300D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_30D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_350D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_400D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_40D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_450D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_500D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_50D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_550D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_5D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_5D_Mark_II-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_600D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_60D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_7D-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_D2000-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_D30-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_D60-simple.dcp
%%DATADIR%%/profiles/Canon_EOS_D6000-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A470-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A5-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A50-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A530-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A610-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A620-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A630-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A640-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A650-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_A720-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G1-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G10-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G11-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G12-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G2-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G3-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G5-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G6-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_G9-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_Pro1-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_Pro70-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_Pro90-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S30-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S3_IS-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S40-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S45-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S50-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S60-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S70-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S90-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_S95-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_SX110_IS-simple.dcp
%%DATADIR%%/profiles/Canon_PowerShot_SX1_IS-simple.dcp
%%DATADIR%%/profiles/Contax_N_Digital-simple.dcp
%%DATADIR%%/profiles/EPSON_R-D1-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_E550-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_E900-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_F7-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_F8-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S100FS-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S20Pro-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S2Pro-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S3Pro-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S5000-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S5100-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S5200-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S5500-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S5600-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S5Pro-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S6-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S6000fd-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S7000-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S9000-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S9100-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S9500-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_FinePix_S9600-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_IS-1-simple.dcp
%%DATADIR%%/profiles/FUJIFILM_IS_Pro-simple.dcp
%%DATADIR%%/profiles/Fuji_HS10-simple.dcp
%%DATADIR%%/profiles/Imacon_Ixpress-simple.dcp
%%DATADIR%%/profiles/KODAK_DCS420-simple.dcp
%%DATADIR%%/profiles/KODAK_DCS460-simple.dcp
%%DATADIR%%/profiles/KODAK_EASYSHARE_Z1015-simple.dcp
%%DATADIR%%/profiles/KODAK_EOSDCS1-simple.dcp
%%DATADIR%%/profiles/KODAK_EOSDCS3B-simple.dcp
%%DATADIR%%/profiles/KODAK_EasyShare_Z980-simple.dcp
%%DATADIR%%/profiles/KODAK_NC2000-simple.dcp
%%DATADIR%%/profiles/KODAK_P712-simple.dcp
%%DATADIR%%/profiles/KODAK_P850-simple.dcp
%%DATADIR%%/profiles/KODAK_P880-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS315C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS330C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS520C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS560C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS620C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS620X-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS660C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS720X-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS760C-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS_Pro_14-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS_Pro_14nx-simple.dcp
%%DATADIR%%/profiles/Kodak_DCS_Pro_SLR-simple.dcp
%%DATADIR%%/profiles/Kodak_ProBack-simple.dcp
%%DATADIR%%/profiles/Kodak_ProBack645-simple.dcp
%%DATADIR%%/profiles/Konica_Minolta_DiMAGE_A2-simple.dcp
%%DATADIR%%/profiles/Konica_Minolta_DiMAGE_A200-simple.dcp
%%DATADIR%%/profiles/Konica_Minolta_Maxxum_5D-simple.dcp
%%DATADIR%%/profiles/Konica_Minolta_Maxxum_7D-simple.dcp
%%DATADIR%%/profiles/Leaf-simple.dcp
%%DATADIR%%/profiles/Leaf_Aptus_54S-simple.dcp
%%DATADIR%%/profiles/Leaf_Aptus_65-simple.dcp
%%DATADIR%%/profiles/Leaf_Aptus_75-simple.dcp
%%DATADIR%%/profiles/Leaf_CMost-simple.dcp
%%DATADIR%%/profiles/Leaf_Valeo_6-simple.dcp
%%DATADIR%%/profiles/Leica-M8-simple.dcp
%%DATADIR%%/profiles/Leica-S2-simple.dcp
%%DATADIR%%/profiles/Leica-X1-native.dcp
%%DATADIR%%/profiles/MINOLTA_DYNAX_5-simple.dcp
%%DATADIR%%/profiles/MINOLTA_DYNAX_7-simple.dcp
%%DATADIR%%/profiles/MOTOROLA_PIXL-simple.dcp
%%DATADIR%%/profiles/Mamiya_ZD-simple.dcp
%%DATADIR%%/profiles/Micron_2010-simple.dcp
%%DATADIR%%/profiles/Minolta_DiMAGE_5-simple.dcp
%%DATADIR%%/profiles/Minolta_DiMAGE_7-simple.dcp
%%DATADIR%%/profiles/Minolta_DiMAGE_7Hi-simple.dcp
%%DATADIR%%/profiles/Minolta_DiMAGE_7i-simple.dcp
%%DATADIR%%/profiles/Minolta_DiMAGE_A1-simple.dcp
%%DATADIR%%/profiles/Minolta_DiMAGE_Z2-simple.dcp
%%DATADIR%%/profiles/NIKON_COOLPIX_P6000-simple.dcp
%%DATADIR%%/profiles/NIKON_COOLPIX_P7000-simple.dcp
%%DATADIR%%/profiles/NIKON_D1-simple.dcp
%%DATADIR%%/profiles/NIKON_D100-simple.dcp
%%DATADIR%%/profiles/NIKON_D1H-simple.dcp
%%DATADIR%%/profiles/NIKON_D1X-simple.dcp
%%DATADIR%%/profiles/NIKON_D200-simple.dcp
%%DATADIR%%/profiles/NIKON_D2H-simple.dcp
%%DATADIR%%/profiles/NIKON_D2X-simple.dcp
%%DATADIR%%/profiles/NIKON_D3-simple.dcp
%%DATADIR%%/profiles/NIKON_D300-simple.dcp
%%DATADIR%%/profiles/NIKON_D3000-simple.dcp
%%DATADIR%%/profiles/NIKON_D3100-simple.dcp
%%DATADIR%%/profiles/NIKON_D3S-simple.dcp
%%DATADIR%%/profiles/NIKON_D3X-simple.dcp
%%DATADIR%%/profiles/NIKON_D40-simple.dcp
%%DATADIR%%/profiles/NIKON_D40X-simple.dcp
%%DATADIR%%/profiles/NIKON_D50-simple.dcp
%%DATADIR%%/profiles/NIKON_D5000-simple.dcp
%%DATADIR%%/profiles/NIKON_D60-simple.dcp
%%DATADIR%%/profiles/NIKON_D70-simple.dcp
%%DATADIR%%/profiles/NIKON_D700-simple.dcp
%%DATADIR%%/profiles/NIKON_D7000-simple.dcp
%%DATADIR%%/profiles/NIKON_D70s-simple.dcp
%%DATADIR%%/profiles/NIKON_D80-simple.dcp
%%DATADIR%%/profiles/NIKON_D90-simple.dcp
%%DATADIR%%/profiles/NIKON_E2100-simple.dcp
%%DATADIR%%/profiles/NIKON_E2500-simple.dcp
%%DATADIR%%/profiles/NIKON_E4300-simple.dcp
%%DATADIR%%/profiles/NIKON_E4500-simple.dcp
%%DATADIR%%/profiles/NIKON_E5000-simple.dcp
%%DATADIR%%/profiles/NIKON_E5400-simple.dcp
%%DATADIR%%/profiles/NIKON_E5700-simple.dcp
%%DATADIR%%/profiles/NIKON_E8400-simple.dcp
%%DATADIR%%/profiles/NIKON_E8700-simple.dcp
%%DATADIR%%/profiles/NIKON_E8800-simple.dcp
%%DATADIR%%/profiles/NIKON_E950-simple.dcp
%%DATADIR%%/profiles/NIKON_E995-simple.dcp
%%DATADIR%%/profiles/Neutral-With-Tonecurve-AdobeRGB.dcp
%%DATADIR%%/profiles/Neutral-With-Tonecurve-Prophoto.dcp
%%DATADIR%%/profiles/Neutral-With-Tonecurve-sRGB.dcp
%%DATADIR%%/profiles/OLYMPUS_C5050-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_C5060-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_C70-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_C7070-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_C80-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-1-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-10-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-20-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-3-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-30-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-300-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-330-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-400-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-410-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-420-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-450-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-5-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-500-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-510-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-520-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-620-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-P1-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-PL1-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-PL1s-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_E-PL2-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP3-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP350-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP500UZ-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP510UZ-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP550UZ-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP560UZ-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_SP570UZ-simple.dcp
%%DATADIR%%/profiles/OLYMPUS_XZ-1-simple.dcp
%%DATADIR%%/profiles/PENTAX_645D-simple.dcp
%%DATADIR%%/profiles/PENTAX_K-5-simple.dcp
%%DATADIR%%/profiles/PENTAX_K-7-simple.dcp
%%DATADIR%%/profiles/PENTAX_K-m-simple.dcp
%%DATADIR%%/profiles/PENTAX_K-r-simple.dcp
%%DATADIR%%/profiles/PENTAX_K-x-simple.dcp
%%DATADIR%%/profiles/PENTAX_K1-simple.dcp
%%DATADIR%%/profiles/PENTAX_K10D-simple.dcp
%%DATADIR%%/profiles/PENTAX_K2000-simple.dcp
%%DATADIR%%/profiles/PENTAX_K200D-simple.dcp
%%DATADIR%%/profiles/PENTAX_K20D-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FX150-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FZ18-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FZ28-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FZ30-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FZ35-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FZ50-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-FZ8-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-G1-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-G10-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-G2-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-GF1-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-GF2-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-GH1-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-GH2-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-L1-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-L10-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-LC1-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-LX1-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-LX2-simple.dcp
%%DATADIR%%/profiles/Panasonic_DMC-LX3-simple.dcp
%%DATADIR%%/profiles/Panasonic_FZ100-simple.dcp
%%DATADIR%%/profiles/Panasonic_FZ40-simple.dcp
%%DATADIR%%/profiles/Panasonic_LX5-simple.dcp
%%DATADIR%%/profiles/Phase_One_H_20-simple.dcp
%%DATADIR%%/profiles/Phase_One_P65-simple.dcp
%%DATADIR%%/profiles/Phase_One_P_2-simple.dcp
%%DATADIR%%/profiles/Phase_One_P_30-simple.dcp
%%DATADIR%%/profiles/Phase_One_P_45-simple.dcp
%%DATADIR%%/profiles/Ricoh_A12_28mm-simple.dcp
%%DATADIR%%/profiles/Ricoh_A12_50mm-simple.dcp
%%DATADIR%%/profiles/Ricoh_Digital_3-simple.dcp
%%DATADIR%%/profiles/Ricoh_GX200-simple.dcp
%%DATADIR%%/profiles/Ricoh_S10_24-72mm-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_EX1-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_GX-1-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_GX-1L-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_GX-1S-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_GX10-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_GX20-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_NX10-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_NX100-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_NX11-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_NX5-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_S85-simple.dcp
%%DATADIR%%/profiles/SAMSUNG_WB2000-simple.dcp
%%DATADIR%%/profiles/SONY_DSC-F828-simple.dcp
%%DATADIR%%/profiles/SONY_DSC-R1-simple.dcp
%%DATADIR%%/profiles/SONY_DSC-V3-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A100-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A200-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A230-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A290-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A300-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A330-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A350-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A380-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A390-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A450-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A5-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A500-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A550-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A560-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A580-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A700-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A850-simple.dcp
%%DATADIR%%/profiles/SONY_DSLR-A900-simple.dcp
%%DATADIR%%/profiles/SONY_NEX-3-simple.dcp
%%DATADIR%%/profiles/SONY_NEX-5-simple.dcp
%%DATADIR%%/profiles/SONY_SLTA33-simple.dcp
%%DATADIR%%/profiles/SONY_SLTA55V-simple.dcp
%%DATADIR%%/profiles/Sinar-simple.dcp
%%DATADIR%%/profiles/compatibleWithAdobeRGB1998-linear.icc
%%DATADIR%%/profiles/compatibleWithAdobeRGB1998.icc
%%DATADIR%%/profiles/generic_camera_profile.icc
%%DATADIR%%/profiles/prophoto-linear.icc
%%DATADIR%%/profiles/prophoto.icc
%%DATADIR%%/profiles/rawstudio-cameras.xml
%%DATADIR%%/profiles/sRGB-linear.icc
%%DATADIR%%/profiles/sRGB.icc
%%DATADIR%%/rawstudio.gtkrc
%%DATADIR%%/ui.xml