mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
x11-toolkits/pangomm: update to 2.46.4
Converted to meson and removed REFERENCE_PORT vestiges. PORTSCOUT limited to the 2.46 series as 2.48 and later have an incompatible API intended for GTK4 consumers. Changelog: https://gitlab.gnome.org/GNOME/pangomm/-/blob/2.46.4/NEWS Reviewed by: tcberner, arrowd Differential Revision: https://reviews.freebsd.org/D33940
This commit is contained in:
parent
611436a53f
commit
92a9f9d9b5
4 changed files with 24 additions and 53 deletions
|
@ -1,42 +1,25 @@
|
|||
PORTNAME= pangomm
|
||||
PORTVERSION= 2.40.1
|
||||
PORTREVISION?= 6
|
||||
PORTVERSION= 2.46.4
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= GNOME
|
||||
DIST_SUBDIR= gnome2
|
||||
DIST_SUBDIR= gnome
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= C++ wrapper for Pango
|
||||
WWW= http://gtkmm.sourceforge.net/
|
||||
WWW= https://www.gtkmm.org/
|
||||
|
||||
LICENSE= LGPL21
|
||||
|
||||
USES= tar:xz
|
||||
|
||||
.if !defined(REFERENCE_PORT)
|
||||
PORTSCOUT= limitw:1,even
|
||||
|
||||
USES+= compiler:c++11-lang gmake gnome libtool localbase pathfix \
|
||||
pkgconfig
|
||||
USE_CXXSTD= c++11
|
||||
USES= compiler:c++11-lang gnome localbase meson pkgconfig \
|
||||
python:build tar:xz
|
||||
USE_GNOME= cairomm glibmm pango
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --disable-documentation \
|
||||
--enable-static=yes
|
||||
INSTALL_TARGET= install-strip
|
||||
BINARY_WRAPPERS= gm4
|
||||
MESON_ARGS= -Ddefault_library=both
|
||||
BINARY_ALIAS= python3=${PYTHON_CMD}
|
||||
|
||||
PLIST_SUB= VERSION="2.4" API_VERSION="1.4"
|
||||
|
||||
post-patch:
|
||||
.for d in tests
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/${d}//' \
|
||||
${WRKSRC}/Makefile.in
|
||||
.endfor
|
||||
# 2.48 and later are incompatible
|
||||
PORTSCOUT= limit:^2\.46
|
||||
PLIST_SUB= API_VERSION=1.4
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
||||
.else
|
||||
PORTSCOUT= ignore:1
|
||||
.endif
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1491167697
|
||||
SHA256 (gnome2/pangomm-2.40.1.tar.xz) = 9762ee2a2d5781be6797448d4dd2383ce14907159b30bc12bf6b08e7227be3af
|
||||
SIZE (gnome2/pangomm-2.40.1.tar.xz) = 810384
|
||||
TIMESTAMP = 1733426036
|
||||
SHA256 (gnome/pangomm-2.46.4.tar.xz) = b92016661526424de4b9377f1512f59781f41fb16c9c0267d6133ba1cd68db22
|
||||
SIZE (gnome/pangomm-2.46.4.tar.xz) = 695088
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
https://gitlab.gnome.org/GNOME/pangomm/-/commit/a8ab02ac9b96
|
||||
https://gitlab.gnome.org/GNOME/pangomm/-/commit/c098f35144ff
|
||||
|
||||
attrlist.cc:38:20: error: use of undeclared identifier 'pango_parse_markup'
|
||||
gboolean bTest = pango_parse_markup(markup_text.c_str(), -1 /* means null-terminated */, accel_marker,
|
||||
^
|
||||
attrlist.cc:65:20: error: use of undeclared identifier 'pango_parse_markup'
|
||||
gboolean bTest = pango_parse_markup(markup_text.c_str(), -1 /* means null-terminated */, accel_marker,
|
||||
^
|
||||
|
||||
--- pango/pangomm/attributes.h.orig 2016-08-19 13:58:37 UTC
|
||||
+++ pango/pangomm/attributes.h
|
||||
@@ -30,6 +30,9 @@
|
||||
#include <pangomm/color.h>
|
||||
#include <pangomm/fontdescription.h>
|
||||
#include <pango/pango-attributes.h>
|
||||
+#if __has_include(<pango/pango-markup.h>)
|
||||
+#include <pango/pango-markup.h>
|
||||
+#endif
|
||||
#include <glibmm/slisthandle.h>
|
||||
|
||||
|
|
@ -0,0 +1,10 @@
|
|||
--- tools/extra_defs_gen/meson.build.orig 2021-12-06 18:18:10 UTC
|
||||
+++ tools/extra_defs_gen/meson.build
|
||||
@@ -7,6 +7,7 @@
|
||||
glibmm_generate_extra_defs_dep = cpp_compiler.find_library(
|
||||
'glibmm_generate_extra_defs@0@-2.68'.format(msvc14x_toolset_ver),
|
||||
required: glibmm_dep.type_name() != 'internal',
|
||||
+ dirs: join_paths(get_option('prefix'), get_option('libdir')),
|
||||
)
|
||||
if not glibmm_generate_extra_defs_dep.found()
|
||||
glibmm_generate_extra_defs_dep = dependency(
|
Loading…
Add table
Reference in a new issue