- Follow PECL ports naming conversion

This commit is contained in:
Yen-Ming Lee 2006-11-01 15:36:55 +00:00
parent c5117ae602
commit 90f8e43c39
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176096
7 changed files with 2 additions and 102 deletions

2
MOVED
View file

@ -2512,3 +2512,5 @@ x11-themes/e17-theme-mclaren||2006-11-01|Has expired: doesn't work with recent e
x11-themes/e17-theme-grey||2006-11-01|Has expired: doesn't work with recent e17
devel/ac-archive|devel/autoconf-archive|2006-11-01|Replace broken ac-archive with working autoconf-archive
www/firefox-devel|www/firefox|2006-11-01|Firefox 2.0 is now stable
graphics/php4-imlib2|graphics/pecl-imlib2|2006-11-01|Follow PECL ports naming conversion
graphics/php5-imlib2|graphics/pecl-imlib2|2006-11-01|Follow PECL ports naming conversion

View file

@ -499,11 +499,9 @@
SUBDIR += php-magickwand
SUBDIR += php4-exif
SUBDIR += php4-gd
SUBDIR += php4-imlib2
SUBDIR += php4-ming
SUBDIR += php5-exif
SUBDIR += php5-gd
SUBDIR += php5-imlib2
SUBDIR += php5-ming
SUBDIR += phplot
SUBDIR += phpsview

View file

@ -1,16 +0,0 @@
# New ports collection makefile for: php5-imlib2
# Date created: 18 September 2006
# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= graphics
PKGNAMEPREFIX= php4-
MASTERDIR= ${.CURDIR}/../../graphics/php5-imlib2
IGNORE_WITH_PHP=5
DEFAULT_PHP_VER=4
.include "${MASTERDIR}/Makefile"

View file

@ -1,33 +0,0 @@
# New ports collection makefile for: php5-imlib2
# Date created: 18 September 2006
# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= imlib2
PORTVERSION= 0.1.00
CATEGORIES= graphics
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX?= php5-
EXTRACT_SUFX= .tgz
MAINTAINER= leeym@FreeBSD.org
COMMENT= The imlib2 shared extension for php
LIB_DEPENDS= Imlib2:${PORTSDIR}/graphics/imlib2
USE_PHP= yes
USE_PHPEXT= yes
IGNORE_WITH_PHP?=4
DEFAULT_PHP_VER?=5
# libImlib2 may or may not depend on X, however,
# imlib2 extension doesn't need X related functions in libImlib2
CFLAGS+= -DX_DISPLAY_MISSING
post-patch:
@${REINPLACE_CMD} -e 's/-ldl//' ${WRKSRC}/config.m4
@${REINPLACE_CMD} -e '/Xlib.h/d' ${WRKSRC}/php_imlib2.h
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (imlib2-0.1.00.tgz) = 8bc2d64a7f8897e914f1e1b1f8e7b554
SHA256 (imlib2-0.1.00.tgz) = 4506ac1bdefdb5d0eb1f4e16080010463ffcc48c4fec4119717f769858dc6cd2
SIZE (imlib2-0.1.00.tgz) = 15536

View file

@ -1,43 +0,0 @@
--- imlib2.c.orig Wed Sep 20 10:05:27 2006
+++ imlib2.c Wed Sep 20 10:06:15 2006
@@ -643,8 +643,8 @@
zval **img, **gamma;
Imlib_Image im;
Imlib_Color_Modifier cm;
- IMLIB2_LS_FETCH();
double ng;
+ IMLIB2_LS_FETCH();
if (ZEND_NUM_ARGS() != 2 | zend_get_parameters_ex(2, &img, &gamma) == FAILURE) {
WRONG_PARAM_COUNT;
@@ -675,8 +675,8 @@
zval **img, **contrast;
Imlib_Image im;
Imlib_Color_Modifier cm;
- IMLIB2_LS_FETCH();
double nc;
+ IMLIB2_LS_FETCH();
if (ZEND_NUM_ARGS() != 2 | zend_get_parameters_ex(2, &img, &contrast) == FAILURE) {
WRONG_PARAM_COUNT;
@@ -707,8 +707,8 @@
zval **img, **bv;
Imlib_Image im;
Imlib_Color_Modifier cm;
- IMLIB2_LS_FETCH();
double nbv;
+ IMLIB2_LS_FETCH();
if (ZEND_NUM_ARGS() != 2 | zend_get_parameters_ex(2, &img, &bv) == FAILURE) {
WRONG_PARAM_COUNT;
@@ -760,9 +760,9 @@
{
zval **img, **angle;
double rot_angle, rads, pi;
- pi = 3.141592653;
Imlib_Image src_img, dst_img;
IMLIB2_LS_FETCH();
+ pi = 3.141592653;
if((ZEND_NUM_ARGS() != 2) || zend_get_parameters_ex(2, &img, &angle) == FAILURE) {
WRONG_PARAM_COUNT;

View file

@ -1,5 +0,0 @@
This extension provides an image manipulation interface using libImlib2.
Imlib2 is a very fast image manipulation library, but without the support
for as many image formats as other libraries such as imagemagick.
WWW: http://pecl.php.net/package/imlib2