mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
graphics/lux: fix build on i386
Use int over unsigned int for fc_t to avoid a type narrowing error. Regenerate patches while we are at it. MFH: 2024Q4
This commit is contained in:
parent
6ea6f50dc5
commit
905958dd6f
5 changed files with 25 additions and 14 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= lux
|
||||
DISTVERSION= 1.2.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://bitbucket.org/kfj/pv/get/
|
||||
PKGNAMESUFFIX= -pv # distinguish from www/lux
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2023-02-09 16:33:06 UTC
|
||||
--- CMakeLists.txt.orig 2024-04-22 10:18:21 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -139,8 +139,8 @@ message(STATUS "***** => LUX DATA DIRECTORY ${DataDir}
|
||||
@@ -140,8 +140,8 @@ if ( ${CMAKE_SYSTEM_PROCESSOR} STREQUAL x86_64
|
||||
message(STATUS "***** SYSTEM PROCESSOR ${CMAKE_SYSTEM_PROCESSOR}")
|
||||
|
||||
if ( ${CMAKE_SYSTEM_PROCESSOR} STREQUAL x86_64
|
||||
|
@ -11,7 +11,7 @@
|
|||
set(i86 TRUE)
|
||||
message(STATUS "***** setting i86 TRUE for an intel/AMD target")
|
||||
else()
|
||||
@@ -351,7 +351,7 @@ set(AVX2_FLAGS "${RENDERING_FLAGS} \
|
||||
@@ -383,7 +383,7 @@ set(AVX512f_FLAGS "${RENDERING_FLAGS} \
|
||||
# about it and I don't have an AVX512 machine.
|
||||
|
||||
set(AVX512f_FLAGS "${RENDERING_FLAGS} \
|
||||
|
@ -20,16 +20,16 @@
|
|||
-D hn=hn_avx512 -D PV_ARCH=PV_AVX512f \
|
||||
-D PV_ARCHNAME=\\\"avx512f\\\" \
|
||||
-D PV_PRIORITY=0 -D PV_VIABILITY=has_avx512f -D FLV_AVX512f")
|
||||
@@ -651,12 +651,6 @@ endif()
|
||||
@@ -727,12 +727,6 @@ install(TARGETS ${_project_name} DESTINATION bin)
|
||||
# install the binary
|
||||
|
||||
install(TARGETS ${_project_name} DESTINATION bin)
|
||||
|
||||
-
|
||||
-# Copy the NotoSans-Regular font and the readme (as required by the license)
|
||||
-# to the platform-specific font directory
|
||||
-
|
||||
-install(FILES NotoSans-Regular.ttf noto_font_license.txt DESTINATION
|
||||
- "${DataDir}/fonts")
|
||||
-
|
||||
|
||||
# The next section could do with sone tidying up. It deals with packaging
|
||||
# lux for distribution. This is used for some distribution channles, e.g.
|
||||
# to make .deb packages for ubuntu and debian, but packaging for windows
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- options.h.orig 2022-08-27 02:26:10 UTC
|
||||
--- options.h.orig 2024-04-22 10:18:21 UTC
|
||||
+++ options.h
|
||||
@@ -132,7 +132,7 @@ yes_no ( fullscreen , true )
|
||||
@@ -136,7 +136,7 @@ yes_no ( grey_edge , true )
|
||||
yes_no ( fully_covered , false )
|
||||
yes_no ( fuse , false )
|
||||
yes_no ( grey_edge , true )
|
||||
|
@ -8,4 +8,4 @@
|
|||
+option ( gui_font , "%%GUIFONT%%" )
|
||||
integer ( gui_extent , 0 )
|
||||
real ( gui_scale_factor , 0.0 )
|
||||
yes_no ( hdr_merge , false )
|
||||
yes_no ( gpu_for_srgb , false )
|
||||
|
|
11
graphics/lux/files/patch-pv__rendering__common.h
Normal file
11
graphics/lux/files/patch-pv__rendering__common.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pv_rendering_common.h.orig 2024-10-14 12:36:31 UTC
|
||||
+++ pv_rendering_common.h
|
||||
@@ -194,7 +194,7 @@ static const int max_degree = 7 ; // vspline_constants
|
||||
|
||||
// typedef unsigned short fc_t ;
|
||||
|
||||
-typedef unsigned int fc_t ;
|
||||
+typedef int fc_t ;
|
||||
|
||||
#ifdef VECTORIZE
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
--- tinyfiledialogs.c.orig 2022-03-08 00:31:39 UTC
|
||||
--- tinyfiledialogs.c.orig 2024-10-14 12:36:00 UTC
|
||||
+++ tinyfiledialogs.c
|
||||
@@ -47,13 +47,6 @@ Thanks for contributions, bug corrections & thorough t
|
||||
- Paul Rouget
|
||||
@@ -53,13 +53,6 @@ misrepresented as being the original software.
|
||||
|__________________________________________|
|
||||
*/
|
||||
|
||||
-
|
||||
|
|
Loading…
Add table
Reference in a new issue