mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
misc/getopt: Use util-linux repo as upstream
- Unmark DEPRECATED and remove EXPIRATION_DATE - Bump PORTREVISION for package change Changes: https://github.com/util-linux/util-linux/commits/master/misc-utils/getopt.c https://github.com/util-linux/util-linux/commits/master/misc-utils/getopt.1.adoc
This commit is contained in:
parent
4ddfd281f8
commit
8cef01d3b3
6 changed files with 55 additions and 102 deletions
|
@ -1,38 +1,32 @@
|
|||
PORTNAME= getopt
|
||||
PORTVERSION= 1.1.6
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://frodo.looijaard.name/system/files/software/getopt/ \
|
||||
LOCAL/sunpoet
|
||||
MASTER_SITES= KERNEL_ORG/linux/utils/util-linux/v${UTIL_LINUX_PORTVERSION:R}/
|
||||
DISTNAME= util-linux-${UTIL_LINUX_PORTVERSION}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Replacement for getopt(1) that supports GNU-style long options
|
||||
WWW= https://software.frodo.looijaard.name/getopt/
|
||||
WWW= https://github.com/util-linux/util-linux
|
||||
|
||||
LICENSE= GPLv2 GPLv3
|
||||
LICENSE_COMB= dual
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
DEPRECATED= Use getopt from devel/util-linux instead
|
||||
EXPIRATION_DATE=2024-10-31
|
||||
USES= gmake pkgconfig shebangfix tar:xz
|
||||
|
||||
OPTIONS_DEFINE= DOCS NLS
|
||||
OPTIONS_SUB= yes
|
||||
CONFIGURE_ARGS= --disable-asciidoc \
|
||||
--disable-all-programs \
|
||||
--disable-gtk-doc \
|
||||
--disable-nls \
|
||||
--disable-makeinstall-chown \
|
||||
--disable-makeinstall-setuid \
|
||||
--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAKE_ARGS= CC=${CC} LIBCGETOPT=0
|
||||
USES= gmake
|
||||
SHEBANG_FILES= misc-utils/getopt-example.bash
|
||||
|
||||
PORTDOCS= Changelog README
|
||||
UTIL_LINUX_PORTVERSION= 2.39.4
|
||||
|
||||
NLS_MAKE_ARGS= WITHOUT_GETTEXT=0
|
||||
NLS_MAKE_ARGS_OFF= WITHOUT_GETTEXT=1
|
||||
NLS_LDFLAGS= -lintl
|
||||
NLS_USES= gettext localbase:ldflags
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/getopt
|
||||
|
||||
post-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}/
|
||||
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1730633654
|
||||
SHA256 (getopt-1.1.6.tar.gz) = d0bf1dc642a993e7388a1cddfb9409bed375c21d5278056ccca3a0acd09dc5fe
|
||||
SIZE (getopt-1.1.6.tar.gz) = 58926
|
||||
TIMESTAMP = 1714112744
|
||||
SHA256 (util-linux-2.39.4.tar.xz) = 6c4f8723dafd41c39d93ecbf16509fc88c33cd5bd3277880ae5a1d97a014fd0e
|
||||
SIZE (util-linux-2.39.4.tar.xz) = 8541176
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
--- Makefile.orig 2014-11-24 12:33:39 UTC
|
||||
+++ Makefile
|
||||
@@ -1,9 +1,9 @@ DESTDIR=
|
||||
.SUFFIXES:
|
||||
|
||||
DESTDIR=
|
||||
-prefix=/usr/local
|
||||
+prefix=$(PREFIX)
|
||||
bindir=$(prefix)/bin
|
||||
-mandir=$(prefix)/man
|
||||
+mandir=$(prefix)/share/man
|
||||
man1dir=$(mandir)/man1
|
||||
sharedir=$(prefix)/share
|
||||
getoptdir=$(sharedir)/getopt
|
||||
@@ -32,18 +32,15 @@ MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
|
||||
LANGUAGES = ca cs da de es et eu fi fr gl hr hu id it ja nl pl pt_BR ru sl sv tr uk vi zh_CN zh_TW
|
||||
MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
|
||||
|
||||
-CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)\" -Dprogram_version=\"$(VERSION)\"
|
||||
+CPPFLAGS+=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)\" -Dprogram_version=\"$(VERSION)\"
|
||||
ifeq ($(LIBCGETOPT),0)
|
||||
-CPPFLAGS+=-I./gnu
|
||||
+CPPFLAGS+=-I./gnu
|
||||
endif
|
||||
WARNINGS=-Wall \
|
||||
-W -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual \
|
||||
-Wcast-align -Wmissing-declarations \
|
||||
-Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
|
||||
-Wnested-externs -Winline
|
||||
-OPTIMIZE=-O3 -fno-strength-reduce
|
||||
-CFLAGS=$(WARNINGS) $(OPTIMIZE)
|
||||
-LDFLAGS=
|
||||
|
||||
sources=getopt.c
|
||||
ifeq ($(LIBCGETOPT),0)
|
||||
@@ -54,11 +51,11 @@ binaries=getopt
|
||||
|
||||
binaries=getopt
|
||||
|
||||
-.PHONY: all clean realclean
|
||||
+.PHONY: all clean realclean
|
||||
all: $(binaries) all_po
|
||||
|
||||
clean: clean_po
|
||||
- -$(RM) $(objects) $(binaries)
|
||||
+ -$(RM) $(objects) $(binaries)
|
||||
|
||||
getopt: $(objects)
|
||||
$(CC) $(LDFLAGS) -o $@ $(objects)
|
20
misc/getopt/files/patch-Makefile.in
Normal file
20
misc/getopt/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Makefile.in.orig 2024-04-04 09:13:52 UTC
|
||||
+++ Makefile.in
|
||||
@@ -5335,7 +5335,7 @@ ADOCFILES_COMMON = man-common/bugreports.adoc man-comm
|
||||
man-common/footer-lib.adoc man-common/help-version.adoc \
|
||||
man-common/in-bytes.adoc man-common/manpage-stub.adoc \
|
||||
man-common/translation.adoc
|
||||
-MANPAGES = lib/terminal-colors.d.5 $(am__append_20) $(am__append_44) \
|
||||
+MANPAGES = $(am__append_20) $(am__append_44) \
|
||||
$(am__append_91) $(am__append_94) $(am__append_97) \
|
||||
$(am__append_100) $(am__append_103) $(am__append_106) \
|
||||
$(am__append_109) $(am__append_112) $(am__append_115) \
|
||||
@@ -5436,7 +5436,7 @@ CLEANFILES = $(am__append_336) $(PATHFILES) $(EXTRA_LT
|
||||
disk-utils/meson.build login-utils/meson.build \
|
||||
$(PATHFILES:=.in) $(am__append_667) $(am__append_670)
|
||||
CLEANFILES = $(am__append_336) $(PATHFILES) $(EXTRA_LTLIBRARIES)
|
||||
-SUBDIRS = po $(am__append_3) $(am__append_41) $(am__append_63) \
|
||||
+SUBDIRS = $(am__append_3) $(am__append_41) $(am__append_63) \
|
||||
$(am__append_73) $(am__append_87)
|
||||
RCS_FIND_IGNORE = \( -name SCCS -o -name BitKeeper -o -name .svn -o \
|
||||
-name CVS -o -name .pc -o -name .hg -o -name .git \) -prune -o
|
11
misc/getopt/files/patch-configure
Normal file
11
misc/getopt/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig 2024-04-04 09:13:50 UTC
|
||||
+++ configure
|
||||
@@ -35861,7 +35861,7 @@ fi
|
||||
enable_getopt=$ul_default_estate
|
||||
build_getopt=yes
|
||||
if test "x$ul_default_estate" = xno; then
|
||||
- build_getopt=no
|
||||
+ build_getopt=yes
|
||||
fi
|
||||
else
|
||||
|
|
@ -1,28 +1,5 @@
|
|||
bin/getopt
|
||||
%%NLS%%share/locale/ca/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/cs/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/da/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/et/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/eu/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/fi/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/gl/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/hr/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/hu/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/id/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/it/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/ja/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/nl/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/pl/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/pt_BR/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/sl/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/sv/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/tr/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/uk/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/vi/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/getopt.mo
|
||||
%%NLS%%share/locale/zh_TW/LC_MESSAGES/getopt.mo
|
||||
share/bash-completion/completions/getopt
|
||||
%%PORTDOCS%%share/doc/util-linux/getopt-example.bash
|
||||
%%PORTDOCS%%share/doc/util-linux/getopt-example.tcsh
|
||||
share/man/man1/getopt.1.gz
|
||||
|
|
Loading…
Add table
Reference in a new issue